Welcome! Log In Create A New Profile



Posted by ataraxia00 
January 04, 2012 08:10PM
Fixed, turns out it fixed itself when I reloaded the firmware. I am assuming it was a problem during the uploading process.

Edited 3 time(s). Last edit at 02/13/2012 12:24AM by ataraxia00.
Re: Z-Axis/Pronterface Problems
January 05, 2012 02:10AM
Hi Ataraxia00,

It sounds to me like your Z endstop connection may be the problem.
I don't know what kind you have but they may need to be checked at the point where they plug into the Ramps board.

You may have one of the wires in the the3 pin connector reversed.
Green where brown should be for example.

Just a thought.
Re: Z-Axis/Pronterface Problems
January 05, 2012 03:35AM
All the connections look good to me, and like I said in my first post, everything worked previously but then I updated to marlin and started using a new computer and the Z-axis won't work. Naturally I'm assuming it's a software problem.
Re: Z-Axis/Pronterface Problems
January 09, 2012 09:59AM
It may well be a problem with the z-axis speed. If you try to move it too fast it may not work at all.

Did you fix it?

Re: Z-Axis/Pronterface Problems
January 09, 2012 05:11PM
The baud default for the Marlin firmware set in config is much higher than other firmware and you must match it to the baud setting in Pronterface.

Funky things happen when the baud settings do not match, but mismatch typically impacts more than just z-axis issues.

On the other hand, Pronterface crashing/becoming non-responsive reflects it may be something on the config/software side rather than mechanical.

Edited 1 time(s). Last edit at 01/09/2012 05:12PM by thewaterengine.
Re: Z-Axis/Pronterface Problems
January 09, 2012 05:25PM
Not the speed, and I haven't fixed it yet

Not the baud. I'm reloading sprinter today with the old settings to verify it's software over mechanical today.
Re: Z-Axis/Pronterface Problems
February 06, 2012 01:41AM
Hi Ataraxia,

I finished building a prusa mendel a week ago (RAMPS 1.4 electronics, sprinter firmware, pronterface) and experienced the same issue when I tried to upgrade to marlin v1.0 beta firmware today. I altered the default settings for the baud rate, end stop inversion, axis steps, etc. to match the settings in my successfully configured sprinter and everything worked except the z axis wouldn't move and then the RAMPS wouldn't respond. I fiddled with min feed rate and z axis speed and acceleration without success. When I reloaded the sprinter firmware, everything worked again. Then I tried the previous version of marlin (the non gen 6 version) and this did the trick! It is now printing great and I definitely notice better performance vs sprinter. If you want to figure out how to get marlin v1 beta working, I'd start by looking for differences between v1 beta and the previous non gen6 version. But just using the older version has a good chance of fixing the issue.
Re: Z-Axis/Pronterface Problems
May 25, 2012 01:29AM
I have a problem with the Z axis homing. I get 2 different points.
In one mode the z motors drive down till the homing switch is made then reverses till the switch opens.
In the other mode the z motors drive down till the homing switch is made then reverses till the switch opens then slowly moves back down till the switch is made again.
There seems to be no rhyme or reason as to which homing I get but there is about 1mm between the two (my limit switch hysteresis).

More information.
If I press the switch manualy and hold mode one happens.
If I press the swich and let go quickly the other mode happens.
I am just on the edge of this time does anyone know how to change the swap-over point so I home usig one mode or the other?
Aparently my switches are at the sweetspot as far as hysteresis goes to get random results.

Edited 1 time(s). Last edit at 05/25/2012 01:50AM by tag16c.
Re: Z-Axis/Pronterface Problems
October 18, 2012 12:19AM
Thanks for the info (http://forums.reprap.org/read.php?1,112305,117414#msg-117414)

Having exactly this problem with Lincomatics Marlin (https://github.com/lincomatic/Marlin/network (downloaded yesterday)).
Might try an older/other version very soon..
Sorry, only registered users may post in this forum.

Click here to login