Welcome! Log In Create A New Profile


ReplicatorG Machine Drivers

Posted by Skypuppet 
ReplicatorG Machine Drivers
January 26, 2012 05:07AM
I've heard some good things about ReplicatorG, and since I've been dealing with a
nagging fatal pause in Pronterface, I thought I'd give it a try.

I DL'd the latest version (29_r2) and followed instruction on the website, but I'm hitting a wall with "Machine Type(Driver)".

My machine is not in the dialog, so I chose "klimentkip" thinking it may be for various builds.

I had my machine connected, heating, homing, jogging and converted an stl file to gcode, but then had a warning
of some sort when I hit build. I don't remember specifically, but it was something to do with a wrong machine configuration.

I'm running windows vista. My machine has ramps 1.3, arduino mega2560 running sprinter firmware. Anybody out there already running this configuration with RepG?
Re: ReplicatorG Machine Drivers
January 26, 2012 07:03AM
I think this is what you need:
Re: ReplicatorG Machine Drivers
January 26, 2012 07:56PM
Very nice! Thank yousmiling smiley

I downloaded it and replaced the file in the machines folder as specified. At first when I opened RepG I didn't see a difference, but I went back to the folder and relocated all of the other machine types into a new folder. Then when I went back into RepG I could identify a prusa/mendel machine type.

Unfortunately I was running a part in pronterface, so I didn't attempt to connect. I'll let you know how it works out.

Again, thank you for your help.
Re: ReplicatorG Machine Drivers
January 26, 2012 11:47PM
Please pardon the XL font size. I used it to compete with the images. That said, I grabbed the recommended file from thingiverse and am now generating gcode in RepG. Here's what is now available to me in my Machine Type (Drivers) tab:

I selected the Prusa Mendel as you can see. I don't have high hopes tho, b/c
the defaults are all still geared toward thingomatic printers and mk6 and mk7 extruders.
For instance a default value for the drive gear diameter is 10.58mm.
My wades extruder drive gear is much larger, but do I insert the major or minor diameter?
I'm thinking major (17.65mm).

I was pretty excited to try ReplicatorG, but as a pretty new inductee to the world of reprap, I have to say, it's pretty cryptic. Much help is needed and greatly appreciated winking smiley
Re: ReplicatorG Machine Drivers
January 26, 2012 11:54PM
So here's the same error code as before. Fun. I'm starting to think I'll have to live with Pronter-pause :/

Re: ReplicatorG Machine Drivers
January 27, 2012 07:30AM
And this is a good example of why you post the error message in the first place. M113 is a deprecated code used to drive older, DC motor extruders. What are you using to generate gcode? Assuming its skeinforge, you need to set up your replace.csv to get rid of the M113 codes and a few others. Heres my replace.csv:

M108	;M108
M113	;M113

Note that those are tabs, not spaces, skeinforge is ridiculously picky about that.
Re: ReplicatorG Machine Drivers
January 27, 2012 10:19AM
Andrew, thanks for the reply.

Skeinforge is built into replicatorg, so it's strange that it would generate those codes, isn't it?

Of course that doesn't matter, they need to be removed/replaced, but I'm not very familiar with that process.

I haven't had to do any gcode mods using skeinforge with pronterface, so that could be fun. Especially if I have to do this with every gecode generation output by RepG (skienforge).

Or is this something that needs to be set-up in the machine type folders in xml?
Re: ReplicatorG Machine Drivers
January 27, 2012 10:50AM
you need to go into skein forge sub folder located in /user/ documents section under hidden folder .replicatorg change the skein settings in that folder for all homing and references to start ,end, replace.

it is probably faster to do the rest inside replicator g,select the skein and the setup you want to use, then edit it. when skienforge opens up, you will want to change dimensions settings as well

xml folder does nothing for reprap driver printers. host code is not translated it goes as it is seen.
the only things that change from xml file is max speed per axis, the type of extrude motor and some formats for if to show bed heater or two extruders. if using sprinter those settings will be done in firmware.

btw the reason for the error is m113 code is not recognized by replicator g. it is a potentiometer reading for tuning extruder on 5d firmware . this m113 command should be removed, and at the very least, disable error checks in preferences menu

replicatorg will timeout and resend a command. here is how to make your usb comm port timeout on its own.


Edited 1 time(s). Last edit at 01/27/2012 10:54AM by jamesdanielv.
Re: ReplicatorG Machine Drivers
January 27, 2012 05:20PM
I know this is moving off topic, but the reason for going to RepG is because of the P-face pauses (not recovering). I've tried everything that this forum had to offer, that I can find anyway. I actually like the Pronterface user interface more than repg, but maybe just because I'm used to it.

My pauses are random, even when running from the same file. It can happen near the beginning or the end, during a sparse layer or during quick cycling, a long straight line, or on a curve/perimeter. No rhyme or reason that is obvious, but it definitely happens less frequently when running PLA. That seems strange, but I suppose the lower temps and maybe less extruder strain could mean something.

Here's what I've tried so far:

- Various baud rates Matching of course, in sprinter, com port and pronterface. Finally returning to 115200 (port-host-firmware)

- Ferrite core at each end of usb (this reduced freeze occurances, definitely had an issue with noise)

- Full range of buffer in com ports (currently at 1 in 1 out)

- I have no ftdi options/drivers on my system.

The freezes are happening very infrequently, but I'm getting tired of wasting plastic. Some projects are so big that they are piece together anyway, so it's tolerable. But when I'm making parts for my machine and it "dies", I kinda lose it a little.

Right now, I'm doing a cold dry run of a 3hr part that has run 2 times without locking up. This is with my buffer at it's lowest possible setting, extruder running (no filament), cold nozzle and cold bed. Unfortunately, there are several new tests here, but I will back out of them one at a time, starting with adding heat, then filament. And if that is all good, then it could be the buffer, or I may be getting teased by my evil little machine.

So with all that said, I was wondering if anybody gets these freeze/pause issues when running from SD slot?

I've run this same issue on two computers, both laptops, one XP, the other, Vista.

Recap of my prusa: Ramps 1.3, sprinter and arduino mega 2560.
Re: ReplicatorG Machine Drivers
January 28, 2012 09:42AM
read here. sorry it is a lot.. you can also set the latency timeout to 1ms.


The latency timer is a form of time-out mechanism for the read buffer of FTDI devices. When a FT_Read instruction is sent to the device, data will not be sent back to the host PC until the requested number of bytes has been read. If the requested number of bytes never comes, the device would not send data back.
The latency timer counts from the last time data was sent back to the PC. If the latency timer expires, the device will send what data it has available to the PC regardless of how many bytes it is waiting on. The latency timer will then reset and begin counting again.
The default value for the latency timer is 16ms. This value may be customised by adding or changing the following entries in the FTDIPORT.INF file of the driver before installation.
This example will set the default latency timer value to 50ms. The valid range for the latency timer is 1ms - 255ms, although 1ms is not recommended as this is the same as the USB frame length.
The latency timer value is held in the registry under
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\FTDIBUS\{Device VID, PID and serial number}\0000\Device Parameters\LatencyTimer
Re: ReplicatorG Machine Drivers
January 28, 2012 07:56PM
I decided to try some different stuff on my old Dell M-60. It was a great workstation several years ago, haha!

Anyhow, I hadn't been able to run pronterface on either computer when I started out. Then I found the pre-compiled version for windows at koti.kapsi. [koti.kapsi.fi]

This is named as an experimental version. With this download I was running pronterface, albeit, stand alone (no Sfact available in settings).

No big deal. It would still run GCode gen'd from Sfact, just no Sfact from the host. The only problem I had was with pauses which seemed to become fewer with settings adjustments, but never went away totally.

Yesterday I attemped a straight-up install of the non-precompiled Pronterface and Sfact on my trusty ol' M60. Boom! No pauses. Not even short ones. Next I will try the same install on my M4400, which is what I use primarily (also becoming antiquated).I hope it will install just as easily on that one.
Re: ReplicatorG Machine Drivers
January 28, 2012 08:48PM

I don't have ftdi drivers. I'm running an Arduino Mega 2560 and they use regular drivers. Here's a quote from arduino's troubleshooting site [arduino.cc] :

"The Arduino Uno and Mega 2560 use standard drivers (USB CDC) provided by the operating system to communicate with the ATmega8U2 on the board. Other Arduino boards use FTDI drivers to communicate with the FTDI chip on the board (or in the USB-serial convertor)."

I've seen several discussions where people had troubles with there Mega 2560 install and it was a problem caused by ftdi drivers.

Here's a link to one such conversation:


Now, I'm not saying that I know that ftdi drivers are wrong, just that I (originally) never installed them based on installation instructions. I know very little about these things and I even suspect that I may misinterpret instructions from time to time, so let me know if you know the above to be inaccurate.
I've used the FTDI chips before.
My first interation of a design for a 3D Printer PCB used one.
Actually I started with a vinculum2 MCU from FTDI which has 2 USB hosts.
the vinculum chips are NO GOOD for a 3D printer MCU. there too slow.. they have alot of software overhead.
So I switched back to what I always use... PIC microcontrollers..
First I tried the FTDI USB-RS232 converter chips...
I had issues.. they would randomly lockup..
perhaps the above latency/timeout issues could have resolved the issue... but i did indeed play with these settings... and I could only improve but not fix the problem...
Then I switched to a MCP2200 USB-RS232 converter by MicroChip.
I have always had great results using Micro-Chip parts.
The MCP2200 works great.

Are there any other 3D Printer hardware that uses parts from microchip ? or even use PIC microcontrollers ?

I have made one now... so i'm not after one,..

Regards, Dean.
Re: ReplicatorG Machine Drivers
July 25, 2013 10:51PM
I don't know. there was a shortage of arduino's back in 2010 when I made some printers, and i thought about going the pic way. but support would always be my concern. technically it would cost half of arduino for parts. but support would need to be provided by the vendor. MIcrochip is not known for true opensource

there are a few controllers out there though..

Here is one: [dangerousprototypes.com]

It can be modified to run code like arduino.

Then there is also the chip kit [www.hownottoengineer.com]

There are some changes in how strings are handled, and also in how the I/O registers are used (for example 16 bits wide)

But it is possible

Edited 2 time(s). Last edit at 07/25/2013 10:55PM by jamesdanielv.
Sorry, only registered users may post in this forum.

Click here to login