Welcome! Log In Create A New Profile


X Axis Crashed during print

Posted by Adam.m.Nelson 
X Axis Crashed during print
July 12, 2013 08:21AM
I tried posting this in another thread, but got no love. Thought I would try it here.

Hey guys, I gave up on my Gen3 electronics and bough a set from ReprapDiscount. Everything is calibrated, and seem right (everything works manually). However, when I try to print a test cube the X Axis drives itself into the end block (This is after its already homed all three axis successfully). I narrowed the problem down to one line of G-Code, but I'm not sure what the problem is. Any thoughts would be appreciated.

My G Code (part of it)

M104 S200 ; set temperature
G28 ; home all axes
M109 S200 ; wait for temperature to be reached
G90 ; use absolute coordinates
G21 ; set units to millimeters
G92 E0 ; reset extrusion distance
M82 ; use absolute distances for extrusion
G1 Z0.400 F7800.000 ; move to next layer
G1 X90.930 Y91.110 ; move to first skirt point<------- This line drives the X Axis into the end....
G1 F1800.000 E1.00000 ; compensate retraction
G1 X91.110 Y90.930 F540.000 E1.00749 ; skirt
G1 X91.490 Y90.590 E1.02248 ; skirt
G1 X92.110 Y90.150 E1.04483 ; skirt
G1 X92.330 Y90.020 E1.05235 ; skirt

I'm using Ramps 1.4 electronics with Teacup firmware, with Pronterface on Win 7. I used Slic3r to make the GCodes.

It seems like its trying to move the axis in the wrong direction as both the home command and the move to centre command send the print head in the same direction; if I had the axis control inverted why does it home properly.... I tried swapping the motor wires around just in-case, but it does the same thing in the opposite direction (surprise surprise).

Thanks in advance!

"Get busy living, or get busy dieing" - Red
Re: X Axis Crashed during print
August 14, 2013 08:14PM
Did you ever find a solution for your problem? I am having a similar issue and I can't figure out the cause. Does it crash every single time or only sometimes? The tricky thing with mine is that I only get it sometimes and I haven't been able to nail down whether it is a bad slicing job or what. Did you every try putting your gcode into a reader to see if it makes any crazy motions in the model that it generates?

Could it be an EMF thing? I wonder if adding snubbing capacitors, power conditioners or anything like that could help. Did you try moving that X axis motor cable so that it is near something else? I am grasping at straws but maybe something can give you a lead. Good luck!
Sorry, only registered users may post in this forum.

Click here to login