Welcome! Log In Create A New Profile

Advanced

So what happened to cause Reprap to go down?

Posted by A2 
A2
So what happened to cause Reprap to go down?
April 18, 2014 11:15PM
Re: So what happened to cause Reprap to go down?
April 18, 2014 11:29PM
will have to navigate the log files for that, it was probably some kind of caching error,




-=( blog )=- -=( thingiverse )=- -=( 3Dindustries )=- -=( Aluhotend - mostly metal hotend)=--=( Facebook )=-



Re: So what happened to cause Reprap to go down?
April 19, 2014 01:28AM
Someone unplugged the Internet... winking smiley
Re: So what happened to cause Reprap to go down?
April 19, 2014 03:32AM
I've been noticing this a lot more often lately.


WWW.ZATOPA.COM - Your Place for high quality 3D Printing Filament and accessories
Re: So what happened to cause Reprap to go down?
April 19, 2014 04:14AM
To many trolls in the pipe, gumming up the works

--NO PERSONAL ATTACKS PLEASE--

Edited 1 time(s). Last edit at 04/19/2014 12:24PM by NewPerfection.
Re: So what happened to cause Reprap to go down?
April 19, 2014 06:13AM
At about one year ago in March, the site was down a lot too. I remember quite well since I was building my first 3D-printer back then and I couldn't reach here for information which was very frustrating.

Buuuut, a little bit of patience and I could go on.

I think there should be a bigger DONATE button on the site smiling smiley
Re: So what happened to cause Reprap to go down?
April 20, 2014 05:11AM
Quote
Ohmarinus
I think there should be a bigger DONATE button on the site smiling smiley

There's even some existing funding. I was asked to become a somewhat paid admin (think of $100/month). The problem is, once we have somebody paid, everybody will point his/her finger there, like "you're paid, so get done what's on my wishlist".

Currently, reprap.org is maintained, but I simply see no problems. I visit this page every day and it works flawlessly. Without flaws, fixing flaws isn't possible. Simple logic :-)

At wich time (GMT) do these dropouts happen?


Generation 7 Electronics Teacup Firmware RepRap DIY
     
Re: So what happened to cause Reprap to go down?
April 20, 2014 05:53AM
It was down this morning at about 06.00 but is on now 09.30 (uk in case it's a regional problem)

TC
Re: So what happened to cause Reprap to go down?
April 20, 2014 10:24AM
During the 6/18 outage (over 7 hours here in North America), Nginx was answering HTTP requests but indicated a caching problem after a minute delay trying to load the page. I don't know the exact architecture in use, but from my experience with Apache as a front-end cache to a back-end web server this is almost always a problem with the back-end server crashing or having database problems. The wiki and main RepRap,org web sites were also down with the same error, FWIW.....
Re: So what happened to cause Reprap to go down?
April 21, 2014 06:53AM
Quote
vreihen
Nginx was answering HTTP requests but indicated a caching problem after a minute delay trying to load the page.

That's useful information, thank you.

Quote
vreihen
I don't know the exact architecture in use, but from my experience with Apache as a front-end cache to a back-end web server this is almost always a problem with the back-end server crashing or having database problems.

It's Gentoo Linux running MySQL and Apache. Apache forwards all file download requests (pictures) to Nginx (which reduces server load by some 60%).


Generation 7 Electronics Teacup Firmware RepRap DIY
     
Re: So what happened to cause Reprap to go down?
April 21, 2014 11:32AM
At about 14:15 UTC today, I tried to view reprap.org/wiki/Azteeg_X3. After a minute delay, I received a "502 Bad Gateway nginx/1.4.1" error.

At 14:30 UTC, I tried to get to this thread to post the above info, but the site wasn't responsive. After a 3+ minute delay, I received a "504 Gateway Time-out nginx/1.4.1" error.

Hopefully the server logs will reveal something useful.

As a side note, Repetier's web site was throwing an "Error establishing a database connection" at the same time that the above two errors occurred. Although a long shot, I wonder if someone isn't running a denial-of-service attack against RepRap sites for some spiteful reason?????

Edited 1 time(s). Last edit at 04/21/2014 11:32AM by vreihen.
Re: So what happened to cause Reprap to go down?
April 21, 2014 11:32AM
It was just down again, from about 2PM-3PM UTC/GMT, April 21. (I'm in the US.)

Can we start a wiki page to log problems like this? Or maybe even better an issue tracker on github?
Re: So what happened to cause Reprap to go down?
April 21, 2014 11:39AM
im getting error 404 now.


[mike-mack.blogspot.com]
Re: So what happened to cause Reprap to go down?
April 21, 2014 01:27PM

502 Bad Gateway



nginx/1.4.1

Re: So what happened to cause Reprap to go down?
April 21, 2014 01:40PM
This telnet test output says it all:

~/ $ telnet forums.reprap.org 80
Trying 69.46.82.69...
Connected to forums.reprap.org.
Escape character is '^]'.
GET /


(html)
(head)(title)502 Bad Gateway(/title)(/head)
(body bgcolor="white")
(center)(h1)502 Bad Gateway(/h1)(/center)
(hr)(center)nginx/1.4.1(/center)
(/body)
(/html)
Connection closed by foreign host.
~/ $

Edited 2 time(s). Last edit at 04/21/2014 01:43PM by vreihen.
Re: So what happened to cause Reprap to go down?
April 21, 2014 01:45PM
Also note that the above post was made at 13:28 EDT (UTC-4), but the timestamp is 12:40 PM.....
Re: So what happened to cause Reprap to go down?
April 21, 2014 02:16PM
i just got the 502 error again and restarted apache at 3:30am ish (mytime)(australia)




-=( blog )=- -=( thingiverse )=- -=( 3Dindustries )=- -=( Aluhotend - mostly metal hotend)=--=( Facebook )=-



Re: So what happened to cause Reprap to go down?
April 21, 2014 04:09PM
Hey, it's been down for half of the day again here in the Netherlands. Happy to see it back!
Re: So what happened to cause Reprap to go down?
April 22, 2014 04:09AM
i changed my dns on my router back to open dns. i am still getting this error though

Quote
Not Found

The requested URL /bin/view/Main/WebHome was not found on this server.



[mike-mack.blogspot.com]
Re: So what happened to cause Reprap to go down?
April 22, 2014 03:18PM
Quote
dissidence
The requested URL /bin/view/Main/WebHome was not found on this server."

No surprise on this one. Such a thing simply doesn't exist.


Generation 7 Electronics Teacup Firmware RepRap DIY
     
Re: So what happened to cause Reprap to go down?
April 22, 2014 09:19PM
thats been my bookmark for ages, also what chrome used for my most popular pages..lol

oh well.


[mike-mack.blogspot.com]
Re: So what happened to cause Reprap to go down?
April 23, 2014 07:10AM
@dissidence: reprap.org also changed ages ago :-)

Finally I got these 502's, too. It's a SYN flood attack, excerpt from dmesg:

possible SYN flooding on port 80. Sending cookies.
possible SYN flooding on port 80. Sending cookies.
TCP: Peer 93.39.64.143:62297/80 unexpectedly shrunk window
779876073:779883373 (repaired)
TCP: Peer 187.195.191.16:54635/80 unexpectedly shrunk window
1932683412:1932686316 (repaired)
TCP: Peer 187.195.191.16:54635/80 unexpectedly shrunk window
1932683412:1932686316 (repaired)
TCP: Peer 212.3.79.6:38850/80 unexpectedly shrunk window
1429369216:1429372694 (repaired)
INFO: RCU detected CPU stalls: 1 (detected by 3, t=1007 jiffies)
sending NMI to all CPUs:
INFO: RCU detected CPU stalls: 3 (detected by 0, t=1002 jiffies)
sending NMI to all CPUs:
INFO: RCU detected CPU 0 stall (t=1016 jiffies)

Now investigating why it stalls Apache, but not Nginx.


Generation 7 Electronics Teacup Firmware RepRap DIY
     
Re: So what happened to cause Reprap to go down?
April 23, 2014 07:17AM
what version of apache is running?




-=( blog )=- -=( thingiverse )=- -=( 3Dindustries )=- -=( Aluhotend - mostly metal hotend)=--=( Facebook )=-



Re: So what happened to cause Reprap to go down?
April 23, 2014 01:01PM
Hello everybody, my 2 cents.
Speaking as an admin I can assure I've got 502 errors in the past. And always when I was managing the forum from the Admin's panel; I don't know why but it happens, example:

- Access the panel
- Modify the description text of a section (everything ok)
- Refresh the forum's page to see the editing (everything ok)
- Modify another section's description (502 error after "Apply" button)
- Wait 2 minutes and refresh the RepRap forum's page, the last editing got saved and everything works.

This is my experience, I've got 502 error also when moderating posts.

About today, no signs of error but I'm connected from the afternoon (Italy time).

Edit: I've opened a topic about this in the italian section and users are telling they got problems (Bad Gateway) in these days.

Edited 1 time(s). Last edit at 04/23/2014 02:58PM by Gordie.


---- "Let me make my move" ----
# Un progetto di stampante multifunzione ## I commenti sono benvenuti #
# ATM planning a multifunction printer with aluminum extrusions ## Comments and thoughts are welcome #
Re: So what happened to cause Reprap to go down?
April 23, 2014 06:26PM
502s happen in forum and wiki at the same time, so it can't be a web software issue. Apache is version 2.2.24.


Generation 7 Electronics Teacup Firmware RepRap DIY
     
Re: So what happened to cause Reprap to go down?
April 23, 2014 07:28PM
Quote
Traumflug
Now investigating why it stalls Apache, but not Nginx.

If Apache is being used as a reverse proxy in front of Nginx, it is probably acting as a "circuit breaker" and not passing that traffic through to Nginx due to not having free TCP resources from the flood.....
Sorry, only registered users may post in this forum.

Click here to login