Welcome! Log In Create A New Profile

Advanced

Getting Reprap software to work on Windows

Posted by bartlee45 
Getting Reprap software to work on Windows
March 09, 2007 01:17AM
I understand that some people already have the control software working under windows. I was wondering if anyone is in a position to update the windows instructions for making it work. Maybe including do's and don'ts. Versions of everything used would be helpful so that one wrong component isn't used. I've had a devil of a time and gotten close. But had problem with making the comm stuff work. Ripped out all but the 1.4.2 java and put it all back in. Removed the repository added new copy back and now I have different problems after using java 1.5 and java 1.6. I've tried the poke utility under cygwin login but it gives an error shown below. I'm ready to nuke it all and start from scratch if I have any hope of doing it any better this time.

[email protected] /cygdrive/c/rr/firmware/tools
$ echo 12 | ./poke.exe -d 2 -t COM1
Get attr: Inappropriate ioctl for device

[email protected] /cygdrive/c/rr/firmware/tools
javax.comm.NoSuchPortException
March 10, 2007 12:07AM
Hmmm.. Lots of views but no comments..
OK OK, I re-did everything and now I'm back to this..
Anyone know how to overcome this?
I'll take suggestions, guesses, snide remarks.. anything really smiling smiley)

Opening port COM1
javax.comm.NoSuchPortException
at javax.comm.CommPortIdentifier.getPortIdentifier(CommPortIdentifier.java:105)
at org.reprap.comms.snap.SNAPCommunicator.(SNAPCommunicator.java:42)
at org.reprap.gui.steppertest.Main.(Main.java:60)
at org.reprap.gui.steppertest.Main.main(Main.java:51)
at org.reprap.Main$17.actionPerformed(Main.java:252)
at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
at javax.swing.AbstractButton$ForwardActionEvents.actionPerformed(Unknown Source)
at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
at javax.swing.AbstractButton.doClick(Unknown Source)
at javax.swing.plaf.basic.BasicMenuItemUI.doClick(Unknown Source)
at javax.swing.plaf.basic.BasicMenuItemUI$MouseInputHandler.mouseReleased(Unknown Source)
at java.awt.Component.processMouseEvent(Unknown Source)
at java.awt.Component.processEvent(Unknown Source)
at java.awt.Container.processEvent(Unknown Source)
at java.awt.Component.dispatchEventImpl(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)
Re: Getting Reprap software to work on Windows
March 10, 2007 12:40AM
ROTFLMAO! Good luck, Bart! :-D
Re: javax.comm.NoSuchPortException
March 10, 2007 01:09AM
have you tried other com ports... i'll alert one of the developers and see if they can help you.
Re: Getting Reprap software to work on Windows
March 10, 2007 01:43AM
I think that the question to ask is whether any of the developers have a RepRap or at least the control board system for a RepRap actually running on a Wintel machine. If the RepRap Project is serious about being anything but a Linux-only undertaking this HAS to happen. I may well be wrong, but to the best of my knowledge to date it hasn't happened. I believe that Simon has come as near as anybody to doing it, but I don't think that a committed, full-time Wintel reference system is running.

Eventually somebody is going to have to bite the bullet and do it. I took a shot at it and gave up. I just didn't have the mix of Linux and Windows skills to make it happen. Do you?
Re: Getting Reprap software to work on Windows
March 10, 2007 02:48AM
Thanks Zach, it is COM1. I used it to program my pic programmer. But the important point is that it says nosuchportexception. Not timeout or something expected from not having it connected. Maybe I'm not naming it right. But the default of /dev/ttyS0 or whatever it originally was gives the same result.

Forrest,
Well thats what we are going to see. This is actually just a stepping stone to me helping Simon make the builtin reprap pic programmer. I don't mind biting on bullets, they taste kind of like solder. But I'm looking at communicating with my little pic chips along multiple avenues, whatever works first is fine with me. I'm looking at your code and a sample from MS and Poke for what has to be sent. I'm surprised that you couldn't get communication going with a the standard pic. That should have been easier than reinventing everything (I would think). You seem well able to wield vb.net. Anyways, I'll crawl, stumble, trip and fall till I can finally walk, run and Reprap. And I'm glad you liked my earlier post smiling smiley I try to go for funny even if I'm the only one that ever laughs.
Re: Getting Reprap software to work on Windows
March 10, 2007 03:09AM
***I'm surprised that you couldn't get communication going with a the standard pic.***

I actually didn't have problems doing comms with the standard pic control board way back when. Simon had set up a little control panel written in Java to drive the stepper motors that worked without hiccoughing on my Wintel PC first time out. Of course, the control panel wasn't trying to do much of anything besides communicate with that one board.

What killed steppers for me at that point was that the board design that was available back then couldn't deliver either enough speed or torque with my bipolar NEMA 17's to drive my prototype 3D printer design.

I seem to remember some months ago that the core team started having problems with RS232 comms in Linux. It was something about the dll having changed or not loading right or something of the sort. I seem to remember Vik having had the problem.

I suspect that it was probably at that point that the problem crept in that you're seeing. Mind, the control panel is a lot more ambitious piece of Java now what with it being able to run a complete system instead of just the odd stepper control board. You're probably just seeing some sort of cross-platform compatability problem with Java. RS232 comms hasn't been a big deal in software for a long, long time so it shouldn't be surprising that nobody has attended to making sure that such compatability problems don't happen..
Re: Getting Reprap software to work on Windows
March 10, 2007 03:13AM
Wait a minute. Correct me if I'm wrong but aren't you trying to do RS232 comms with some sort of different circuitry than the Max232 board approach that goes with RepRap?
sai
Re: Getting Reprap software to work on Windows
March 10, 2007 04:10AM
Forrest Higgs Wrote:
-------------------------------------------------------
> ROTFLMAO! Good luck, Bart! :-D


Just so nobody gets the wrong idea here, the software does work on Windows. At multiple stages, I have built everything on windows and linux and I test it on both. It works just fine. Windows is and I believe always has been a target platform for RepRap.

On several occasions to simplify deployment on Windows, we have had a self-contained ZIP file that includes all dependencies to run it. Using it is just a matter of extracting it and running a launcher, so it is also very easy.

Please bear in mind we haven't reached release version 1.0 and putting together a package like that for every minor revision is difficult to justify. When 1.0 comes around there will probably be a proper Windows installer as well to make things even easier.

If you want to run the bleeding edge versions of a multi-platform application, you need to be prepared for a few cuts and scratches. But it's not as big a drama as some people might have you believe.
Re: Getting Reprap software to work on Windows
March 10, 2007 09:20AM
Simon! Ah good! There is the information that you need, Bart.
sai
Re: javax.comm.NoSuchPortException
March 10, 2007 04:23PM
Can you please list the versions of various components (javacomm, jre, etc.) that you're using?
Re: Getting Reprap software to work on Windows
March 10, 2007 04:33PM
Thanks Simon, I just need to narrow in on the Comms portion. It is what caused me trouble in the beginning and now I'm back to it. As you see above it can't find COM1 . If you have it working on your WINXP system, I'll just need pointers to the version of the comm software for jar, dll and properties file and any others if you have more. I only have 1.4.2 now, so there aren't any questions of which version I might be referencing.
Re: Getting Reprap software to work on Windows
March 10, 2007 04:39PM
Our posts are crossing lol.. I am using J2RE1.4.2_13 and the com 2.0.3 from Sun downloads.
Re: Getting Reprap software to work on Windows
March 20, 2007 01:17AM
Thought I would touch this up.
After cleaning up cygwin install and following instructions on sdcc page for setting up cygwin, I followed Simon's instructions and was able to build software. Still don't know what the answer is for the Java comms portion is yet though. As stated in another post, I was able to get a successful response from my stepper circuit using poke after doing all that.

[sdcc.sourceforge.net]
[www.reprap.org]
Sorry, only registered users may post in this forum.

Click here to login