Welcome! Log In Create A New Profile


Ultimaker PCB board v1.5.7

Posted by zfitzgerald 
Ultimaker PCB board v1.5.7
November 10, 2014 12:14PM
I have recently purchased an Ultimaker 3D printer PCB controller board (version 1.5.7), and I am having some issues getting a k-type thermocouple and a tc1 thermocouple amplifier to give proper temperature data to the PCB board. Currently I have TEMP_SENSOR_0 set to -1 (thermocouple with AD595) in the marlin firmware, which I believe is the proper setting for my current setup. However, my temperature reading is always around 144-146 no matter what the temperature of the extruder is. From my reading on [reprap.org], it appears that for a PCB controller board with a version of 1.5.4, you would have to cut the R23 resistor to make the board read a thermocouple. I do not have the PCB board v1.5.4, but there still is this resistor and in front of the resistor is a little gate labeled j1. If I solder the gate shut will the PCB board read a thermocouple or would I have to do something else? Any help is greatly appreciated; as this is very urgent.

Thanks, Zach
Re: Ultimaker PCB board v1.5.7
November 10, 2014 09:18PM
there needs to be a 4.7k resistor installed for thermister. i don't think they are installed by default . there is a setting change that is needed in firmware for thermal couple or thermister. there is some documentation about length and something about a short causing the temp sensor to read internal temp on chip rather than thru the probe.

Edited 2 time(s). Last edit at 11/10/2014 09:20PM by jamesdanielv.
Re: Ultimaker PCB board v1.5.7
November 10, 2014 11:09PM
Based on the PCB board website, if the thermocouple is showing room temperature, and it does not change when the extruder heats up, and you place a finger on the chip and the value changes, then there is not enough resistance between the thermocouple wires. I do this test and everything is true except for the value being 0 at the beginning, instead it is anywhere from 144-146. I tried testing the temperature with another board and setup and I do get the temperature so I do not know what the problem is.
Re: Ultimaker PCB board v1.5.7
November 11, 2014 01:39AM
does this troubleshooting help at all?

Re: Ultimaker PCB board v1.5.7
November 11, 2014 06:52PM
Thanks for the troubleshooting site but I tried one of the tests (connect a wire from one thermocouple amplifier input terminal to another) and my output is still 144 degrees. I think there is either a problem with the hardware (the chip is broken) or with the software. The only change that I made to the software is setting TEMP_SENSOR_0 to -1. Is there anything else I need to do?
Re: Ultimaker PCB board v1.5.7
November 11, 2014 08:20PM
Thanks for all of the help so far. I am thinking that there is some sort of hardware issue with the tc1 board. I do have a MAX6675 board that should work with the PCB board. However connecting this is very different than just plugging in the connections to my understanding because there are four connections on the MAX board and three on the PCB board. I think that you have to connect it somewhere else and change some extra software settings. After that I am not sure what to do. Any help is greatly appreciated and a very descriptive answer would be preferred. Thanks.
Re: Ultimaker PCB board v1.5.7
November 11, 2014 10:01PM
3 leads to ultimaker pcb are gnd, 5v,sig. diagram included. normally the 3 leads hook up to temp1 the other end of wires to the tc1 board

you need to not have r23 installed. it should not be installed by default. only use if you have a thermister.

also here is the data sheet for the 597 [www.analog.com]
here is the data sheet for the max6675 [datasheets.maximintegrated.com]

they are completely different, as the ad597 is an op amp circuit, and the max6675 includes a a/d 12 bit serial spi communications. you will need to spi pins.
here is the diagram of the max6675 board. [www.brokentoaster.com]
also temp will need to be set to -2

here is someone elses blog that did the same as you [www.brokentoaster.com]

also read this and make sure issues are resolve here:
Always make sure you're running the Ultimaker firmware.
The temperature goes DOWN to 0 if I heat up the thermocouple. This means that you have switch the thermocouple wires.
The values are incorrect: Check if the resistors are left out or removed (see above).
The value is 499.9 degrees: Check if all connections are correct, and if reliable wires are used.
Does the temperature fluctuate too much? Check if C1, C9 and C10 are installed.
The thermocouple is nothing more that two wires of a specific metal that are connected together at one end. This is the measurement end. You can make your own by fusing the end together (do not use solder, it will melt at normal operating temperatures of the extruder. The original thermocouple supplied with Ultimakers has a standardized thermal resistance to the aluminium heater block, so this will give the most reliable measurement.
Using your own firmware? The AD597, as used in the Ultimaker thermocouple PCB, is fully compatible with the AD595. Make sure that the AD595_THERMOCOUPLE is defined and thermistor measurements are turned off.
If you switched the black and signal wires, the LED can be lit, but this is no confirmation that you've wired it up correctly. Incorrect wiring may damage your thermocouple sensor board.
The thermocouple always shows room temperature, but isn't changing when I warm up the thermocouple with a lighter: the AD597 chip is currently in self-measurement mode. If the + and - inputs of the thermocouple have a very low resistance, it will not give you the temperature of the thermocouple, but of the chip itself. Check this by placing a warm finger on the chip. If the value change quickly, this is indeed the case. Extend the thermocouple wires with terminal blocks or solder them together to get a higher resistance between the thermocouple inputs.
Prototype / Design

Edited 4 time(s). Last edit at 11/11/2014 10:09PM by jamesdanielv.
Re: Ultimaker PCB board v1.5.7
November 11, 2014 10:13PM
Thank you very much @jamesdanielv. I understand that I have to use the spi interface, but how would I do this with the Ultimaker 1.5.7 PCB board and when I set the value to -2, I get errors. I am a nooooob so any help really is appreciated.
Re: Ultimaker PCB board v1.5.7
November 11, 2014 10:43PM
look at the exp2 on the ultimaker board. you may not be able to use lcd. but i think it has been fixed


connect the coresponding pins miso,mosi,clk,vcc, and gnd. cs on the chip is chip select [en.wikipedia.org]
do as the documentation says if you have a cs lead. i think it should be driven low. or if the software selects it then connect to ss. this may be part of the original issue with the lcd display because only one device at a time can be active on the same spi channel. I don't have time tonight to see how the 6675 is read and how the software interacts with ss.

what errors do you get, is it compiling errors?

Edited 1 time(s). Last edit at 11/11/2014 10:47PM by jamesdanielv.
Re: Ultimaker PCB board v1.5.7
November 11, 2014 10:54PM
On the MAX board I have VIN 3Vo GND DO CS and CLK, I do not have miso, mosi, or vcc, how do I know what to connect to what? Thanks. I am getting compiling errors, I think it has to do with the pins not being defined and I am unsure how to do it.
Re: Ultimaker PCB board v1.5.7
November 12, 2014 10:59AM
is there any way you would consider just using a thermister? I feel that this all may be too much for you. I provided all the schematic information you should need. if you do not understand it, then wait a bit for using the max6675.

if you need to define the pins then look at the code involved for the max6675, add those pins, and define them in the ultimaker board section of marlin. If someone wants to take the time to walk you thru that then that would be helpful. sorry i don't have time today to look more into that for you. perhaps someone else can? otherwise i will look into it tonight and see where it would need change.

Edited 2 time(s). Last edit at 11/12/2014 11:06AM by jamesdanielv.
Re: Ultimaker PCB board v1.5.7
November 12, 2014 02:32PM
Thanks again @jamesdanielv. The reason I sound so ignorant is because I believe that I may have had some communication error. I am getting an extruder with a 100k thermistor in it, but I need to get the printer going until then. I told you that I am using a MAX6675 board. I am actually using this thermocouple amplifier here: [www.adafruit.com]. It is a thermocouple amp that has the newer version of the MAX6675 integrated into it. My issue is that the outputs of the actual board are different from the outputs of the MAX6675 integrated chip and I need to know how they correspond. Based on the data sheet that you have sent me, I understand which outputs would go with what if I was using just the MAX board but I am not, and I need to understand how the outputs Vin, 3Vo, GND, DO, CS, and CLK connect to the inputs on the exp2 (GND, 5v, 3.3v, MOSI, SS, MISO, and SCK). Thanks again!
Re: Ultimaker PCB board v1.5.7
November 12, 2014 07:26PM
also i sent the data sheet for the 6675 chip. you can look at that for pinouts and additional circuitry required. I like how you now have posted specific questions towards the compiling errors. if you do get the help you need about it please post the answers into this forum topic as well. it seems we need to update the firmware to work easier with max6675 and ultimaker

Edited 1 time(s). Last edit at 11/12/2014 07:28PM by jamesdanielv.
Re: Ultimaker PCB board v1.5.7
November 12, 2014 07:39PM
, and I need to understand how the outputs Vin, 3Vo, GND, DO, CS, and CLK connect to the inputs on the exp2 (GND, 5v, 3.3v, MOSI, SS, MISO, and SCK). Thanks again!

VIN connects to VCC

3VO is not connected.

GND connects to GND.

DO connects to MISO.

CS connects to SS. Note that CS can be any free GPIO pin on the board, defaults to 53, or to 49 if you also have an SD card reader installed.

CLK connets to SCK.

Nothing connects to MOSI.
Re: Ultimaker PCB board v1.5.7
November 12, 2014 07:45PM
Ok I think I got it hooked up right, I set the pins.h file under IF MOTEHRBOARD == 7 to the right pin values. The code uploads but there is not lcd screen at all now and my computer isn't connecting to it right, it just waits for commands to finish and can never send them right.
Re: Ultimaker PCB board v1.5.7
November 14, 2014 06:34PM
if you do not yet have this issue resolved upload your firmware as a zip file and someone will likely take a look at where the issues are, for example not disabling ss for spi device
Sorry, only registered users may post in this forum.

Click here to login