Welcome! Log In Create A New Profile


extruder not operating

Posted by gbot 
extruder not operating
June 25, 2010 11:29AM
Hi all

have made great progess with darwin, can send gcode and get motors to operate.

prob is cant get heater to switch on usind arduino duemilanove and v 0018 software also running reprap console.

Heater is tested... check
PWM Driver works.. check

if I run a Gcode generated from an stl I expected the heater to fire up but it doesn't.

here is the start of the code.............

G21 ;metric is good!
G90 ;absolute positioning
T0; select new extruder
M104 S200
G92 E0 ;zero the extruded length
G1 Z8.0 F90.0 ;clear the bolt heads
G28 Y0 ;go home
G28 X0
G1 X135.0 F3000.0
G28 Z0
G92 Z0 ;Adjust Z height for optimum 1st layer adhesion
G1 Z8.0 F90.0
M109 S210
M113 S0.75
G1 Z0.4 F90.0
G1 X10.0 E360 F1500.0
G92 E0
M115 S60.0
M116 S30.0
M117 S0.0
M113 S1.0
M108 S210.0
M104 S200.0
M104 S198.601
G1 X28.8 Y-27.43 Z0.72 F240.0

Also in the reprap console I press the button heater on and nothing. I expected pin 6 to jump high and the heater to com on.

pin 6 is defined as the heater in the string in the g code interpreter within the init file.

//extruder pins
#define EXTRUDER_THERMISTOR_PIN 0 //a -1 disables thermistor readings
#define EXTRUDER_THERMOCOUPLE_PIN -1 //a -1 disables thermocouple readings

hope you can help...
Re: extruder not operating
June 26, 2010 06:41AM

It might be easier to debug what is happening by using a serial terminal and sending just M codes.

On the firmware version I use M104 S200 gets a response "ok"

M105 gets the current temperature.

Are you using Windows or Linux?


Re: extruder not operating
June 26, 2010 11:23AM
thanks Ian, that sounds like a plan! Ill see if I can fathom how to do that.

Im using windows xp with the reprap console.
Re: extruder not operating
June 28, 2010 08:10AM
Ian, thanks so much. Managed to eliminate loads of possible problems....

Tried the manual input and have managed to switch fan on and off using M106 and M107

M105 pulls the temperature fine and get temp in celcious

when I type M104 S100 for example I get "ok" back on the debugger, but the heater doesnt come on. Should it?

I have tested the pin works by changing the pin assignment of the fan and heater
I have tested the heater
I have tested the pwm driver
I have tested the temperature sensor

Do you think the problem is most likly a setting in the firmware? Oh please help.

open | download - extruder.pde (12.3 KB)
Re: extruder not operating
June 29, 2010 04:40AM

Which electronic hardware are you using? G2, G3 whatever?

Have you tried a simple sketch directly driving the heater to eliminate electronic errors?

An example is here:-

I have just confirmed my heater does start to heat up if I send M104 S100

BUT my firmware is an old version and I am using G2 Arduino electronics so things may have changed in the later versions.

I would not expect the problem to be firmware, if there where any problems I am sure lots of users would have reported then.


Re: extruder not operating
June 29, 2010 06:02AM
Are you reading temperatures correctly? If it thinks it is already at 100C it will not switch on.

Re: extruder not operating
June 29, 2010 07:57AM
Thanks Ian

Thats been loads of help.....thumbs up

Using Gen 2 electronics on a ard duemillanove. Using v 0018 arduino software. Have a dc motor not a stepper on the extruder. extruder is running pwm driver v 1.1

Loaded the test software like you suggested and all worked as expected. Fans, temp, dc motor, no problem. So looks like all hardware is fine.

even tried checking if the pin went high with a multimeter!
tried swapping the pin configeration too.

I wonder did you have to make any changes to the firmware to get it to operate? Any thought would be great! I suppose getting some firmware of another rep rapper would be the next step of elimination and maybe try another arduino?

Re: extruder not operating
June 29, 2010 08:10AM
Thanks Nophead!!!!

I think so, when I send M105 I get T25 back which is about room temperature.

If I force the heater on the temp climbs and as I hit M105 again I get readings back that seem about right T100 T150 T200 etc

So the temp data is arriving back O.k. Plus on the test software ian suggested which uses the temp sensor, all seems fine.

There was a couple of lines in the firmware i needed to change.

one was

// Comment the next line out to use the Arduino
//#define SANGUINO

the other

// Uncomment the next line if you are using a thermistor; leave it if you have a thermocouple

They are the only changes I have made.

cheers graham

P.S. I dont know if you remember but I came over your place with my mate Simon some months ago! V. Impressed.

Re: extruder not operating
June 29, 2010 12:33PM

Which version of the firmware are you using? Can you post a link to where you downloaded it. At some point I thought the Arduino was dropped as it can't run 5D code.


Re: extruder not operating
June 29, 2010 01:03PM
Hi Ian

I didnt use this... [reprap.svn.sourceforge.net]

I did use the arduino firmware from here v1.3 [sourceforge.net]

strangly it seems in order to work there is also a file called init.pde this isntn mentioned in the instructions which are here


Re: extruder not operating
June 29, 2010 01:22PM
here is that init file to, I cant compite the sketch without it.

open | download - _init.pde (1.7 KB)
Re: extruder not operating
June 30, 2010 03:56AM

I think that is an early version.

Have you tried the firmware on this page:-


You will need to follow the instructions to make sure you have the defines set correctly.

I am off on holiday today and may not get online for a while.

Edited 1 time(s). Last edit at 06/30/2010 05:41AM by emt.


Re: extruder not operating
June 30, 2010 06:14AM
Cheers Ian I'll give that a try!

O.k. Tried and got this error

osad smiley.data.temptable+0x0): multiple definition of `temptable'
C:\DOCUME~1\GRAHAM~2.24D\LOCALS~1\Temp\build4622668242942025243.tmp\ThermoplastExtruder\ThermoplastExtruder.cpp.osad smiley.data.temptable+0x0): first defined here

looked in this folder and nothing there.

I downloaded all 8 files and renamed 4 of them to .h extensions and put them in a folder called GCode_interpreter .

think I might need to buy a sanguino..

Have a great holiday!!!!
Re: extruder not operating
June 30, 2010 03:30PM
I am successfully using a Duemilanove with the 5D firmware. Some of these boards have an AtMega164, which does not have enough program memory for the 5D firmware. If your board has the AtMega328, like mine, you should be able to run the 5D firmware. I've uploaded my firmware if you would like to try it: [github.com]

From everything you have posted, it sounds like the problem is in the firmware. The next step would be to debug the firmware with Serial.println() lines and use a terminal program to send the M104S100 command and see where it is failing.

Looking over the v1.3 firmware you linked to, it appears it is looking for a different character. Try M104 P100 instead.

Darwin clone, Gen 2 electronics, Arduino Duemilanove w/ AtMega328, 5D Firmware, Pinchwheel extruder
Re: extruder not operating
July 01, 2010 04:37AM
thanks mccoyn,

It worked!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!1>grinning smiley<

I understand, id have been weeks finding that firware was expecting a p and not an s,

Thanks so much, not only does it work but I have a much better understanding of how the code is working.

Ill try your 5g code later.

Cheers again.
Re: extruder not operating
July 01, 2010 12:35PM

I don't think 5D will work with a DC extruder, only stepper drives.

I would stick with the firmware you have working to start with. If you use skeinforge you can define a replace.csv where you can get the M104 with the P output instead of S.



From a very very wet and windy Cornish campsite where to my surprise they have WiFi
Re: extruder not operating
July 02, 2010 10:34AM
cheers ian

better weather coming your way sat!!!!

cheers, have swapped letter and no probs so farspinning smiley sticking its tongue out gonna build it all up now and hopfully..................

Sorry, only registered users may post in this forum.

Click here to login