Welcome! Log In Create A New Profile


failed Mega 2560 firmware update

Posted by sk8nmike 
failed Mega 2560 firmware update
June 07, 2015 08:43AM
I have a printer based on an Arduino Mega2560 and a Ramps controller. I recently changed the configurationi.h filed, uploaded it and killed my printer. Now all I get on the LCD display is 2 rows of squares and can't communicate with it via the arduino program or pronterface. The mega does showup in me device manager.
Re: failed Mega 2560 firmware update
June 07, 2015 08:46AM
Have you tried to flash it again? Maybe it just went wrong once.
Re: failed Mega 2560 firmware update
June 07, 2015 08:50AM
Yes, tried reflashing several times with a known good file. Main problem seems to be that the Mega isn't talking, I get no responce when I open the serial monitor no matter what baud rate I select.
Re: failed Mega 2560 firmware update
June 07, 2015 09:46AM
I had one die the same way- lost communications. I think the USB interface chip dies, maybe due to ground loops between the computer and the printer if they are plugged into separate household electrical circuits. I ultimately replaced the Arduino board.

FWIW, I'm using a smoothieboard now and configuring the printer is much easier. There's no screwing around with compilers and hunting through multiple config files for the parameter you want to change.- just edit a single text file containing ALL configuration parameters and reboot. Updating firmware is the same- copy the new firmware file to the board's uSD card and reboot. Done.
Re: failed Mega 2560 firmware update
June 07, 2015 10:45AM
Next thing to try is to strip down the electronics so that the mega is on its own.
Try flashing again,
if that doesn't work, you have two issues to work through.
both can be diagnosed by bypassing the usb chip but you will need additional programmer.
Go to arduino.cc and see if it's the boot loaded (if it has one) that has died, (can be reprogrammed)
You will need an ISP programmer to check if its the mega or just the usb chip that given up the ghost.
Re: failed Mega 2560 firmware update
June 07, 2015 10:58AM
Can you see the mega board in the device manager, when it´s connect thru USB?

Using a ISP programmer is only one option to bypass a fried USB-chip. You can also use any other arduino-board to act as a programmer-dummy.
See arduino.cc for more details.
But all the options only help with flashing the firmware/bootloader. I don´t know, if pronterface or printing in general would work via ISP or second arduino.

Edited 1 time(s). Last edit at 06/07/2015 10:59AM by o_lampe.
Re: failed Mega 2560 firmware update
June 07, 2015 11:10AM
Have you upgraded the Arduino software?

See [forums.reprap.org] and [forums.reprap.org]


Re: failed Mega 2560 firmware update
June 11, 2015 09:10AM
OK, I've tried burning a new bootloader onthe the Mega and it failed. Might be something I'm doing. There doesn't seem to be any communication between the Mega and the AVR ISP. I've attached a picture of how I have the ISP programmer connected to the Mega. The red light on the ISP never goes out and no green light nor to the TX/RX leds on the mega flash
open | download - IMG_3945[1].jpg (564.5 KB)
Sorry, only registered users may post in this forum.

Click here to login