Welcome! Log In Create A New Profile


Stranger problem of Z-axis (Solved)

Posted by tv7957ht 
Stranger problem of Z-axis (Solved)
July 24, 2010 02:09PM
As my last post i had resolve a Z axis about it cannot lifting up in correct printing position and nophead advise me that its seem setting too fast of Z axis and losing stepping on Z motor, than i go to config a lower value of "Maximum Z feed Rate = 0.5" in Skeinforge, and its seem work fine after changed it. However, After i tried a few print test than i found a very stranger problem and i cannot figure out why it is happen.

1.) All of my mendel parts printing of Z-axis height is not correct (X,Y is fine) (see attached pic. x-bar-clamp-m4_4off the correct height is 11mm but my printing is 8.68mm)
Problem cause : I found that the problem is a z-axis stepper motor didn't spinning a same distance on each
layer when is printing, (i'm checked by put my finger on a z-axis belt, and checking for each layer for whole printing)

2.) The most strange things is i'm printing my test printi object is 15mm(L)x15mm(W)x25mm(H) in 1.5mm thick wall in a same configuration as about and its print Z-axis height is correct. (see attached pic.)

Follow is my setting.
1.) fireware -
// define the XYZ parameters of Mendel

#define X_STEPS_PER_MM 10.047
#define INVERT_X_DIR 0

#define Y_STEPS_PER_MM 10.047
#define INVERT_Y_DIR 0

#define Z_STEPS_PER_MM 833.398
#define INVERT_Z_DIR 0

2.) Z-axis belt is T5 - 5mm pitch
Stepper motor - 1.8deg
z-threaded rod 1.25mm pitch

3.) Skeinforge setting see attached.

Please advice me what's the problem of my setting.

Edited 1 time(s). Last edit at 07/26/2010 09:13AM by tv7957ht.
open | download - CIMG4570.jpg (133.7 KB)
open | download - CIMG4571.jpg (140.8 KB)
open | download - x-bar-clamp-m4_4off.jpg (32.6 KB)
open | download - speed.jpg (79 KB)
open | download - raft.jpg (110.8 KB)
open | download - fill.jpg (98.9 KB)
open | download - carve.jpg (61.6 KB)
open | download - 15x15x25TestPrint.jpg (31.4 KB)
open | download - x-bar-clamp-m4_4off_export.gcode (333.7 KB)
Re: Stranger problem of Z-axis
July 24, 2010 08:02PM
See your GCode file, line 946f:

G1 X46.28 Y19.06 Z1.0 F900.0 E2.525
G1 X46.54 Y18.76 Z1.13 F37.896 E45.75

The movement commanded with the second line starts at a feedrate of 900 mm/min, which this axis probably can't achieve. You'd still drop steps.

Inserting a "G1 F40" between both (and at every other layer change) would help, but I have no idea on how to tell Skeinforge to do that automatically.

Generation 7 Electronics Teacup Firmware RepRap DIY
Re: Stranger problem of Z-axis
July 25, 2010 01:23PM
Do you think is't any problem on a stepper motor ? hardware problem cause this happen ? but how can explain why when i printing a 15x15x25 test object is correct ??????????

Thanks a lot !

Edited 1 time(s). Last edit at 07/25/2010 01:23PM by tv7957ht.
Re: Stranger problem of Z-axis
July 25, 2010 07:19PM
I found adding M105 (dud command i think) to .skeinforge/alterations/homing.gcode enables separate xy and z speeds, horribly arcane but it worked for me. I also had to enable homing in skeinforge. Might be worth a shot?
Re: Stranger problem of Z-axis
July 25, 2010 10:19PM
Hi, I just tried to add homing.gcode with M105 command and seem not working, may be i did some wrong ?

can you tell me how much of Z max feedrate i need to set.

I've tried 0.002, 0.1, 4, until to 10 mm/s .... all of them its seem make z axis step very fast and cause no movement on z axis.


Edited 2 time(s). Last edit at 07/26/2010 07:36AM by tv7957ht.
Re: Stranger problem of Z-axis (Solved)
July 26, 2010 09:25AM
Finally, I read a older post [forums.reprap.org] and saw Wade said he set is firmware with "acceleration turned off"
than i go to change my firmware setting and i was so happy its works..... my object finally got corrected printing.

Hope it would help someone if got this problem.
(If you using the "FiveD_GCode_Interpreter " firmware.)

1.) First open your arduino0018 IDE (what i using now.) than open a "configuration.h"

2.) find a command line call #define ACCELERATION_ON and add ( // in-front of this command) --> //#define ACCELERATION_ON
than a firmware will trun-off acceleration when printing.

3.) Save and upload it to your motherboad.

Edited 3 time(s). Last edit at 07/26/2010 09:28AM by tv7957ht.
Sorry, only registered users may post in this forum.

Click here to login