Welcome! Log In Create A New Profile


Trouble with direct drive extruder

Posted by jsadusk 
Trouble with direct drive extruder
October 20, 2010 05:31PM
After months of building I finally have my mendel mostly working, but I'm having trouble with my extruder. I built a direct drive extruder with a dremel splined stepper shaft because I didn't know Wade's existed (and at the time I started Adrian's geared extruder didn't).

It works fine for a while, long enough to get one or two layers of a minimug down, and then plastic stops coming out. No amount of forcing the filament in seems to help. When I reverse the filament out I always see that there are tooth marks on the side up until where it stopped moving, and the side of the filament is stripped at that point. Also it almost always ends up with a larger looking plastic plug on the end of the filament where I'm assuming it entered the thermal barrier.

I'm using Ultimachine black PLA, my thermal barrier is PEEK, and my temp is set to 200 C. I've tried adjusting the distance between the stepper shaft and the bearing and it has no effect. Does anyone know what I can look at to debug this?
Re: Trouble with direct drive extruder
October 20, 2010 06:38PM
Ok I just found the various pages with extruder help and they described my problem exactly. They all suggest raising the temp so that's what I'll try.
Extruder cools down when I hit print
October 20, 2010 10:06PM
Ok, I see why its having problems. I run reprap-host, and in the extruder tab heat the extruder up to my target temp, right now around 230. It extrudes fine at that temp. When I hit print, the extruder goes over to the dump area and hangs for a while. By the time it finishes hanging there, either it can no longer extrude or it gets a layer out and then gets stuck.

I just noticed that if I stop it at that point my temp is down at 186! Is it not running the heater while it hangs over the dump point? What am I doing wrong?
Re: Extruder cools down when I hit print
October 21, 2010 12:00AM
Manually check your G codes and see what the M104 or M109 argument is. They should probably be in the first 20 lines.

I had the same issue when using repsnapper and it turned out the M109 was being set to 0 at the start of each print.

Re: Trouble with direct drive extruder
October 22, 2010 12:57PM
Hmm, now that I think of it, I've been using gcode that was generated when my temperature was set lower. It didn't occur to me that the temperature control commands would be stored in that gcode, so I just set it higher in preferences and reran the same gcode. I'll have a chance to try it again tomorrow and I'll see if regenerating the gcode works better.
Sorry, only registered users may post in this forum.

Click here to login