Welcome! Log In Create A New Profile

Advanced

every layer prints with offset sad smiley

Posted by asrt 
every layer prints with offset sad smiley
May 12, 2016 11:40AM
Hello again smiling smiley
I finally finished my first 3d printer (by the way thanks for yours help winking smiley )
Another problem that occurs is offset after every single layer prints:


My steeper drivers are cold, so its not because of overheating.
Calibration is ok, when I manually checks everything works just fine.

I use Pronterface and Slic3r.

Please help me to solve this (hopefully) last problem.

Edited 2 time(s). Last edit at 05/12/2016 11:41AM by asrt.
Attachments:
open | download - 5mm_Calibration_Steps.gcode (162.6 KB)
Re: every layer prints with offset sad smiley
May 12, 2016 11:47AM
It is shifting in both X and Y. You probably have the acceleration set too high for the speed you're using. You may also need to adjust the motor currents. It also looks like you're over extruding. See [reprap.org]

Edited 1 time(s). Last edit at 05/12/2016 11:48AM by the_digital_dentist.


Son of MegaMax 3D printer: [www.instructables.com]
Ultra MegaMax Dominator 3D printer: [drmrehorst.blogspot.com]
Re: every layer prints with offset sad smiley
May 12, 2016 12:36PM
I adjust motor currents, reduce some extruder disable acceleration in teacup firmware.
Strange thing is that printer stops for a few seconds before layer change, and then move outside of the previous one.
Every layer has the same dimensions, but they are moved.

Edited 4 time(s). Last edit at 05/12/2016 02:37PM by asrt.
Re: every layer prints with offset sad smiley
May 12, 2016 02:38PM
How fast are you trying to print?


Son of MegaMax 3D printer: [www.instructables.com]
Ultra MegaMax Dominator 3D printer: [drmrehorst.blogspot.com]
Re: every layer prints with offset sad smiley
May 12, 2016 03:15PM


also tried lower and higher values, with the same result.

Edited 1 time(s). Last edit at 05/12/2016 03:24PM by asrt.
Re: every layer prints with offset sad smiley
May 12, 2016 04:45PM
Whoa! You gotta crawl before you walk and you gotta walk before you run! Slow it down to a reasonable 40 mm/sec or so, then calibrate everything, and once its is behaving better, then you can start ratcheting up the speed. You may as well crank the acceleration down too. Try setting it to about 500 mm.sec^2.

Make sure the motor pulleys are securely fastened to the motor shafts.

Edited 1 time(s). Last edit at 05/13/2016 09:35PM by the_digital_dentist.


Son of MegaMax 3D printer: [www.instructables.com]
Ultra MegaMax Dominator 3D printer: [drmrehorst.blogspot.com]
Re: every layer prints with offset sad smiley
May 13, 2016 12:27AM
I tried 40 mm/s as you said, even with 3mm/s - with no better result.
My acceleration in teacup is turned off for now.
Re: every layer prints with offset sad smiley
May 13, 2016 12:13PM
Quote
asrt
My acceleration in teacup is turned off for now.

Why?

You need to set maximum acceleration and jerk (not sure if teacup has jerk?) or you'll get skipping.

The S3D troubleshooting page has a section on layer shifting: [www.simplify3d.com]

There are a huge number of possible causes for slipping/misalignment:

* Loose pulley on stepper (tighten grubscrew)
* Stepper driver current too high or too low (adjust)
* Stepper driver not adequately cooled (should have fan cooling)
* Acceleration values set too high (try 500mm/s^2)
* Jerk set too high
* PSU problem (can't supply enough current for everything running at the same time? Check output voltage isn't dropping while printing)
* Probably more causes which I don't remember right now! sad smiley
Re: every layer prints with offset sad smiley
May 13, 2016 07:39PM
Quote

Probably more causes which I don't remember right now!

There's a handy page for that: [reprap.org]

Edited 1 time(s). Last edit at 05/13/2016 07:39PM by JamesK.
Re: every layer prints with offset sad smiley
May 13, 2016 10:46PM
You want to turn acceleration on. It may seem counter intuitive, but by turning it off you are demanding that the machine start and stop instantly. In other words without acceleration handling in the firmware, the acceleration you are demanding of the machine is very high. If you turn it on you can set it to a low value such as 500 mm/s^2 so that it starts slow and ramps up to speed gently.

Also I agree that it looks like you are extruding too much. Try doing a manual extrude of a few cm of filament and measure the amount that is extruded. Also make sure your filament diameter is set in your slicer settings. When you extrude too much plastic the hot end can run into the lower layers and catch. This causes skipped steps like you are experiencing.

If the motors are cold after running for 10 minutes or so then your stepper driver current is probably too low. You generally want to set the drivers to 80% or so of the max rated current for the steppers. This way they will run warm but not hot and will give you nearly full rated torque.
Re: every layer prints with offset sad smiley
May 14, 2016 04:25AM
Now I'm trying manually get what is the problem before next print.
I set Acceleration to Ramping and Maximum Jerk

I have problem to interpret difference between G0 and G1

When i hit:
G91
G0 Y10.0 F3
G90

Then it is fast move from 0 to 10mm

When i type:
G91
G1 Y10.0 F3
G90

Then printer move Y plate really slow (but also accurate)


Can any body tell me what parameter is added (or multiply) to F3 in G0 code that make it faster then G1 ?
Re: every layer prints with offset sad smiley
May 14, 2016 08:38AM
According to the spec, G0 is a rapid move and G1 is a coordinated linear move [reprap.org]. How these are handled varies by firmware, some treat G0 the same as G1, some don't.

The way Teacup handles G0 is to ignore the F parameter, and set feedrate to MAXIMUM_FEEDRATE_X * 2.

If your slicer generates G0 for travel moves when not extruding, it could be that the high feedrate is causing the motor to stall.

Edited 1 time(s). Last edit at 05/14/2016 08:40AM by bobc.


What is Open Source?
What is Open Source Hardware?
Open Source in a nutshell: the Four Freedoms
CC BY-NC is not an Open Source license
Re: every layer prints with offset sad smiley
May 15, 2016 07:24AM
Quote
bobc
The way Teacup handles G0 is to ignore the F parameter, and set feedrate to MAXIMUM_FEEDRATE_X * 2.

... and then limits this to maximum feedrate for each individual axis, so capabilities of the printer, given by MAXIMUM_FEEDRATE_{XYZE} are never exceeded.


Generation 7 Electronics Teacup Firmware RepRap DIY
     
Re: every layer prints with offset sad smiley
May 15, 2016 02:18PM
Thank you all.
Problem was trivial.
In slicer (Printer Settings->General->Firmware->G-code flavor) I had enabled RepRap instead of Teacup eye rolling smiley
If anyone will have same problem, good idea is to check this option before reassemble printer winking smiley
Sorry, only registered users may post in this forum.

Click here to login