Welcome! Log In Create A New Profile


Y-axis Step Issue (Lost in translation)

Posted by Coyote9488 
Y-axis Step Issue (Lost in translation)
June 22, 2016 11:27AM
Hey all-

I have been having some fantastic luck with my Sunhokey Prusa i3 the past few months after installing a new hot end; my prints have been getting better and stronger with respectable bridges/overhangs and great bed adhesion on 3M tape.

Then I decided to upgrade to 3mm glass on thin silicone over my aluminium heated bed, which went well enough after some trail and error. I was printing successfully for a few days/prints with this setup, before a random issue sprouted up (without any significant changes!) seemingly out of the blue. I had been fine tuning my Z height for the best adhesion to the glass, literally 1/8 turns on my adjustment screw here and there, and left a print for a few hours while I was away. I came home to a wonky 40mm E3D V6 fan mount that looked like it was being torn between dimensions... (the part was actually still usable, and is currently on my printer with my new 40mm fan - photos to come)

At this time, I have tried over a half-dozen different prints which all appear to be zig-zagging up the Y-axis... It is not a steady slant or pull in one direction for the duration of the print, but rather a kind of zig-zag pattern when looking up the print vertically.

As for troubleshooting: I've tried oiling my bearings for the belt guide, tightening and loosening the Y axis belt tension many times, moving and re-leveling the printer frame itself, re-leveled the print bed to perfection, checked all connecting rods and bolts for loose nuts and screws, and pulled out some hair... (no I literally pulled a little bit of fine filament hair out from one of the Z steppers...)

What I have not tried is: Removing the glass and silicone to see if the weight of the added bed surface took it's toll on the Y motor after only 4-5 prints, and can no longer bear the grueling weight of a 3mm piece of glass... Nor have I tried to increase the voltage of the stepper motor yet... (I would require a basic instruction on how to accomplish this, if anyone has reason to believe it will help)

I now plead for your collective wisdom and experience to help me overcome this conundrum!

TLDR: Everything was peachy, started Zig-zagging up the Y-axis out of the blue. I've checked the belts and bearings... Help!
Re: Y-axis Step Issue (Lost in translation)
June 22, 2016 02:09PM
Usually when you increase the weight of what's moving on an axis, you have to increase the stepper current.

This assumes the glass itself isn't shifting on the bed.
Re: Y-axis Step Issue (Lost in translation)
June 22, 2016 04:48PM
The pane of glass does not appear to be shifting, but I can definitely add some more bind clips to be sure. I will look into upping the stepper motor current, assuming this has to be done in the Marlin config file?

Thanks for the feedback!
Re: Y-axis Step Issue (Lost in translation)
June 22, 2016 05:37PM
The stepper motor current is the pot on the top of the driver modules that are plugged into your RAMPS board assuming your using the Mega/RAMPS setup since you said Marlin.
Re: Y-axis Step Issue (Lost in translation)
June 23, 2016 07:24AM
Check how much/how easy it is to move the bed on the levelling springs.
If the adjuster screw load is low the bed gets nearer to just resting on the springs so a Y motion can move the whole bed as far as the adjusting screw shaft to hole clearance allows. This may not seem much but can be visible.
This can be made worse by increasing the bed weight (you added glass) and having only a small compression /low load springs (you said you were adjusting the height)
You can improve the situation by making sure the adjusters are rigidly attached at one end. That's probably a nut under the bed so the screw is fixed to the bed.
Also limit the size of hole in the carriage so the screw maintains an accurate position. Alternatively use a larger hole in the carriage and print some adjuster nuts with a tapper that fits in the hole - this will self align under the spring load.
Hope this helps.
Re: Y-axis Step Issue (Lost in translation) SOLVED
June 23, 2016 09:06AM
Hey all!

Thanks for the great feedback, and wonderful suggestions. I have resolved the issue, which seemed to be with the alignment of my Y belt, rubbing slightly against the Motor pulley. I've braced the motor now, and all seems to be well. Just finishing up a 9 hour print without any Y-axis shifting!

In summary, Y-axis off-steps were caused by physical binding or restrictions on the movement of my y-axis. Lube your rails, and make sure your belts are not catching on anything. :-)
Sorry, only registered users may post in this forum.

Click here to login