Welcome! Log In Create A New Profile


Extruder skipping layers

Posted by uorbe001 
Extruder skipping layers
July 15, 2016 09:38AM
A bit of background first: I recently opened another thread where someone pointed out to me there was something weird going on with the extrusion temp on my printer. I looked into it, and found there was a lot of molten plastic all over the extruder block (it was covered on some sort of isolator, so I didn't see it), this had stuck the ceramic cartridge heater and the thermistor (and the thermistor had what looked to me like burn damage/was blackish). All this was due to the tube the heating block is attached to not being properly tightened and plastic coming out from the top of the block.

I tried cleaning it up, and re-tightening and after that I started watching the temp pretty closely. This is when I started experiencing more serious temp issues, I noticed there was a lot of clicking noise (blockage), and I finally found out this clicking noise was happening around the same time my extruder's temperature dropped by around 5C. I was also having some prints during which the printer stopped with a 'thermal runaway' error when the extruder temperature went down about 10C. (around this time I ran out of filament because of all the tests I did and had to get a new spool)

So, I decided to replace everything I could think of. I replaced the tube from the extruder driver gear to the heater block, the heater block itself, the ceramic heater and the thermistor with brand new ones. I also replaced the arduino board because the one I had was a chinese clone and it did misbehave occasionally. Ran some tests with this, and everything seems to be fine, the temperature is pretty stable (it never seems to oscillate more than 1C and when I have noticed it change 1C it's when it just reached the target temperature).

Printing the first 'real' print I had this issue, which I had also noticed before replacing everything but I thought it was due to the heat problems. Occasionally, sometimes on the first layer but most often after a while of printing (seems to be totally random), my extruder will stop extruding plastic. I have tried to watch it when it happens, and it seems to be unable to move the filament for some reason. If I push the filament manually at this point, it will immediately grab the filament and start extruder as usual again, but if I don't, it is usually able to do it on its own in a few seconds (leaving empty layers on the print though).

I have tried tightening/loosening the idler, but it doesn't seem to change anything (it makes it click when this happens if it is tight enough or just slips the filament when it is too loose), and I have also replaced the extruder's driver just in case it was malfunctioning. I have tried different temperatures ranging from 200-210C (PLA, printing temperature being 200-220C according to the manufacturer) and I have noticed no improvement. I also disassembled the extruder, checked that the bearing in the drive mechanism was fine (oiled it) and cleaned up the driver gear just in case, none of the above seem to do any good. My extruder is an MK9 (direct-drive), and the filament brand I'm using is supposed to be one of those 'premium' filaments, this reel is new (bought it when I ran out of it with the temp issues I was having) and as such I haven't successfully used it before but I have used the same brand and color without this issue.

Can someone think of something I might be missing or I should test? The only thing I haven't yet replaced is the extruder nozzle, but I don't think the problem is in the nozzle itself (I can try to replace it though). All I can think of is that it is either a problem with the drive mechanism (I have tried pulling from the filament against the driver running and it doesn't slip out) or the filament spool is a dud, but I might be missing something else. Please help?
Sorry, only registered users may post in this forum.

Click here to login