Welcome! Log In Create A New Profile



Posted by anode505 
January 05, 2011 06:35PM
Any Mac people out there?

Just gearing up (and waiting for UPS to bring me my mendel and filament)

But whats the easiest to get going with software-wise?

I have RepRap Host working (sans machine comms) But it seems an item or two isn't working. In the 'nesting/bed' view, there is a view & manipulate menus. View doesn't do anything. Manipulate seems to function OK. Normal?

If I choose more then 1 when loading a new STL, it seems to lock up for a spell and only puts one on the 'bed'

Is there a way to reset the view to default after doing the fun rotating/zooming? (is it in the non-functional view menu item?)

Is there an auto-nest feature?

When I export to a G Code file I get a ton of temp files. At least I think they are temp files. Shouldn't they have been cleaned up?

Any 3D scanners that won't break the bank? (Mac friendly)

Re: Macs?
January 05, 2011 06:44PM
Install Linux
Re: Macs?
January 05, 2011 06:49PM
Linux is a trainwreck. Computers are supposed to make life easier. Hunting down prerequisites (and the possibilities of doing that generations back) shouldn't have to be done these days.

(now before you go off on me, why would you come into a Mac post just to say that? For the troll bait? just to be a DB? To prove how much more geeky you are then me?)
Re: Macs?
January 05, 2011 06:59PM
I eventually want to use my mac to print (pc atm) and i am going to try and get replicator G to work, the newest version has mendel settings although they haven't been extensively tested, would be awesome to be able to print of SD card, and have skeinforge in the same software.

Linux i tried once... unless you know what you're doing and understand how to do things in the terminal window i would leave it because it was a bit of a headache and i never got reprap running, much easier to get running on XP. couldn't get reprap running on mac (which was a whiles ago, there might be a newer version)
Re: Macs?
January 05, 2011 07:12PM
I'm ok with Linux. Modified and compiled my own kernel for a specific oddball task a few years back. Just don't see why in the 21st century we still need to spend that much time on a command line, compiling programs, etc. Heck, why not just toss out the CAD and just open emacs, pico or joe and write the g-code from scratch?

And the Mac is BSD based (another *nix OS)

I have an XP netbook I can use if the Mac route fails, but I need that for work (PLC programing pays the bills here) and a bit scared to mess with it, with software of this type.
Re: Macs?
January 05, 2011 07:36PM
FWIW: RepRap is starting to appear as packages for some Linux distros (eg: Jonathan Marsden's excellent work on Ubuntu packages) so you don't need to do any compiling.
Re: Macs?
January 05, 2011 10:48PM
I use a MacBook pro, but I boot ubuntu and run skeinforge and gcdump for reprapping. Skeinforge works fine on the Mac, and the reprap host runs, but I prefer gcdump. For most design work I use Alibre in a win vm, but occasionally I use Blender to edit meshes. YMMV.

Basically, use whichever OS matches the software you want to run, unless you're great at re compiling stuff for your favorite OS. Jmarsden's ubuntu reprap repo makes it really easy.

Re: Macs?
January 05, 2011 10:57PM
I know that this is a change of subject, but which windows VM are you using to using to run Alibre on. I have a short go with Virtual Box and windows XP to run a demo version of the latest version of Alibre but it would not display the graphics correctly on my system... (The 2D select would not work and it fell over when selecting 3D mode if I remember correctly).

Any advice as it would save me purchasing a Windows system just to run the Personal Edition of Alibre.
Re: Macs?
January 06, 2011 12:46AM
Back on topic - I use a Mac just fine. ReplicatorG works, RepSnapper works*. RepRap Host works, but has some glitches with button sizes in the UI on OSX. It also has some other quirks that I'm not sure are specific to running on OSX or not - for instance, I always have to quit and restart reprap host after generating gcode or else it tends to lockup - quitting also cleans up all those temp files.

As far as 3D scanning goes - I've been totally unsuccessful at trying to get ANY open source 3D scanning software to work. I tried MakerScanner and Grape3D and failed. It's frustrated me so much that I've decided to start writing my own at [github.com] (although it doesn't work yet either lol)

* RepSnapper from [sites.google.com] works, however when I click the icon it crashes when I try to connect. However for some reason, if you run it from terminal it works fine. ie. /Applications/RepSnapper.app/Contents/MacOS/repsnapper

Tony Buser http://tonybuser.com * http://reprap.org/wiki/User:Tbuser#Projects
Re: Macs?
January 08, 2011 03:09AM
It would help a lot if people state what Mac and OS system they're using. I've been using a MacPro 8-core and MacBook Air both running Leopard (10.5.8) with a Mendel with Techzone Gen 3 remix electronics. The GUI of the reprap host works but it has a lot of bugs. I tried a few versions and settled on the latest 64-bit version dated in July since seems to be the only one that can reliable send G-codes to the Mendel. On the MacPro, the viewer freezes after rotating the view consistently while on the Air it seems to work most of the time. But on the Air, I can't communicate to the Mendel at all.

After converting an STL to G-Codes with the Reprap host, During the process, the Disply Path option works only sometimes. Most of the time, the window never opens. When it finishes, I have to quit the host in order to put the temp files together into one G-code file. Then I rerun the host and read in the G-Code for sending to the Mendel. Often times, the GUI doesn't show progress or estimate of completion time. The best way to see the progress is to look at the console. With simple shapes, the host does a fairly good job in creating g-codes. For complicated shapes, like surface redering of MRI scans, it usually makes a mistakes.

I found one compiled version of Repsnapper that works with the Leopard: [sites.google.com]. The others that are available crashes upon running. I wanted to compile it myself but XCODE, which is needed to do it, is only available for Snow Leopard. RepSnapper is very fast and produces good G-codes most of the time but also makes frequent errors. It's a good thing that it has a very good viewer for the G-codes so that you can verify it before sending it to the printer. One common mistake is that the infill goes all the way to the perimiter often leading to jagged edges. It communicates very well with the Mendel, perhaps even better than the Reprap host.

The best G-codes are the ones produced by Skeinforge. I've been using ReplicatorG 023 with Skeinforge 35 to produce G-codes. I had to disable the acceleration option in the firmware and also enable the option to separate z-modes in Replicator G to make it work. If not done, the z stepper doesn't respond since Skeinforge sends the z moves with the x, y moves and specifies rates that are too fast. The other thing to do is to turn on limits in Skeinforge and set the z limit to 1 mm/s or so depending on how fast your z-axis can move. I use either RepSnapper or Reprap to send the G-code file to Mendel for printing.
Re: Macs?
January 08, 2011 10:37AM
Thanks brnrd & gr0k !

Some other Qs.

Why use ReplicatorG & Skeinforge? Why not just go straight to Skeinforge?

Been playing around with all of them. RepG looks 'finished' RepRap Host looks good but seems a bit buggy, Skeinforge looks basic/proof of concept (not that I care about the eye candy)

With Skeinforge,
1 I've noticed that the scroll bars sometimes don't work (though resizing the window sometimes fixes it)
2 I can see each layer in one window, but when it generated the 3D view (after gcode?) it shows all layers at once.

Simulation runs WAY to fast. (just making small test parts, though needed parts)
How do you add a second, third, etc parts to the nest?

General Qs
I've noticed (Skeinforge) that the inner layers come up 'semi-hollow', how do you make a solid part?
The SD slot, can I load a gcode and run it without a PC connected?
And what are you guys using to make your STLs? (I'm using TurboCAD, and maybe ViaCAD)
Re: Macs?
January 08, 2011 11:13AM
ReplicatorG puts a nice GUI in front of Skeinforge as far as I can tell. I don't know how to position and orient the part on the bed with Skeinforge and it's easier to do it with ReplicatorG. In theory, ReplicatorG can also send the G-code file to the printer.

I have the same problem with the simulator in ReplicatorG. It would be nice if there's an option to slow it down. If you want to see the G-Code, you can do it in Skeinforge by turning on two options in the Analyze tab: Skeiniso and Skeinlayer. The best interactive viewer of the three is RepSnapper.

I'm also trying to figure out how to add more parts to the build in Skeinforge/ReplicatorG. I would love to be able to print multiple parts overnight. You can do it with Reprap host and RepSnapper.

In Skeinforge, there's an option in the Fill dialog for Infill Solidity Ratio. I would guess that you would make a solid part if this is set to 1 but I haven't tried it yet.

I use SolidWorks. It's expensive but this is what I've been using for my work. I played with Google Sketch and it's very good for a free software but I haven't made anything with it.
Re: Macs?
January 08, 2011 12:13PM
I mainly use a really old MacBookPro running OSX 10.6.4 and really don't have any problems getting it to talk to the printer. Just make sure you have the most recent ftdi driver from: [www.ftdichip.com]

Yeah I have the same display bugs with skeinforge. Often when I change to a different tool, I have to resize the window in order to get it to render all of the form. I don't know if that is a bug specific to osx or not.

Tony Buser http://tonybuser.com * http://reprap.org/wiki/User:Tbuser#Projects
Re: Macs?
February 26, 2011 02:49PM
Perhaps I need to update to Snow Leopard then. The latest ReplicatorG (024) still doesn't work. I tried different reprap host firmware and even the firmware that came with ReplicatorG and the best I can do is control the printer. But I can't print. I wonder if you're using different motherboard (electronics). I'm using Techzone Gen 3 remix.

I only use Skeinlayer since the control for Skeiniso is not very intuitive to me. So, I haven't seen the same issues.

As far as printing multiple parts, I do it from Solidworks by making an assembly of parts and making sure that their bottoms are all coincident and are on the Z-axis origin.
Re: Macs?
February 27, 2011 03:28PM
For those of us with a number of old ppc Macs that run Tiger, I found that the "Mac ports" work just fine and allow the newer java and python builds to install and be used by skienforge etc. This way one only needs to configure the X11 shell to launch.

If one really wants to use the host software, Installing and running from the "Netbeans" IDE works after a fashion. I never could get the host software to run as a native java app.

Sorry, only registered users may post in this forum.

Click here to login