Z axis not moving
October 19, 2016 01:33PM
I have been through some troubles getting to this point. Fried a couple voltage regulators, ramps board. I now have everything connected and my Z motors wont move. All other motors move and home. Endstops are hooked up as always open and trigger when pressed. All the lights come on with ramps test. I get 12v at the vmot pin on my Z driver and I have the voltage set around 1.2v as I have a4998 drivers and 2a steppers. I have also tried another driver with the same result. The motors work when plugged into the other axis ports. Not the lcd nor Repetier Host can move the Z. I have my settings to 2mm and 50mm with acceleration at 100 I believe. The screws move freely by hand, no binding. What else can I try?


Edited 4 time(s). Last edit at 10/19/2016 01:53PM by Bmeehan19.
Re: Z axis not moving
October 19, 2016 02:44PM
If the motors work on other outputs, it has to be somewhere else.

Z Motors are usually wired in parallel to the same motor (some wire them in series).

Where they join together can be problematic - if one or other set of wires was reversed being assembled, that would explain it.

It's got to be somewhere between the Arduino and the motor itself, so start by swapping the Z Pololu into a different position. Pololus as well at first. That should tell you quickly if the Pololu is faulty.

Then check the cable isn't joined together wrong.. Try a single motor on the Z Axis, that will tell you if the Arduino and Pololu are fine, and it's a problem on the cable joining the two motors.

If the single motor moves, Arduino and Pololu are OK. If not, one or other (MAYBE BOTH) must be faulty.

I'm betting it's an issue on the motors being wired together incorrectly. Easily done on a production line.

Edited 1 time(s). Last edit at 10/19/2016 02:47PM by DragonFire.
Re: Z axis not moving
October 19, 2016 02:55PM
I tried the pololu on another axis and it worked. I tried a single z motor on the z axis and it did not move. I did this with each motor. I also triedeach z motor on the X axis where each z moror worked as it should. My ramps board has two sets of pins to plug two separate motors into that are run off the Z driver. I tried reversing one motor plug than the other and nothing worked. So im not sure if the wiring could be wrong. I used and led and put it in each side of the connector for the motors and it lit up on both right plugs and both left plugs and no power in the middle. If I spin one Z motor while they are both plugged in the other will move along with it. When power is applied I can move both motors with little felt resistance.

Edited 1 time(s). Last edit at 10/19/2016 03:10PM by Bmeehan19.
Re: Z axis not moving
October 19, 2016 06:00PM
Well I decided to take a close look at the arduino soldered pins and found a super thin hair of soldier bridging two points on the underside. Got it removed and now the Z axis moves as it should. Heres a pic. Maybe you will know exactly what these solder points do.

Another indicator that something was fixed as after I removed the solder bridge, LED 1 on my ramps lights up. I didnt before except for initial plug in. It is dimmer than when it flashes so there may be another issue somewhere that may show up down the road.

Edited 1 time(s). Last edit at 10/19/2016 06:14PM by Bmeehan19.
open | download - IMG_4110.JPG (51.7 KB)
Re: Z axis not moving
October 19, 2016 06:46PM
No idea pal. I just happen to have a fresh unopened Mega Rev 3 for a project... no sign of those shorted pads, just the group of four below and to the left of them. Can't help with that question. May be an earlier revision? Does look the area around the LEDs, but I can't tell exactly what your pins connect to. Suggest you quiz over at Arduino, they might know.
Re: Z axis not moving
October 19, 2016 07:48PM
If you've go your RAMPS board from China (e.g. AliExpress), or indirectly from China (e.g. eBay, dx.com, gearbest.com), then you're exposed to risk. There are *no* guarantees, and plenty of unscrupulous people. I'm sure that there are vendors who sell untested boards. And I suspect that there are probably vendors who acquire known faulty boards and sell them as "Excellent quality, brand new".

The only way to avoid this is to buy from a reputable vendor in your own country.
Re: Z axis not moving
October 19, 2016 07:57PM
Good job Bryan. Dry joints and solder bridges are always a possibility, but it's not always something that comes to mind. Thanks for reminding us.
Sorry, only registered users may post in this forum.

Click here to login