Welcome! Log In Create A New Profile


Prusa Ramps 1.4 Home Problems

Posted by haydnsamuels 
Prusa Ramps 1.4 Home Problems
December 15, 2016 06:14AM
Hi I have a problem with my x axis Everything was working ok then i tried to print something and the printer tried to print the item outside the print area on the x axis max side.
When i try to home the printer it would move the y axis then the x axis then the z axis Now it just does the the y axis and the z axis. The x axis just stays were it is.
The x axis does move but is limited to about the center location when moving in the min direction.
Ive tried a different driver and different stepper motor and i tried disconnecting endstop on x axis.
Ive got a spare ramps board to try and spare endstops.
Im reluctant to flash firmware as im unsure of the settings used as i bought this from someone and not sure of heat sensor used.
Using M119 when moving away from endstops i get:

x_max: open
y_min: open
z_min: open

When I home the printer i get:

x_max: open

Im thinking it could be endstop

Enstops are mechanical using signal and com

Im a little wary to change things as the wiring is a mess well the printers a mess but it was working just about so left it as it was untill i gained enough knowledge to reflash from scratch.

Also is it possible to change the language without completely reflashing as Ive got discount display but everything is in polish and would like it to be english

Thank You

Re: Prusa Ramps 1.4 Home Problems
December 15, 2016 08:49AM
Looks to me like it doesn't change state whether the switch is engaged or not. I'd suspect wiring or the switch itself.

I'd rewire it. And if it doesn't change, try another switch.
Re: Prusa Ramps 1.4 Home Problems
December 15, 2016 12:53PM
Yeah got some spare switches I'll wire one and try it. Was trying to avoid that as i read you could fry the Arduino if wired wrong.
Its not the wiring as it was working ok and the connections are surprisingly good lol
I was thinking the switch or component on the ramps board connected to the x min endstop connection.
My Plan was to install the marlin firmware on a spare Arduino board i have then install it with the spare ramps and switch everything over.
however not got around to working everything out to install and configure marlin. suppose this will push me to learn
Re: Prusa Ramps 1.4 Home Problems
December 15, 2016 01:41PM
Send M503 and it will return the minimum settings that you can use to get the machine moving the same when configuring a new version of marlin.
Re: Prusa Ramps 1.4 Home Problems
December 15, 2016 06:25PM
Thanks tried a new switch but things are still the same. I tested the old switch with multimeter continuity test.
When Open it makes a ciruit when closed it breaks the circuit, which is strange as the endstops are the same just 2 connections and the other switches are opposite.
the new switch has 3 connections ive gone with when switch pressed it makes a circuit but its still the same.
ill have to try the other ramps board but im dreading it lol. when changed the switch the wire fell apart there was 5 jumper wires soldered in series lol
its all a bodge i should have bought a kit lol
theres no order to the colour of wires lol i think now its either settings become corrupted in firmware faulty ramps or faulty arduino.
tried as you suggested this is the results:
>>> M503
echoconfused smileyteps per unit:
echo: M92 X78.74 Y78.74 Z533.33 E100.00
echo:Maximum feedrates (mm/s):
echo: M203 X500.00 Y500.00 Z5.00 E25.00
echo:Maximum Acceleration (mm/s2):
echo: M201 X9000 Y9000 Z100 E10000
echo:Acceleration: S=acceleration, T=retract acceleration
echo: M204 S3000.00 T3000.00
echo:Advanced variables: S=Min feedrate (mm/s), T=Min travel feedrate (mm/s), B=minimum segment time (ms), X=maximum XY jerk (mm/s), Z=maximum Z jerk (mm/s), E=maximum E jerk (mm/s)
echo: M205 S0.00 T0.00 B20000 X20.00 Z0.40 E5.00
echo:Home offset (mm):
echo: M206 X0.00 Y0.00 Z0.00
echotongue sticking out smileyID settings:
echo: M301 P22.20 I1.08 D114.00

one strange thing is if it hits the opposite x max it tries to continue makes a noise then going back the other way allows it to travel a little further in the x min direction
anyway thanks a lot i appreciate your help
Re: Prusa Ramps 1.4 Home Problems
December 15, 2016 06:37PM
Do you have min and max endstops fitted?
It should not be reporting that you have min and max triggered at the same time,
Re: Prusa Ramps 1.4 Home Problems
December 15, 2016 07:40PM
Hi No Just Min EndStops. To be Honest I Dont Know What Is In The Settings Either How Its Been Set Up.
Everything Was Working Ok Then It Just Decided To Move Everything About 75 mm Towards X Max Direction. And Didnt Move When Sending Home Command
I Did Notice It Was Saying Max Triggered I Thought That Was Normal. The Y And Z Is Fine It Behaves As Expected.
I Do Notice That After Switching On No Axis Will Move I Click Home Then They Start Working. I Dont Know If That Is Common To Happen.
I Might Switch The X And Y EndStop Jumpers Then If The X Works And Y Develops The X Symptoms I Know Its The Ramps Board Or Settings In The Firmware.
Re: Prusa Ramps 1.4 Home Problems
December 16, 2016 04:03AM
If you only have mins fitted then only the mins should be triggered.

If both min and max is triggered then the printer is confused.
Recheck your wiring and recheck your firmware.
Re: Prusa Ramps 1.4 Home Problems
December 16, 2016 08:59PM
Yeah Well Ive Got Some Old Firmware The Lad Used, Unfortunately They Are for The Old Card He Was Using Melzi But The Config Shows Me His Settings Not That I Should Use Them LOL

I Checked All The Wiring Tied Everything Up. Ive Managed To Get It To Print Something However When It Goes To Home It Continues To Try And Go Further Even Though The Switch Is Triggered.
It Makes A Horrible Noise Like The Belt Is Slipping. It Does It On The Z And Y Axsis Now, But Other Than That It Works.
Looking Through The Lads Config There Is A Setting To Set The Min Travel After Home And He Has Put -30 For The Y And Z Axsis.
Not Sure What This Achieves I Would Of Thought Min Travel After Homing Would Be Zero.

Anyway Tried Installing Marlin On Spare Arduino And Ramps Board But No Success And Kept Getting Heater Failed Error So Went Back To Old Arduino And Ramps.
Will just Have To Work Everything Out Wiring Steppers Working Out Travel Setting Drivers Etc.
Did Intend To Do it In My Own Time But This Has Forced The Issue.

Checked Drivers All 0.9 Volt Z Was 1.6 Volt I Take It This Is Because Its Driving Two Motors
The Lad has Put All Z Connections On One Ramp Motor Connection Dont Think this Makes a Difference As Its Only Using One Driver For The Two.

Found The Answer To Changing Language Via LCD It Cant Be Done Because Theres Not Enough Room To Store All Languases So Your Choice Is Compiled And Uploaded.

Im Going To Do Some Research To start Afresh And See If I Can Alter The -30 Home Settings For Now.
Noticed In The Old Firmware A Setting Was Set To Store To Eprom So Take This Means You Can Make Changes Without Reprogramming.

Thanks For All The Help I Appreciate It

Re: Prusa Ramps 1.4 Home Problems
December 16, 2016 09:15PM
If the switch is OK, it could be the case that the connector to RAMPs is not, or the actual RAMPS itself is damaged (short circuit on the back between pins).

One way to test is to swap the X motor and X endstop cables with another axis, and try homing again.

If the new axis likewise stalls (wants to keep moving past the endstop) then it's a fault with the RAMPs. Probably a short circuit on the back of the board (which most people don't look at, as it means powering off, and lifting the RAMPs off the Arduino carefully).

Make sure all the pins are going to the right place when plugging RAMPs back in to the Arduino.

Final point - it helps a lot if you label all the motor and endstop cables before unplugging them. Saves plugging them into the wrong place by mistake.
Re: Prusa Ramps 1.4 Home Problems
December 20, 2016 07:42PM
Ok So The Plot Thickens Tried Different Ramps Board And Everything Was Working Ok Apart From Over Running On The X And Y Axsis When I Click Home.
Just To point Out Ive Tried Different Switches And If I Use The Manual Controls In Repetier Host Or Pronter Face It Stops And Behaves As It Should.
However Now It Has Started Printing Wrong. Prints Are Nice But It Is Printing Different Size Than File. For Instance A Bush I Printed Instead Of Being 20mm x 30mm It Is Printing 10mm x 40mm Seems Bizarre.
The Time This All Started I Did Discover A Virus On My Computer And Just wondering If This Could Be The Cause. For Things To Just Change For No Reason At All. One Thing That Comes To Mind Was Repetier Popping Up saying Save New Settings Which Contained X Y Z Values I Clicked Cancel And Thought So More.

Would It Be Possible To Make Changes To The Firmware Via Repetier.

I Need To Make Fresh Firmware But Not Sure Quite What Im Doing Yet.

Im Compotent At Electronics, Programming and Pic Micros But Not So With Arduino.

My Biggest Problem Is Setting The Actual Print Area And End Stops And Setting The Home Position Cause Im Not Quite Sure What They Do.

Im A Bit Worried About Loosing The Settings.

I Can Set The Glcd Controller And Sound Cause I Understand Whats Required.

The Lad I Bought The Printer Off Had Melzi Board And Transferred The Setting To Ramps Ive Attached The Config File Mabe Someone Could See Something Thats Not Right

Thank You for Any Help Im At The End Of My Teather
open | download - Configuration.h (33 KB)
open | download - Configuration_adv.h (20.4 KB)
Re: Prusa Ramps 1.4 Home Problems
December 30, 2016 07:58PM
OK Got Printer Back To Normal I Ripped Out Old Wiring And Totally Rewired Printer It Homes Perfect No Horrible Noise Or Trying To Continue Past The End Stop.
Only Other Thing I Did Was Turn End Stop Wiring Around. Now Common Is On Signal Pin And NC Is On Signal This Seems To Work Not Sure Why But It Does.
Tuned Stepper Drivers.
X Y And Z Where Showing 1.2 Volt I Tuned Them To 0.7 Volt
Extruder Was Showing 1.6 Volt I Tuned This To 0.7 Volt And Later Tuned To 1.2 Volt Cause Extruder Seemed To Struggle At 0.7 Volt

Two Problems Im Left With Are:

1. When I Connect To Printer Via Computer And Try To Move Axis (Any Axis) It Wont Move Manually I Have To Click Each Axis Click Home For Each Axis Or Home For All Axis
At Some Point An Axis Will Move Then All Axis Will Move.

I Can Work Around This But Would Like To Understand Why It Happens.

The Other Thing Is The Printer Prints Incorrectly As I've Mentioned Before.

While Printing A Bush The Printer Prints It 10 mm X 40 mm Instead Of 20 mm X 30 mm

Im Thinking It Seems Like 10 mm Is Being Taken From The X Axis And Added To The Z Axis Im Not Sure If This Is The Case

Im Not Sure If Its To Do With Slicing Or To Do With The Printer.

Ive Attached A G.Code File If Someone Could Print It To See What Size It Is I Would Be Greatfull

Cant Attach File Its To Large If Someone Could Message Me I Could Email The File

Thanks Haydn
Sorry, only registered users may post in this forum.

Click here to login