Welcome! Log In Create A New Profile

Advanced

Z axis goes up instead of down when going "home" prusa i3 JG Aurora

Posted by MadisOmega 
Z axis goes up instead of down when going "home" prusa i3 JG Aurora
January 18, 2017 05:14PM
Hello all thank you for your help in advance.

First off, I am a newbie to 3D printing.. so if I use the wrong terminology I apologize.. I'll do my best to pick it up quickly.... this is my first printer and it was a DIY box of parts... went together pretty easily even though the instructions were awful .. (youtube videos with no words)... however it all mechanically works smoothly and I think we have it assembled correctly... our current problem is that when the printer seeks home the Z axis goes UP instead of down toward the limit switches... when it reaches the top it rattles and shakes until I unplug it... I have checked all the connections and nothing seems to be reversed and the X and Y axis's seem to do the correct thing so the overall polarity seems to be correct... any suggestions? if you are familiar with the JG Aurora board this is the Red board not the Black one... after some reading the Red seems to be the newer version.

Thank you again,
JD
Re: Z axis goes up instead of down when going "home" prusa i3 JG Aurora
January 20, 2017 12:20AM
reverse z axis stepper connections it should move down when homed
Re: Z axis goes up instead of down when going "home" prusa i3 JG Aurora
January 24, 2017 12:22PM
Thank you Roger123D, I assumed it was something like that but I could use a little more specific guidance if possible ... I believe it is a Ramps 1.4 board (red)... it has white connectors on the board that have little ears on them allowing the cable to only be inserted one way... the stepper motors have the same type of cabling and ears ... there are 4 wires...Red,Black,White and Yellow (in that order on each cable) should I just shave the little ears off the cable end and flip flop it or should I cut wires and spice... if so what color wires do I cut and swap? ... one other note is that there is only one plug on the circuit board so there is a splice in the cable seperating it into two .. one for each stepper... I assume that is the common way but thought it may be pertinant

Thank you
M
Re: Z axis goes up instead of down when going "home" prusa i3 JG Aurora
January 24, 2017 02:21PM
Easy way is just to flip the connector 180 and plug it back in if you can (WITHOUT POWER ON!)
Otherwise you have to flip the direction in the firmware.
Re: Z axis goes up instead of down when going "home" prusa i3 JG Aurora
January 24, 2017 05:37PM
Thank you Floyd, so just shave the little ears off so it will fit in that way?
Re: Z axis goes up instead of down when going "home" prusa i3 JG Aurora
January 24, 2017 06:37PM
Sure. Most reprap printers have flat connectors but there are some that come with the keyed connectors.
Just make sure you have no power going to the printer when you flip it.
Re: Z axis goes up instead of down when going "home" prusa i3 JG Aurora
January 25, 2017 10:11AM
Thank you Floyd, I will try that this afternoon and see what I get. Take care and have a great day
Re: Z axis goes up instead of down when going "home" prusa i3 JG Aurora
January 25, 2017 04:17PM
Bit late, to save damaging the connector, use a small flat blade screwdriver to push in the pin that holds the contact in place.

Also check the z- endstop, that could be causing issues like mine did the other day.
Re: Z axis goes up instead of down when going "home" prusa i3 JG Aurora
January 25, 2017 06:55PM
Thanks Graywolf.... at the risk of sounding like a true newbie by "endstop" are you referring to the limit switch or something else entirely?
Re: Z axis goes up instead of down when going "home" prusa i3 JG Aurora
January 26, 2017 08:03AM
Yes the limit switch is also called an endstop.
Re: Z axis goes up instead of down when going "home" prusa i3 JG Aurora
January 30, 2017 07:52PM
Good evening all,
So before the update just wanted to offer a quick shout out THANK YOU to Roger123D, Floyd and GraywolF for there help... I had to reverse the wiring on not only the Z axis but also on the X axis and the Extruder motor, your suggestions worked awesome!! The printer goes to home no problem... However a new issue has arisen,, I would call it an interesting yet not really unexpected result of switching the wires and only seems to have affected the Z axis although I cannot be certain just yet..,,,,,.When I try to print something and the Z should be moving UP to print the next layer, in in fact goes DOWN and starts to scrape the tape off of the bed. Any advice would be appreciated ...I'm thinking maybe there is a software adjustment somewhere but I am completely lost in that realm ... let me know what you think.. Take care,... M
Re: Z axis goes up instead of down when going "home" prusa i3 JG Aurora
January 30, 2017 08:21PM
When it homes the Z axis it goes down right?
Not sure why it would be advancing down instead of up.
When you jog the machine manually with software does going Z+ make the nozzle rise?
Re: Z axis goes up instead of down when going "home" prusa i3 JG Aurora
January 31, 2017 12:57AM
You did calibrate the z-offset correctly, did you?
Re: Z axis goes up instead of down when going "home" prusa i3 JG Aurora
February 01, 2017 08:41AM
Good morning.. there are no instructions with this model, so I have no idea how to calibrate it.. so in answer to your question..., No I didn't.... is that something you may be able to talk me through, because there are no directions I thought I would try the forum before changing anything serious in the settings,not knowing if I would be able to get it back to the factory setting or not... although there does seem to be a "failsafe" option that would seem to indicate that it would restore to factory condition... any advise is appreciated.. Thank you
Sorry, only registered users may post in this forum.

Click here to login