Z_MIN_PROBE_USES_Z_MIN_ENDSTOP_PIN question
July 22, 2017 07:23AM
Good afternoon

I was wondering if anyone could put me right on a question I have. It's mostly about my inability to figure out, what should be easy, but I can't figure it out 100%, and would like to know before going forward as I would hate to damage my board.

I am updating my Marlin to 1.1.4, everything is going okay, I particularly like the "Auto-Calibration" feature. My problem is that I would like to know if I have "Z_MIN_PROBE_USES_Z_MIN_ENDSTOP_PIN" or not? I have tried to look at the older Marlin version that's already installed, but for the life of me I just can't find it. Strangely, the older version did have a calibrate option!!

I have attached a picture of my board, it's a MKS GEN V1.1 with the layout of the different pins illustrated. I have also attached a picture of where my Z probe is located.

So my question is, if I look at the picture of the board, I see that the probe is plugged into the Z - slot, is that what is meant by Z_MIN_PROBE_USES_Z_MIN_ENDSTOP_PIN? so in my case I would un-comment #define Z_MIN_PROBE_USES_Z_MIN_ENDSTOP_PIN

Also, can anyone tell me a good board to use instead of this one, or is this one okay? I have a kossel delta and wondered if there was a better board to use.

Thank you for your time and help in this matter.

Bob
Attachments:
open | download - Board.jpg (348 KB)
open | download - Z-Probe.jpg (88.5 KB)
Re: Z_MIN_PROBE_USES_Z_MIN_ENDSTOP_PIN question
July 22, 2017 07:58AM
It appears you may have a Delta Printer.

Edited 2 time(s). Last edit at 07/22/2017 08:02AM by Roberts_Clif.
Re: Z_MIN_PROBE_USES_Z_MIN_ENDSTOP_PIN question
July 22, 2017 08:04AM
Yes indeed I do thumbs up

Tiz a thing of beauty
Re: Z_MIN_PROBE_USES_Z_MIN_ENDSTOP_PIN question
July 22, 2017 08:32AM
I knew enough to see that, will have to leave this to a delta owner.

in believe it uses

#define Z_MIN_PROBE_PLUG

SEE
[github.com]

and
[www.appropedia.org]

Wish I could be of more Help.
Re: Z_MIN_PROBE_USES_Z_MIN_ENDSTOP_PIN question
July 24, 2017 08:48AM
Quote
Roberts_Clif


Wish I could be of more Help.

Actually you were, I had a look at some of these link you added, and that took me somewhere else, then that went over there....Anyway, I can confirm that should anyone have the same question about the "Z_MIN_PROBE_USES_Z_MIN_ENDSTOP_PIN" I can tell you that it does indeed use the Z - MIN pin. In the end I thought I had most of the information needed to make a 100% correct guess, but was only 90% sure, so I bit the bullet and tested it, the probe worked and treat with that configuration. I know I could have wrecked the board, but by the time I had come to that conclusion, I was ready to try anything anyway hot smiley

Thanks very much for your help and assistance, much appreciated.

Regards
Bob
Sorry, only registered users may post in this forum.

Click here to login