SD card not working with long wire
August 06, 2017 09:50AM
Hey there,

I like to have my cables organized. But the wires from my board (mks gen L) to my controller (reprapdiscount smart controller) are very short so I bought longer ones.
I have a big machine so the short wires were 60cm and the new long ones are 120cm.

The problem: When I connect both long wires to the board and the lcd I will get a SD init fail means the lcd recognizes the inserted SD Card ("SD inserted") but when I go to the menu it says No SD card.

Now it gets strange: if I only connect the EXP1 with the long wire and the EXP2 with a short one everything works fine.

Things I've tried so far:
- Checked both wires
- decreased SPI speed to 1/8
- shorted a long wire to ~90cm (minimum lenght I need)
- tried two different SD cards
But nothing worked

My Printer is a FLsun cube and I updated it to Marlin V1.1.4

Could someone help me solve this?

Edited 1 time(s). Last edit at 08/06/2017 11:02AM by Schild0r.
Re: SD card not working with long wire
August 06, 2017 01:45PM
It could be as simple as the ribbon cable wire size is too small for the length of the run.

OR

Electrical energy (EFI) can cause many problems, with computers in close proximity being coupled with bed Heater, Nozzle Heater and steppers only aggravates the situation.
A test would be to place the LCD / SD card as far away from the Printer as possible, and if the LCD / SD works there then I would suspect EFI problems.

Once you determine the cause the easier it is the fix.
Re: SD card not working with long wire
August 06, 2017 02:17PM
I already tried wrapping aluminium foil around the cables but it did not help..
Re: SD card not working with long wire
August 06, 2017 03:31PM
It's to be expected that long wires to the SD card won't work. The SPI protocol that most electronics use to interface to the SD card is not designed to run over any significant distance.

There are two things you can try to allow a greater length:

1. Use thicker cable. Ordinary 1.27mm pitch ribbon cable is 28awg AFAIR, but you can also get 26awg.

2. Reduce the maximum SPI clock rate that your firmware uses.

Edited 1 time(s). Last edit at 08/06/2017 03:31PM by dc42.



Large delta printer [miscsolutions.wordpress.com], E3D tool changer, Robotdigg SCARA printer, Crane Quad and Ormerod

Disclosure: I design Duet electronics and work on RepRapFirmware, [duet3d.com].
Re: SD card not working with long wire
August 07, 2017 04:50AM
Quote

2. Reduce the maximum SPI clock rate that your firmware uses.
Isnt that what I did by uncommenting the line
#define SPI_SPEED SPI_EIGHTH_SPEED?

I will look for a 26awg 10 pin cable but those are wider aren't they? Or can I use the same connectors as with the 28awg flat cables?

But thanks for the info

Edited 1 time(s). Last edit at 08/07/2017 04:58AM by Schild0r.
Sorry, only registered users may post in this forum.

Click here to login