can control the motor in Pronterface but g code command not executed
August 23, 2017 09:09AM
Dear All,

I'm a newbie here, I'm using Ramps 1.4 to control my stepper motor. I found that I can control the motor by pressing the buttons on Pronterface UI (for example, by pressing the z motion button in the Pronterface UI my stepper motor can run). However, if I just type G0 Z10 or other G code in the Pronterface UI and click send, the G code is not executed.

I'm using Marlin 1.0.2 firmware, Win10 OS.

How should I send some simple G code commands to the machine? Thank you in advance for the help.
VDX
Re: can control the motor in Pronterface but g code command not executed
August 23, 2017 10:08AM
... try sending "M114" or "M119" - if you don't get response from the firmare, then your sender/receiver-functions won't work ...


Viktor
--------
Aufruf zum Projekt "Müll-freie Meere" - [reprap.org] -- Deutsche Facebook-Gruppe - [www.facebook.com]

Call for the project "garbage-free seas" - [reprap.org]
Re: can control the motor in Pronterface but g code command not executed
August 23, 2017 10:49AM
Thank you for the suggestions. I tried M114 and M119 and I can get response from the firmware.

When I connect the machine to Pronterface, send g0 z10, it will run for the first time. When i try to send another g0 z10, it won't run. I have to disconnect and reconnect the machine to let it execute the g code, but again, it only response to the first g code that I send, and not response for my second g code command. Meanwhile, I can still use the button on Pronterface to control the z motor.

Any suggestions? Thank you.
VDX
Re: can control the motor in Pronterface but g code command not executed
August 23, 2017 10:54AM
... this is simple - if you move it to Z=10, then a new move to this same position won't do anything (it's already there) ... move it with "G0 Z20" away, then "G0 Z10" will work again winking smiley


Viktor
--------
Aufruf zum Projekt "Müll-freie Meere" - [reprap.org] -- Deutsche Facebook-Gruppe - [www.facebook.com]

Call for the project "garbage-free seas" - [reprap.org]
VDX
Re: can control the motor in Pronterface but g code command not executed
August 23, 2017 10:56AM
... this will be different, if you change the mode from "absolute" (G90) to "relative" - send "G91", then every "G0 Z10" will move the Z-axis 10mm in the same direction winking smiley


Viktor
--------
Aufruf zum Projekt "Müll-freie Meere" - [reprap.org] -- Deutsche Facebook-Gruppe - [www.facebook.com]

Call for the project "garbage-free seas" - [reprap.org]
Re: can control the motor in Pronterface but g code command not executed
August 23, 2017 10:57AM
Oh I see.... Thank you so much for the help! Sorry for the stupid mistakesmileys with beer
VDX
Re: can control the motor in Pronterface but g code command not executed
August 24, 2017 04:06AM
... there weren't so much stupid questions, but much more stupid answers !! cool smiley


Viktor
--------
Aufruf zum Projekt "Müll-freie Meere" - [reprap.org] -- Deutsche Facebook-Gruppe - [www.facebook.com]

Call for the project "garbage-free seas" - [reprap.org]
Sorry, only registered users may post in this forum.

Click here to login