Welcome! Log In Create A New Profile


Prusa i3 - Rumba board - Diamond hotend

Posted by DKLeader 
Prusa i3 - Rumba board - Diamond hotend
October 11, 2017 04:04PM

My problem is that I cannot get my step motors activated / running. This being xyz and extruders.
Seems they are not getting energized / signal.

Following is working:
Fans, hotend and heattbed.
Sending M119 shows that endstops are working and set correct.

I have the following setup :
A Hictop Prusa i3
It has been modified with a Rumba board and Diamond hotend.
I have installed Marlin software using Arduino 1.8.4
Marlin firmware downloaded from [reprap.org]
In "Confiiguration.h" I have selected the correct board.
Disabled the endstops not used.

I have attached a few pictures from the setup and my configuration.h.

Hope someone could give me some ideas on what could be testet.

Best Regards
open | download - Photo-2017-10-11-21-48-45_4985 (Small).JPG (100.1 KB)
open | download - Photo-2017-10-11-21-48-12_4984 (Small).JPG (95.1 KB)
open | download - Photo-2017-10-11-21-47-38_4983 (Small).JPG (71.9 KB)
open | download - Photo-2017-10-11-20-03-32_4982 (Small).JPG (96.2 KB)
open | download - Photo-2017-10-11-20-03-15_4981 (Small).JPG (79.4 KB)
open | download - Photo-2017-10-11-20-02-55_4980 (Small).JPG (62.6 KB)
open | download - Configuration.h (35.6 KB)
Re: Prusa i3 - Rumba board - Diamond hotend
October 11, 2017 06:11PM
Marlin has a safety interlock to prevent cold extrusion, so you have to heat up your hot-end above 170 degrees.

I don't think that applies to the XYZ motors though. Fans and hotend working means your 12V supply is good. Are your stepper drivers plugged in the right way round? When the motors are on but not moving, are they easy to move? You should see 12V across one or other pair of wires to each stepper when energised but stopped.
Re: Prusa i3 - Rumba board - Diamond hotend
October 14, 2017 09:32AM
I have tried with temp above 170 as knew about this interlock - this did not change the situation.

The stepper drivers are turned in the correct direction.
The motors can easily be moved even when they have received "on" signal.

Will try to measure if there is 12 V on one or the other pair of wires.

Best regards
Re: Prusa i3 - Rumba board - Diamond hotend
October 17, 2017 03:00PM
Still need some help on this - have not managed to get any of the stepper motors up running.

I have now measured on the stepper driver :
VDD - GND : 4,94 V
VMOT - GND : 24 V (my power supply is 24 V)

Between potmeter and ground I measured : 0,596 V

Best Regards
Re: Prusa i3 - Rumba board - Diamond hotend
October 17, 2017 04:45PM
Solved this one.

It seems to be all my stepper drivers that are burnt.
Took a new one and got x stepper motor running.

Looking back at when they could have been damaged/burnt I have concluded below:

When I wanted to upgrade to diamond hotend I bought a set with a Arduino Mega board, Ramps 1.4 board and extender board.
Even though they, at the store, were informed that my Hictop Prusa i3 system is a 24 V system they did not react and informed me that Mega and Ramps are for 12 V.
After this I got my Rumba board, but used the stepper drivers which already have been used on the Ramps card. Guess they got damaged when the Ramps card was burnt.

Hopefully all will be OK once I have some new stepper drivers.
Re: Prusa i3 - Rumba board - Diamond hotend
October 17, 2017 04:49PM
"Disabled the endstops not used" how?

what does m119 say?

If any say triggered you cant move that axis

Are you steppers wired correctly? From you images. Take out the black and green stepper wires, test you have continuity from black to green (ie that it forms one coil of the stepper) and repeat for red to blue (the second coil of the stepper)
Sorry, only registered users may post in this forum.

Click here to login