Welcome! Log In Create A New Profile


Z axis won't work - is it programming or the board?

Posted by ChaChaHula 
Z axis won't work - is it programming or the board?
December 09, 2017 06:29PM
I have a new Reprap Guru Prusa V2 and am running Marlan v3 and I have not been able to get the z axis to work. I put it together last weekend and the power supply failed immediately (it was defective making loud noises out of the box). I have a new power supply but I can not get the z axis to work. The wiring was done correctly when I put it together.

I've done extensive testing and it seems to be either a board problem or a software problem. I'm not very knowledgeable on coding - I can update and fix it if I know what the problem and solution are, but I don't know how to figure out if there is a problem with the code.

This is what's happening:

On the board - the z motor slot doesn't seem to work with any of the motors (all the motors work). I do get the error "Endstops hit: z:0.00" when I try to move the z axis even when the z stop and when all of the end stops are not activated. The z endstop works in the x and y slots and the z endstop slot works for the x and y axis. I can detect no problem with any of the ports or the hardware regarding any of the endstops.

When I put the x and y motors into the z motor slots they did not work but the z motors worked fine in the x and y slots.

Also, I get the info on the log that says "Endstops hit: z:0.00" when the arduino is plugged in and either there is power on or power off and all of the cords are working correctly.

To me, it seems like the board slots for the z axis motor are broken or there is some coding or set up problem I can't figure out. How can I figure this out? Any ideas on testing or what the problem could be?

Testing I've done:
What's working - all Endstops, the heated bed, the nozzle, the fan, the power supply and all motors for sure work. I've extensively tested all of this.
I get the same issue on apple or windows. I'm trying to run it on the Repeater - Host Mac 1.0.2 on an iMac running OS X El Capitan version 10.11.6
I have put a new stepper driver into the z axis slots to see if it was the stepper driver. There was no change.
It's not mechanical - all the mechanics are working and in alignment. Again, extensive.
Not electrical - all cords are working and installed in correct ports and voltage has been tested. Again, extensive.
The feedrates are fine - they are quite low.
I've uninstalled and reinstalled both Arduino and Repetier to completely reset them.
I've checked the printer settings and slicer settings many times.
I checked the Marlin code to make sure the z-stop wasn't programed to always be on.

Any help is greatly appreciated!

Thank you!

Edited 2 time(s). Last edit at 12/10/2017 02:08PM by ChaChaHula.
Re: X axis won't work - is it programming or the board?
December 09, 2017 10:32PM
I dont know what your running but Marlan v3 doesn't exist, well isn't official anyways.
real official marlin is at 1.1.6 [github.com]

which axis is it? subject says X, body say Z?

all endstops are working? I suspect not, especially with the error "Endstops hit: z:0.00" which means the machine thinks that Z min endstop is triggered

The led's may be lit on the end stops, but that does not mean they are working. eg you may have placed the endstop plug in the incorrect place, on zmax vs zmin
Use M119 to see what the controller thinks of the endstops.
Re: X axis won't work - is it programming or the board?
December 10, 2017 02:21AM
Did you check the electronics for shortcuts, solderblobs or cold joints? You might have a shortcut in the z-endstop header.
Re: X axis won't work - is it programming or the board?
December 10, 2017 02:14PM
Hi Dust and O_lampe-

Great ideas. I'm going to try the V2 1.8.5 software, which is Reprap's Marlan. I'm pretty sure V3 works - because I downloaded it from Reprap's google drive. Also, I will try Marlan (and not Reprap's Marlan) to see if that works too.

I did look and there doesn't seem to be any shortcuts in the z-endstop header.

I know all of the endstops work because I switched them all around and tested them. So I put the z endstop on the y axis - ran the y axis and then put my finger on the endstop and it stopped immediately. All of the endstops are in the correct slots. I've checked this many times. Also, I made sure all of the endstops were not being touched and then I tried to run the z axis and still got the endstop problem.


Edited 2 time(s). Last edit at 12/10/2017 02:47PM by ChaChaHula.
Re: X axis won't work - is it programming or the board?
December 10, 2017 11:14PM
Well, none of this worked. Also, the M119 says the endstops are working fine. I think it must be the board.
Re: Z axis won't work - is it programming or the board?
December 10, 2017 11:30PM
The "Reprap Guru Prusa V2" page says this is just a ramps 1.4 controller

so why not use the ramps test firmware


Things to note: It turns on all heaters but doesn't monitor temperature , so remove hotend and heated bed
It ignores endstops
It makes all axis move back and forth, so start with all axis away from end stops or limits of travel
Sorry, only registered users may post in this forum.

Click here to login