Welcome! Log In Create A New Profile


Configuring Marlin

Posted by FallingShells 
Configuring Marlin
February 07, 2018 02:03PM
To anyone who can help me, I have a prusa i3 DIY kit that came with default firmware pre-installed on a MKS Gen-2Z V1.1 controller. The control board had a catastrophic failure when a ferrite bead shorted and caused an arc across a second ferrite bead and fried the five volt circuitry. Now I have the next generation up in control board (V1.2) and marlin is giving me issues with the auto-leveling sections of code and a few other things in configuration. I'm not by any means a programmer, but I do know electronics and mechanics. I cannot locate the original firmware and the printer itself has worked fine for three years. The bed has to be leveled with my own two hands while the steppers are disabled, or rather it had to be in the past, using thumb screws and springs on the buildplate. there may be other issues with the program, but I'd like to tackle each one at a time. If you need the code to look at, I can post it at request. Thanks again. -Fallin
Re: Configuring Marlin
February 07, 2018 11:21PM
Was the original firmware Marlin? What is working ok? What is not? Do the steppers work and the limits? Did the printer have auto level or is it something your now adding. A list of what doesn't work and config file will help.
Re: Configuring Marlin
February 08, 2018 08:55AM
You need to edit the Configuration.h file in the Marlin source code.

You need data to put in there, since you said it was a DIY Prusa i3, this data should be out there, probably under DIY Prusa i3.

You need the Arduino compiler/IDE, then open marlin in there, set your COM port to the usb connector to the board. I would simply build the default Marlin code and try to upload it. Just start the baord to see if it works, but dont try to RUN anything yet.

Then you can try to edit the Configuration.h file.

Heres a general outline of steps, but remember this uses RAMPS, not your board, so try to find all the data bits for your board and printer configuration.

Once you get the basics running again, then you can add new cool things, like autoleveling, etc.

Good Luck.
Re: Configuring Marlin
February 08, 2018 11:22AM
In order of appearance: I have no idea what the original firmware was, only that Marlin was a common one compatible with my board. The PSU and all of my components work fine I just had a freak accident on the original board and I now have a functional replacement. The printer itself never had auto leveling and I have no intentions on adding it, the arduino compiler is just not having anything to do with the auto leveling command lines and I don't know how to bypass them. I will include the current Configuration.h file as an attachment. The original DIY PRUSA i3 Configuration.h file does exist, however arduino and Marlin claim the commands in this file are out of date and that I should update the file or use the one provided with Marlin. I do have the correct configuration parameters set up in my new Configuration.h file (the one that comes with marlin), but I'm not having a problem with the parameters, rather a few lines that don't even apply to my printer. If you need a picture of the printer and it's set up, I will provide that too. Again I thank you for taking time to help me. -Fallin
open | download - Configuration.h (64.8 KB)
open | download - 2018-02-08_1121.png (285.7 KB)
open | download - 2018-02-08_1119.png (224 KB)
Re: Configuring Marlin
February 08, 2018 08:11PM
I am sorry, in that Configuration.h I don't see where any auto bed leveling is activated.

Are you sure you are in the correct project? This config is for Marlin 1.1.7, you have all that source code right? It should compile straight out of the zip package, have you done that?

Can you screenshot the compile error?

The only thing I can see is this, are you sure its supposed to be MOTHERBOARD_MKS_13? I think it should be MOTHERBOARD_MKS_GEN_L if its v1.2 ?
Re: Configuring Marlin
February 09, 2018 11:46AM
Well now that you mention it, I daresay that I'm not entirely certain I've selected the correct motherboard in the configuration... In the compiling bit, I can open everything, but it gives me the error when I try to verify and if i try to transfer it to the device. The error has something to do with a G26 code and the auto leveling bits. I just changed the motherboard to the L one and had two smaller hitches that I could fix, but I'm still getting the issue attached. The picture is the problem that leads to other problems. If i comment out the line, it gives me a whole slew of other errors. I actually don't know what to do with the code to prevent or circumvent these errors. I will attach the updated Configuration.h. The transfer protocol runs with an ATmega2560. Any help is still appreciated and thank you. -Fallin'
open | download - 2018-02-09_1135.png (102.5 KB)
open | download - Configuration.h (64.8 KB)
Re: Configuring Marlin
February 09, 2018 01:37PM
Ok, thats a interesting clue.

Just a heads up, I will not be able to look at this tonite, tomorrow at the earliest.
Re: Configuring Marlin
February 10, 2018 12:13PM

2 Problems;

1) about line 790 should read;

#define X_MAX_POS X_BED_SIZE 200
#define Y_MAX_POS Y_BED_SIZE 200

Change the size at lines 783/784

2) Uncomment the bed leveling '#if' test at line 885, and the matching '#endif' at 908
Commenting these out turns on the various params contained therein.

If I made a mistake you should be able to see these using a Diff tool (like WinMerge, or WinDiff or similar) between your config file and the original config file.

I have attached a corrected config file.

Good Luck.
open | download - Configuration.h (64.8 KB)
Re: Configuring Marlin
February 11, 2018 08:06PM
You, ode kind one, art mine savior! I got an error on first validation that claimed I couldn't have an endif without an if. I commented out the one it indicated and the error it spawned, and it compiled successfully. I managed to install the firmware onto my printer and I can now receive data from it in the serial monitor. Here is where I incur a new problem. If the screen is hooked up, it will claim within five seconds that the kill switch has been pressed. Mind you the LCD does not yet come on, as I haven't figured out how to set it up, much less attempted to configure it, but when the LCD and SD Reader plugs are disconnected, there is no kill command executed. It just says that the SD failed to initiate. I've never printed anything from my computer before, only the SD via the LCD controls. I tried to connect to both of the utilities I have on my computer and neither are having it. I believe it may be possible that the LCD reset button is acting as a negative trigger kill switch, not that I have any Idea how to make it into the reset switch of old, nor do I know how to disable the kill command in the code. Thank you for what you have done for me thus far, the printer is another step closer to printing. -Fallin'
Sorry, only registered users may post in this forum.

Click here to login