May 22, 2018 02:39PM
Hi i am new to hobby, I've been given a prusa knockoff , the main board (Meltzi) is not working right, I can home all axis but that seems to be all, I would like to replace board but have no idea how to program it, I understand using Arduino and Marlin but do not understand necessary changes needed, I understand how to compile and upload. I quess my main question is it possible to buy the boards pre programed ? I am not able to get original copy of program.
Thanks for any help you can offer.
May 22, 2018 05:18PM
Most of us on this Forum would help you to get the correct configurations for your 3D Printer. This can go quick or at times can take quite a lot of time.
It would help to know more information about your Prusa knockoff.
Marlin is fairly simple to configure and works with

BOARD_MELZI Sanguino pins_MELZI.h Melzi
BOARD_MELZI_CREALITY Sanguino pins_MELZI_CREALITY.h Melzi for Creality
BOARD_MELZI_MAKR3D Sanguino pins_MELZI_MAKR3D.h Melzi "MaKr3d"
BOARD_MELZI_MALYAN Sanguino pins_MELZI_MALYAN.h Melzi for Malyan
BOARD_MELZI_TRONXY Sanguino pins_MELZI_TRONXY.h Melzi for Tronxy

RepRap Prusa Calculator.
May 23, 2018 02:16AM
You could try reading out the memory of the Melzi board. Connect it via USB and use pronterface to send M503. The answer will tell you a lot about the current settings. ( copy&paste it in a .txt file for later reference )

When homing works but nothing else, it might be possible to get the Melzi board running.
Tell us more about the temperature readings ( after homing ) or error messages.

My guess is, there's something wrong with endstop config and homing/stepper direction. ( a common problem for newbies )
May 23, 2018 04:40PM
Thank you for the two replies, I will dig a little further, the homing works perfectly, but i had no heat to the board or extruder, after much fooling around they started heating but went far past settings before I shut it down. I definately will try your solutions.
Thanks Terry
May 23, 2018 05:37PM

As I find information will post here
Check the processor on your board to see if it is the ATmega644 or ATmega1284.

#define BOARD_MELZI 63 // Melzi
#define BOARD_MELZI_MAKR3D 66 // Melzi with ATmega1284 (MaKr3d version)
May 23, 2018 07:06PM
echoconfused smileyteps per unit:
echo: M92 X100.00 Y100.00 Z400.00 E90.00
echo:Maximum feedrates (mm/s):
echo: M203 X400.00 Y400.00 Z4.00 E50.00
echo:Maximum Acceleration (mm/s2):
echo: M201 X3000 Y3000 Z1000 E5000
echo:Acceleration: S=acceleration, T=retract acceleration
echo: M204 S1000.00 T3000.00
echo:Advanced variables: S=Min feedrate (mm/s), T=Min travel feedrate (mm/s), B=minimum segment time (ms), X=maximum XY jerk (mm/s), Z=maximum Z jerk (mm/s), E=maximum E jerk (mm/s)
echo: M205 S0.00 T0.00 B20000 X20.00 Z0.40 E5.00
echo:Home offset (mm):
echo: M206 X0.00 Y0.00 Z0.00
echotongue sticking out smileyID settings:
echo: M301 P22.20 I1.08 D114.00
Hi this is what I got after downloading Pronterface and typing M503, makes no sense to me. Still homes properly including z height. No heat to bed or extruder. Just tried it again, bed and extruder stated heating, extruder set at 190c, went on past and I stopped it at 245c was still going higher.

Edited 1 time(s). Last edit at 05/23/2018 07:15PM by skaha.
May 23, 2018 09:27PM
Most of your numbers are identical to my 3D Printers. As we have different Lead-Screws and Belt Pulleys The differences are normal.

Try to send a M502 ("Reset firmware defaults") then M500 ("Store Settings") Reboot 3D Printer. This will re-set the printer to Firmware defaults.

And try to heat extruder again.

Edited 1 time(s). Last edit at 05/23/2018 09:49PM by Roberts_Clif.
May 24, 2018 02:06AM
maybe the thermistors for bed and hotend are in the wrong terminal? With pronterface connected, you could heat up the extruder and see, which temperature changes in pronterface. ( the temperature of your fingers will be enough to heat the extruder up a bit )
May 24, 2018 02:04PM
Hi still having heating problems, I think the board is a Melzi sanquino pins. I have tried all the suggestions but the problem is still with the plate and extruder, I let it go on up and the extruder reached cut out temp and shut off.
I think this is beyond me, but thanks for trying to help.
Sorry, only registered users may post in this forum.

Click here to login