Welcome! Log In Create A New Profile


Z axis motors keep pulsing ( TMC 2130 )

Posted by Gu_Seiffer 
Z axis motors keep pulsing ( TMC 2130 )
June 20, 2018 12:18AM
Hello there! I'm building my first 3D printer, and decided to - apparently - make a "really" complicated one. I decided to use TMC 2130 drivers, and I had some problems already (Wiring them and configuring some stuff) but I managed to solve all of my problems except one:

The Z Motors are "pulsing".

I don't know why this is happening, but it simply is. It has some strange pulsing sound, the motor seems to work for 1 second, then it pulses and it "deactivates", then it pulses again and it "activates" again. (If I try to spin it by hand when that happens, at everytime it "activates", I can't spin it, and then it "deactivates" and I can spin it by hand. Like current keeps going on and off the motors)
It happens with both of the motors, but at different "frequencies" (when one deactivates, the other activates). If I plug the Z axis motors on X and Y, they work beautifully, but If I plug the X motor on Z, it has the same pulsing problem). The fans also spin slower when the motors pulse.

My Hardware
Arduino Mega 2560 + Ramps 1.4
5x tmc 2130 v1.1 ( one for each stepper motor. But the same error seems to happen when I put two motors in one Driver)
12v 240w 20a Power Supply
Z motors: [pt.aliexpress.com]
X, Y and E motors: [pt.aliexpress.com]

Things I tried to do to solve this issue:
  • ... Changing the power supply for a more powerfull one ( the one on My Anycubic i3 Mega) - Didn't work
  • ... Turning the Motors Current down ( My stepper motors are 1.7a, so I put 800mA (800x1.41= 1128, so way under the limit. I even tried going all the way down to 200) - Also didn't work

I only tried to change the motors current though, so maybe there's another thing I should do? Does it seem like a firmware or hardware issue? (I'm using Marlin 1.1.8).

I attached 2 videos, one after telling the printer to "autohome" where you can clearly see how one turns and the other stops. And the other where you can hear the noise it makes.
Sorry about anything. It's my first post here.
open | download - WhatsApp Image 2018-06-20 at 1.04.50 AM.jpeg (128.4 KB)
open | download - WhatsApp Video 2018-06-20 at 1.05.41 AM (1).mp4 (715.8 KB)
open | download - WhatsApp Video 2018-06-20 at 1.14.34 AM (1).mp4 (457.7 KB)
Re: Z axis motors keep pulsing ( TMC 2130 )
June 20, 2018 01:54AM
The only difference I see between Z-axis and XY axis is the steps/mm. They are usually much higher for Z-axis and Marlin on Atmega2560 might have problems with it.
Just for fun set Z-steps/mm to the same value as XY and see, if the problem disappears.
Re: Z axis motors keep pulsing ( TMC 2130 )
June 20, 2018 02:05AM
reading between the lines you have one stepper driver per Z stepper, so your using E1 as Z1 ?

Where are the cs lines for Z0 and Z1 attached?

image isnt clear, no configuration.h

I ask as people like to try and use d0 and d1 on aux-1, but you cant as they interfere with usb communications.
Re: Z axis motors keep pulsing ( TMC 2130 )
June 20, 2018 07:51AM
By "pulsing" do you mean a clicking/thumping noise? That could be skipped steps, a symptom of too low driver current or too high jerk/accel, or motor binding etc. Skipped steps seem fairly common on the z axis on these forums.
Re: Z axis motors keep pulsing ( TMC 2130 )
June 20, 2018 09:32AM
Not really clicking. You can see/hear in the video I attached, it isn't a clicking sound, it really does look like a "pulse" of energy. I've tried putting the motors on their limit ( about 1200mA ) but still had the same problem. Even if i remove the entire X axis so the motors spin freely, they still have the same problem. Thanks for the help!
Re: Z axis motors keep pulsing ( TMC 2130 )
June 21, 2018 03:15AM
Ahh, ok, sorry I didn't see the video before. That's a bit odd, the axis motors look like they're taking turns in the first video. The second video, it's hard to tell but that sort of sounds like a motor skipping steps, where it tries to step forward, but then lurches back as the rotor falls too far out of phase.

You say the same thing happens even when the X axis is removed (i.e the motors are on their own, not attached to or driving anything)? In that case it could be loose/faulty wiring on one of the phases. I recall someone had a similar issue recently when one of their coils was shorted inside the motor, but the same thing could be happening with the connector.

Do the motors/driviers work when you test them on a different axis? I.e. try the z axis motors on the Y axis driver, try running the X/Y motor on the Z axis driver, try the Z axis drivers in the X/Y axis spot and see if you can narrow down the issue.
Sorry, only registered users may post in this forum.

Click here to login