Welcome! Log In Create A New Profile



Posted by liljuanton 
July 21, 2018 07:22PM
Hey There,

So I'm having an interesting issue after installing and configuring my authentic BLTOUCH Smart V2 with my FT-5 R2.
I currently am using a titan aero/ E3D V6 hotend/extruder, TMC2208 Drivers, Original MKS Board, 713 ultra lite x carriage, 713 Maker all metal gantry, Plus a couple more things (but those should be the important ones. My BLTOUCH is Mounted to the left of my hotend, and connected to my Z_MIN PIN.

The issue Im having is related to bed leveling. Im able to Home Z Axis without issue. When I send a G29 my Printer starts probing the rear left corner and then proceeds to complete the next 4 points in the x axis without issue. It then moves forward in the Y axis and proceeds to complete the next 4 points in the x axis, again without issue. Then it moves to what is the 9th probing position in a total of what should be 16 position and it immediately deploys the probe before and then Immediately retracts it and displays a probing failed message.

I've enabled leveling debugging but I can't seem to figure out where things go wrong. I'm currently on the most current bugfix1.1 Marlin, I was on a version from a month ago and the same issue was happens on that version.

Current CONFIG.h file.

Video of issue

P.S. Ive searched an can't find anyone with the same or similar enough issue to resolve this. I've spent the better part of this week trying to solve it myself, but I've had to suck up my pride and ask for help.

Thanks for any help

Edited 1 time(s). Last edit at 07/21/2018 07:24PM by liljuanton.
July 21, 2018 08:38PM
Some additional info printer is able to complete M48 the entire width of the printer (x-axis) bed without issue, However failed instantly beyond 153 on the Y AXIS with this error

Send: M48 V4 P4
Recv: M48 Z-Probe Repeatability Test
Recv: Positioning the probe...
Recv: Errorconfused smileyTOP called because of BLTouch error - restart with M999
Recv: Errortongue sticking out smileyrinter stopped due to errors. Fix the error and use M999 to restart. (Temperature is reset. Set it after restarting)
Recv: echo:busy: processing
Recv: echo:busy: processing
Recv: Bed X: 272.000 Y: 154.000 Z: 0.000
Recv: Errortongue sticking out smileyrobing failed
Recv: X:221.00 Y:154.00 Z:18.01 E:0.00 Count X:17680 Y:12320 Z:7202
Recv: ok
July 24, 2018 12:22PM
Issue has been isolated to a bad signal connection, this was discovered by disabling motors and manually moving why axes while bombarding the printer with M119 G-Code and found a position where it would go from open to triggered, if I bent the cable and tried again I could get it to return to a open state. So then I ran a continuity test and on the first cable I tested (the white signal wire from BLTOUCH) I found the offending wire. I then made a quick patch harness out of some spare wire and bypassed the original wiring and attempted G29 and it completed without issue. I then opened up my cable chain and found where the issue was and completed a temp fix while my replacement extension cable comes from S.Korea. buttoned it all back up an guess what??.......it works now.
Sorry, only registered users may post in this forum.

Click here to login