Welcome! Log In Create A New Profile


New Thermal Bed not heating

Posted by Yarnlover 
New Thermal Bed not heating
September 21, 2018 07:28AM
I am very new to 3D printing. Two months ago I purchased a Prusa I3 kit from reprapguru, assembled it, and was printing fine (I’m very pleased with it). After a couple weeks of working well, I noticed that the thermal bed was no longer holding the set temp (60), and was continuing to increase in temp throughout the print. I use Repetier Host, and could see that in Bed Output, that instead of cycling on and off to heat, once the bed reached the set temp, no output was registering but the bed temp slowly steadily increased - up to at least 90 degrees before I stopped it. The bed also did not stop heating if I tried to turn it off using Repetier. I shared this info with REPRAPGURU and they sent me a new thermal bed.

Yesterday I received the new bed and installed it. The thermistor reads room temp (20), but I can not get the bed to heat when connected to the RAMPS board. I read somewhere about connecting the thermal bed ends directly to the power supply, and it immediately began to heat up (and Repetier /thermistor recorded increase in temp), so I think that means the thermal bed is working and connections are fine. Re-connected it to the RAMPS board. No response when trying to get it to heat in Repetier (The way I’m doing this is under manual controls, clicking on the bed heater icon so red line disappears - normally started heating to set temp in the past, but nothing happens now, and the fan doesn’t kick on in the power supply either, like it used to or does when heating the hot end.).

I re-uploaded the Marlin firmware to the ramps board. Heater still not working.

Please help!
Re: New Thermal Bed not heating
September 21, 2018 09:04AM
Your original fault sounds like the bed mosfet on the ramps board has gone short circuit thus supplying power all the time to the bed.
If the bed heats ok when conected direct to the 12 volts,then the bed is ok, it is likely the larger poly fuse on the ramps has gone open circuit now, this supplies 12 volts to the bed mosfet.

Edited 1 time(s). Last edit at 09/21/2018 09:04AM by obewan.
Re: New Thermal Bed not heating
September 21, 2018 09:46AM
Thank you Obewan. I’m assuming this means I should get a new ramps board?
Sorry, only registered users may post in this forum.

Click here to login