Welcome! Log In Create A New Profile

Advanced

Finally upgraded z-axis on p3steel, but I am having stepping issues now. Seeking help.

Posted by ML3D 
Finally upgraded z-axis on p3steel, but I am having stepping issues now. Seeking help.
December 30, 2018 01:31AM
Hello.

So, I have a p3steel that I cobbled together a number of years ago. I have finally upgraded the z axis by installing 8mm lead screws in place of the M4 threaded rods

I am running RAMPS with DRV8825 drivers. PSU is 12 volt. The motors are Kysan Nema 17 with 1.8 degree and 1.5A per phase.
[www.kysanelectronics.com]

Both motors are running off of the one Z stepper driver and they are connected directly to the Ramps board, so in parallel.

Marlin version is 1.0.2 ( I plan on updating this but I was trying to get the old version of the firmware working first )

Previously, my default axis steps for Z in Marlin was set to 8000. This matched Prusa's calculator for 1.8, M5 with 1/32 microstepping.

Now here's my problem:
I've installed 8mm lead screws with a 2mm pitch. However, when I set Marlin to the calculated value of 3200, 10mm becomes 30mm of z movement.

Essentially, I've had to set it to 800 steps in order to get 10mm of travel from Repetier manual control. ( which the calculators suggest is only 1/8 step ) I've attempted to change the step jumpers to 1/16, but it didn't change anything.

I've also doubled the vref value on the stepper driver from .79 to 1.6, but this didn't change the stepping and distance traveled.

So what I don't understand is why 1/32 stepping was working fine before and now it seems stuck at 1/8. Is it because the motors are under powered for the lead screws?

I'm a bit stumped here. Maybe I'm missing something that's right in front of me?

Any thoughts, advice or feedback is appreciated. Thanks.
Re: Finally upgraded z-axis on p3steel, but I am having stepping issues now. Seeking help.
December 30, 2018 03:07AM
And how many starts is the 8mm rod with 2mm pitch?

A single start would be 3200, but.. I suspect its a 4 start, that divides the steps/mm by 4 giving 800 eg [www.aliexpress.com]

Ie its doing as it should.

Edited 2 time(s). Last edit at 12/30/2018 03:13AM by Dust.
That was a good choice of lead screws, though I agree with DUST your lead screw most probably is a T8-8 Trapezoidal 4 start Lead screw.

It is a Simple check to see which it is.
A single start lead screw will rise 2mm from a single 360 degree rotation ("one revolution").
A four start lead screw will rise 8mm from a single 360 degree rotation ("one revolution").

My Problems Using T8-8 Trapezoidal 4 start Lead screws

I personally chose the single start lead screw that rise 2mm from a single 360 degree rotation.
As I had the TT8-8 rapezoidal 4 start Lead screws and in my 3D Printer they caused me more headaches than they were worth.
Every time I would have one 3D Printer running next to the other that was not running the Z-Axis would have to be re-aligned before next use...
The vibrations from the working 3D Printer would cause the 3D Printer not running Z-Axis lead screws to turn at a random rate.
This was not a linear motion one lead screw would turn more than the other causing constant alignment of the Dual Stepper Z-Axis before a print.

See Video
T8-8 Trapezoidal Lead-screw Nut Dropping with Gravity
[youtu.be]

The T8-2 Trapezoidal Single Start lead screws have not shown to be prone the this problem for me.


Electronics Technician / Computer Programmer
Re: Finally upgraded z-axis on p3steel, but I am having stepping issues now. Seeking help.
December 30, 2018 10:36AM
Thank you Dust and Roberts Cliff. I'm sure you must be right about the lead screws being "4 start".

This was my first ever lead screw purchase and I have to be honest, I didn't know about different 'start' values. The product listing I bought didn't mention start count anywhere and the calculators don't mention it, although they do mention height per revolution.

However, wouldn't changing the stepping on the driver require a value change in the firmware? I changed to 1/16 and it didn't seem to alter the distance moved. ( At least I changed the pin settings to 1/16 )

As for the alignment issue, I did get the anti-backlash nuts, so hopefully that will keep them where they stop.
Sorry, only registered users may post in this forum.

Click here to login