Welcome! Log In Create A New Profile

Advanced

initial success...then failure

Posted by honerboy 
initial success...then failure
February 18, 2019 04:30PM
hi - first post here - just so everyone understands - i am retired and in my 60's - i am brand new to 3d printing - my family bought me one for my birthday in december - they know i like to tinker and make stuff and i was very happy to receive this gift - while i consider myself semi tech savvy i don't know how to write code - usually i "play" with a program and gradually get used to it's particular quirks - so i assembled this reprapguru 3d printer in early january - the reprapguru website has downloads for arduino and repetier, which i installed and got the printer to answer commands as far as moving the extruder head in all directions - i then started with sketchup and designed a fitting for my shop vac - had a lot of problems as it's a open tube but the slicer (repetier came with cura engine and slic3r) - they both wanted to put in solid layers at certain levels of the tube - so i printed out a couple of them and cut out the 2 layers (after much setting work i got the solid pieces down to 2 and figured that's as good as i could do right now) - the pieces work great but i thought i'd look for another slicer to see if i could get rid of those 2 layers - i downloaded cura 3 (i think that's what it was) and installed it - the printer has not worked since - i uninstalled cura 3, but it still won't print right with either slic3r or cura engine - so i uninstalled repetier - since i had changed so many settings in it"s 2 slicers i figured i'd start over - i ran the initial arduino setup but still can't get it to print correctly - the extruder starts printing in the air about 2-3 mm above the plate and now it's having thermal runaway 0 (which i believe is the plate...right?) issues - i've spent the better part of 4 days working on this to no improvement - some questions

1) does running the arduino initial upload again erase the previous install and start fresh...

2) if not how do i completely reset the board as new....

3) why the "air" printing? after it worked great initially (i have slightly tried to tweek the g code but honestly i don't know what i'm doing) - i tried changing some of the z coordinates but then the printer would only print the first layer over and over....i can see in print preview the object is 2-3 mm above plate but in object placement view it's flat on the deck

4) could all of this be because of the cura 3 install?...-

5) why after it working would it now have thermal issues - i watch the temps as it's printing and they don't seem to skew off the set temp more than a degree -

any help appreciated - thanks in advance

Edited 2 time(s). Last edit at 02/18/2019 05:40PM by honerboy.
Re: initial success...then failure
February 18, 2019 10:28PM
Setting up Cura for a printer that isn't in its catalog can be a tricky thing to do. Try Slic3r. It's a lot easier to deal with. You can go back to Cura and mess around once you've got the machine working with slic3r and are sure the printer is doing what it is supposed to.

Part of the problem may be using sketchup for the CAD model. Sketchup is a great program and does a lot of cool stuff, but it isn't good for modeling for 3D printing. It is the only CAD software I know of that routinely requires you to repair the STL files before you can print them. If you want to try CAD with a similar user interface, but much more powerful and reliable, try DesignSpark Mechanical. It's free and will take minimal effort to learn, if you are familiar with sketchup. I used it for about 4 years (and occasionally still do) and it never required STL file repair. It can do many things that sketchup can't, such as filleting and chamfering edges, etc. If you want more capability and don't mind a steeper learning curve, try Fusion360, also free.

When you compile the firmware and reprogram the Arduino board it will replace the old stuff with the new.

Check that the heater and thermistor are both still solidly mounted in the heater block, and check the wiring between the heater and thermistor and the controller board. They often crimp the thermistor leads and the crimp connections can get loose, resulting in extra resistance that the controller interprets as a high temperature.


Son of MegaMax 3D printer: [www.instructables.com]
Ultra MegaMax Dominator 3D printer: [drmrehorst.blogspot.com]
Re: initial success...then failure
February 18, 2019 10:52PM
1) it erases the flash memory (program memory) It does not erase the eeprom memory (settings)
2) "to new" you would have to zero the eeprom memory.. You would need to upload a program into the ardunio to do it, or use avrdude coammnd line tool
There is no need to do this. You can simply send the printer a M502 [reprap.org] then a M500 [reprap.org] and this replaces all values in eeprom with the setting you have in configuration.h
3-4) can't say...
5) if your have a fan near or a air conditioner near the machine it can cause issues. Also if the themistor gets detached from the bed it will report the same error.
Re: initial success...then failure
February 19, 2019 01:14PM
thanks for the replies - i just went into registry and deleted all cura, slic3r, repetier, ultimaker, and arduino entries - going to see if i can start over - no fan or a/c near unit - i actually siliconed the thermistor wires to underside of plate as the tape was loose..no change - that thermistor is centered in a hole in the plate - i left it there and did not silicone the head of the thermistor, just the wires - i will check connections to board - the extruder will home to correct coordinates and is a paper thickness off bed - this printer came with sketchy assembly instructions so the routing of the wires was my choice - i coudn't see how the bed could slide back and forth unless the heater and thermistor wires were routed low and towards the rear although that makes the warnings on the plate read upside down - this causes a bending point where it's attached to the frame - i will check there also for wire fatigue - thanks again for the help
Re: initial success...then failure
February 19, 2019 03:39PM
Regarding the thermal runaway... moving wires flex and bend. If all the bending is happening in one place, you get metal fatigue and the wires break. Where the wires are hot, they are especially prone to failure. This sometimes happens inside the insulation, so that in one position they're connected, and in another they're not. My approach is to rigidly attach the wires to the hot-end, and then spiral-wrap the wires so that they all bend together. Also, fiddling with the components can break the wires, so investigation of one problem causes another (don't ask how I know this!).

Tweaking G-code and Z-height manually is probably a bad thing to do until you know what you're doing. You could very well do physical damage to your printer if you get it wrong (e.g. crashing the nozzle into the bed bad enough to loosen screws or bend or break the structure). Once your printer is bent, it's hard to get back to good prints.

My approach to software is to use each component independently, whereas Cura and others tend to try to lump everything together. So I use a CAD program (usually Onshape.com -- it's free and online) to generate a .STL file, then a slicer (usually Slic3r) to generate G-code, then a printer controller (Repetier) to run the printer and send the g-code file to it. With an integrated package like Cura doing all of these things, it's not particularly good at some things, and you also need to work in the way that the Cura developers expect you to.

To be able to help with your modelling issues, it would be helpful to share your .STL & maybe G-code files, or maybe screenshots from your slicer. I'm guessing the air-printing is some misconfiguration in your slicer.
Re: initial success...then failure
February 22, 2019 12:59PM
hey - thanks for all the suggestions - i looked at the wiring to the heater/ thermistor - i put an ohmmeter on the thermistor where it connects to the board while moving the bed back and forth - the resistance did jump a little bit (1-3 ohms) - it seems those wires crossed directly over the led on the plate - while i didn't see any open wires on the thermistor leads if i moved them right where they went over that led the resistance would change - i moved those wires an inch off the led and re-taped - the jumping of the resistance stopped - as i said i went through and removed all programs and registry entries in windows - so i reloaded a newer version of repetier/slic3r and tried a sample print of a cube - it did print correctly but rough - i tweeked some slicer and printer settings (this time i saved the original setting though) - the result is that it prints as good as it did before all these problems - so i'm back up and running - i'm going to try some of the programs suggested here and see if they work better than the sketchup/repetier/slic3r combination i'm using now - i've run into this before ..where windows "remembers" something in the registry and screws things up, especially when i repeatedly install and remove a program - hopefully it's all good now - thanks for all the advice
Sorry, only registered users may post in this forum.

Click here to login