X axis moving all the way to the right when rotate switch to the left
May 10, 2019 06:38PM
hello Im new here and have a question. I already did a research in the forum and couldn't find the answer Im looking for.

I have a CR-10 and after it burned the board motor controller, I decided to go for a MKS Gen L and MKS tft 28 display, plus motor controllers 2208

I installed the Marlin version 1.1.9 and later bugfix with the same results.

its important to mention that for some reason the tft28 display buttons behave worst than the click rotary button in the original CR-10 display.

the problem I have is that I can make the head move and do the "homing" position without problems, that indicates me the motion controller and the end stop switchs are configured correctly.

here is the weird thing : for example once I do the homing then I try to move each axis individually and I can make the Y axis move both directions, Z axis both directions. but the X axis I can move it to the right and it moves with no problem but once I rotate the switch to the left it moves to the right and I have to turn off the machine before it hits to the pole.
I tried different things when its moving to the right, like manually activate the end-stop supposing it will be a bad direction configuration and nothing happens, it is ignored and goes all the way to the right.
also tried rotate the switch to the left and its ignored.

what I noticed is that with the buttons in the display tmks ft28 the problem appears in more buttons for example while pressing the arrows for z+ and z- the same behavior, it makes the x axis move all the way to the right.

do you have an idea what could it be?

sorry if there is already a topic for it but I couldn't find it using the search.

thanks for your help

Re: X axis moving all the way to the right when rotate switch to the left
May 19, 2019 12:44AM
I assume you mean that you can control the motion correctly from a connected computer but not from the display. If you can get all the motions correctly from software but not from the touch screen display then there is likely a firmware bug that messes up the input from the touch screen. There is some chance that you need to configure something in the firmware, but it doesn't seem likely. The menu would be determined by firmware, since it is display based. If it were physical switches I would say that you need to configure the pinout, but that doesn't seem to be the case here. I would submit a bug report to the Marlin developers. In the mean time just use a connected computer if you need to do manual moves. I imagine that this function is not frequently used/tested since manual moves are not often necessary.


Retire early, retire often. [HalfLifeDad.com]
Re: X axis moving all the way to the right when rotate switch to the left
May 19, 2019 08:51AM
I would start with using M119: End-stop States this will test the state of the switches.
I would venture to state that is is highly possible that you have an intermittent of bad switch connection.
After flashing there are two commands that should be sent to the controller to read the factory default settings an store them in non-volatile memory.
M502: Factory Reset (this will allow the newly flashed Firmware defaults to be read)
M500: Save Settings (this will allow the flashed Firmware defaults to be saved)

You should post your Marlin 1.1.9BF configuration.h file to a share system like Google Drive an post a link here. As it is so easy to miss an important configuration.

Computer Programmer / Electronics Technician
Re: X axis moving all the way to the right when rotate switch to the left
May 24, 2019 04:45PM
I really appreciate your help.
I solved the problem by moving from 1.1.9 to Bugfix 2.0 there were something in the 1.1.9 that causes the problem for my particular hardware configuration.
now its working perfect. thank you for your help! thumbs up

Re: X axis moving all the way to the right when rotate switch to the left
May 24, 2019 08:49PM

Was using Marlin 1.1.5 for so long that never really experienced Other versions slowed down long an anything to configure and test then continued but Marlin 1.1.9BF
I never had any problems with Marlin 1.1.9BF though I did with Marlin 1.1.9 so skipped to BF version on the first error after reading about the bugs.

Was not on Marlin 1.1.9BF a real long time before I saw advantages in Marlin 2.0.x and have been using it for several months now.

Computer Programmer / Electronics Technician
Sorry, only registered users may post in this forum.

Click here to login