Welcome! Log In Create A New Profile

Advanced

Marlin - Motors not moving simultaneously

Posted by diegomonzon 
Marlin - Motors not moving simultaneously
June 17, 2019 12:43AM
Hi everyone,

I am trying to build something like this but I am using an MKS Gen L board instead.

It is basically adding Nema 23 motors to a Ramps1.4 with big ST-M5045 drivers.

[www.drdflo.com]

My problem is that the X motor only moves when the Y motor is not moving.

I also removed the Y motor and driver and I still have the same problem with motor X. That makes me think that the problem is with Marlin.

As you can see in the video, I am drawing a circle and both axis should be moving at the same time. It moves only one at a time.

This is a link to the video:
[www.icloud.com]

Any help is very welcomed

Thanks
Diego

Edited 2 time(s). Last edit at 06/17/2019 12:50AM by diegomonzon.
Attachments:
open | download - videoSmall4-Small.mov (1018.6 KB)
Re: Marlin - Motors not moving simultaneously
June 17, 2019 01:15AM
looks like you might have enabled something like corexy... where a diagonal move would only move one stepper

Also how have you wired the enable lines and set them up in firmware?

If you have done the standard trick of connecting the step, direction and enable -ve lines to gnd, you need to invert the enable in firmware.

Edited 2 time(s). Last edit at 06/17/2019 03:10AM by Dust.
Re: Marlin - Motors not moving simultaneously
June 17, 2019 04:04PM
Hi Dust
This is how I wired the drivers
and I attached my config files.

I really appreciate your help
Diego




Attachments:
open | download - Configuration_adv.h (67.4 KB)
open | download - Configuration.h (70.5 KB)
Sorry, only registered users may post in this forum.

Click here to login