Welcome! Log In Create A New Profile


Anet A6 false bed temperature reading problem

Posted by AndreeP 
Anet A6 false bed temperature reading problem
June 23, 2019 01:21PM
I have an Anet A6 and it worked fine for a while. But now it thinks the bed temperature is over 150 degrees and stops what it's doing for safety reasons. I've never even used the heated bed. It's not actually getting hot. It boots, reads 150+ degrees on the heated bed and goes in safety lockdown. It's quite annoying and has made it impossible to print anything.

I already tried booting the printer with that sensor unplugged, but the false reading remains.

How do I troubleshoot this problem? Should I install Marlin firmware (Skynet3D fork) and see if that helps?
Re: Anet A6 false bed temperature reading problem
June 23, 2019 02:04PM
If the temperature reading does not change when you unplug the thermistor, it is a dead ADC in the controller CPU...
If it changes to a very cold temperature when the thermistor is unplugged it means your thermistor wires are shorted together.

New firmware would be able to disable the heated bed completely, but will be lots of work...
Re: Anet A6 false bed temperature reading problem
June 23, 2019 03:44PM
I would ask if you would use a air can and blow off the controller as it could be some conductive material on the circuit board.
This sometimes requires if to be removed from the 3D Printer, an sometime it can be done while still attached.

I had a bad controller where it had a open trace to the thermister pins causing a failed thermister reading.

Edited 1 time(s). Last edit at 06/23/2019 03:45PM by Roberts_Clif.

Computer Programmer / Electronics Technician
Re: Anet A6 false bed temperature reading problem
June 24, 2019 02:07PM
Thank you both for the response, I'll try the air can (I'll have to buy one) and if that doesnt work I'll make a post in the Marlin firmware section to for help with changing the firmware from the Anet to the opensource Marlin Skynet3D fork.
Re: Anet A6 false bed temperature reading problem
June 26, 2019 02:13PM
Don't spend time with the Skynet fork - vanilla Marlin now supports the Anet A8/A6 and is much more up-to-date (last commit on the Skynet branch was 2 years ago).
I had a similar problem with my A8 - in my case the hotend thermistor started reading 150C when the hotend was dead cold, I ended up replacing the Anet board with a Atmega2560/RAMPS combination.
Re: Anet A6 false bed temperature reading problem
July 02, 2019 04:55PM
Update, in case someone else has the same problem.

I successfully installed marlin on my Anet 6, but it was a struggle till I found this set of instructions:
[www.3dprintforum.nl] (dutch)
That's a step by step guide, with all the files you need. (this is important because version updates can mess with the instructions)
It is in dutch, but it also says that it is a translation of a guide posted by Mark Everett on facebook.

Indeed, you dont need the Skynet fork anymore. Marlin is good.

The full list of steps I used to remove the heated bed functionality from my Anet A6 printer:
Part A: installing firmware that is editable.
Install arduino, go to my documents 'Arduino' and create a folder hardware if it doesnt exist. Copy paste the folder called 'anet' there. (It's in the files as 'anet hardware file with optiboot.zip') If you open arduino, you should be able to select the 'Anet V1,0' board. Do not use the optiboot board. It uses less space, but also requires several more steps, including using an USBAsp, I cannot help you with that. It is for advanced users.

It's probably safest if you unplug all other devices, just to make sure you dont try to communicate to the wrong port. The right port is the one that appears after you plug in the powered up Anet A6. With the right board selected and the right port selected, the next step is the firmware.

Close Arduino for now.

The marlin included with the guide (and the one I used) is Marlin-1.1.9, to configure it for the Anet A6, unzip it then go to the example configurations folder, Anet > A6, copy the configuration and configuration adv file. Paste these into the Marlin folder, to overwrite the standard configs.

Next step, open the Marlin firmware in Arduino. Just dubbleclick the Marlin arduino file in the Marlin folder.

It will not compile yet. You need to go to the Sketch > libraries > Manage libraries, search for U8Glib and install it. Others will show up with similar names. Then you can go to Sketch > libraries > U8Glib, this should add a line of code on the file that says: #include smallerthan U8glib.h greaterthan (I dont know how to properly include code segments, sorry)
I dont know if it matters where that include goes. I have it at the top of my configuration.h and that worked for me.

Now it should compile. After confirming that it compiles, use Sketch > upload, with the right board (Anet V1.0), right port, the printer connected and powered. It should compile and upload. You should see the changes on the display after the upload is complete.

Part B, edit the new firmware so it disregards the bed temperature. If your printer does not have this issue, do not do this.

In configuration.h search for the //#define CUSTOM_MACHINE_NAME option. Remove the // to uncomment it. Put a name between the " " that clearly indicates that the bed temperature is not working and should not be used. For example:
#define CUSTOM_MACHINE_NAME "BedT unsafe"
This will serve as a constant reminder to never use a heated bed again with this board. A post-it on it might get lost.

next, search for the #define TEMP_SENSOR_BED 5 setting. Change it to 998.
#define TEMP_SENSOR_BED 998
This changes the bed temperature sensor to a setting that always returns 25. Always. Even if the machine is on fire, it will say 25.

Compile and upload with the new configuration. The bed temperature should say 25.

Disconnect the power to the Printer. Take the white connector at the back of the bed (temp sensor and bed heater) unplug it and never plug it in again.

It should now work, except for the heated bed, which you can never use again. If you want a heated bed, you'll have to change the board. Or use a different printer.

This fixed my problem of a faulty reading of the bed temperature sensor. Thanks again to everyone who replied here, it's appreciated.

Edited 1 time(s). Last edit at 07/02/2019 05:00PM by AndreeP.
Sorry, only registered users may post in this forum.

Click here to login