endstop drives me crazy (stuck at triggered), I am running out of options.
August 23, 2019 07:13AM
I finally get ready to upgrade my printer and found out that my X+ is always triggered. The board I am using is an SKR v1.3 and the end switches I am using..... well it's really irrelevant, I tried different types of switches on X+ and nope they are all stuck at triggered (not because I set the logical wrong in marlin). The same happens to X- Y-, so only Y+ Z- and Z+ works fine, but I really need 4 to get my delta going.

actually, I am using an optical switch,

  • I read people say pullup should be disabled, tried and failed;
  • I also find people say I should replace the 180ohm with 100ohm resistor on the switch, tried and failed;
  • solder a 200/220 ohm in parallel with the 180ohm resistor, tried and failed;
  • disabled SDSUPPORT, don't know why but I am desperate, tried and failed;
  • problem with my optical switch and cable? the same sets of cable and switch work just fine on Y+ and Z+;
  • use an absolutely clean marlin 2.0 and only enabled endstops, tried and failed;

I spent the whole day trying to figure out what's going on, but, no luck so far, it seems I have no options left, inputs are really appreciated.
Re: endstop drives me crazy (stuck at triggered), I am running out of options.
August 23, 2019 08:27AM
Eliminate the actual endstops from the tests.

each endstop plug has 3 pins from this diagram [github.com] (you will need to scroll right to see this)
You can see the top pin is V, the middle pin is G and the bottom pin is S (make sure to orientate your controller so the stepper drivers are at the top to be the same as this image)

Without any endstops plugged in
Send the board a M119 , take note of the output.
now use a female to female Dupont Wire and connect the S pin to the G pin On X- and send another M119. Did anything change?
Now Connect the S pin to the V pin and send another M119, Did anything change?
If the end stop status doesn't change with at least one of these two tests you have either a badly configured firmware or a hardware fault
repeat tests on all endstops

NB under no circumstances connect V pin and G pins, this shorts the power to ground and will destroy your board.

Edited 2 time(s). Last edit at 08/23/2019 08:31AM by Dust.
Re: endstop drives me crazy (stuck at triggered), I am running out of options.
August 26, 2019 10:26PM
thanks Dust, after a long talk with the seller, they rule out the firmware fault (by sending me a firmware they configured and believed it's correct) ,
and we agreed that the problem could be from hardware, so they are sending out a new replacement board, what a lucky day, they sell thousands of boards all year long and I get a lemon.
Sorry, only registered users may post in this forum.

Click here to login