Welcome! Log In Create A New Profile


Can't jog Z-axis from computer

Posted by MufaddalMarvi 
Can't jog Z-axis from computer
October 03, 2019 09:09AM
Hey all,

Built my first reprap, it's a p3 steel using RUMBA control board with Marlin firmware, and a reprap_discount full graphic controller on the side.

The printer seems to work fine if I operate it using the LCD controller (all axis jog without any issue). The problem is when I try to operate the printer using the computer. I'm using the control panel on Simplify3D to control it. Jog commands for x-axis and y-axis work perfectly. So does the Home All command. However if I try to jog the Z-axis separately, then it seems as if the Z-axis motors are jammed or something. They make a loud whining sound and move only a quarter of the revolution it should be making.

I experimented with 115200 and 250000 baud rates. Didn't make a difference. I have no clue what the problem might be.

I really hope someone can point me in the right direction on this.

Re: Can't jog Z-axis from computer
October 03, 2019 09:23AM
Your max Z feed rate is to high.

When you attempt to move Z faster than it can physically move the firmware should limit the feed rate to the max feed rate set in firmware.
If it isnt set the correctly you get whining and lack of movement when you try and move to fast

play with m203 [marlinfw.org] and once you find a value that works either store it to eeprom (m500) or update your firmware with the new value

Edited 2 time(s). Last edit at 10/03/2019 09:34AM by Dust.
Re: Can't jog Z-axis from computer
October 04, 2019 02:21AM
Hey Dust,

Thank you SO MUCH!

I tried it this morning. Changed Max Z feedrate from 5mm/sec to 3mm/sec. Now it works perfectly! smiling bouncing smiley
Sorry, only registered users may post in this forum.

Click here to login