SKR1.3 I/O Pins not working
October 06, 2019 11:03AM
Hey it's me again
I wanted to use the max_endstop pins on my SKR1.3 running Marlin 2.0 for the extruder_auto_fan and the case light/status LED feature like this


Unfortunately this is not working
I enabled the features
#define NEOPIXEL_LED //MS
#if ENABLED(NEOPIXEL_LED)
  #define NEOPIXEL_TYPE   NEO_GRBW // NEO_GRBW / NEO_GRB - four/three channel driver type (defined in Adafruit_NeoPixel.h)
  #define NEOPIXEL_PIN    P1_24       //MS BOOKMARK SKR LED driving pin
  #define NEOPIXEL_PIXELS 49    
  ...
  #define PRINTER_EVENT_LEDS
...

#define CASE_LIGHT_ENABLE //MS
#if ENABLED(CASE_LIGHT_ENABLE)
  #define CASE_LIGHT_PIN P1_24                   //MS BOOKMARK SKR   Override the default pin if needed
  #define INVERT_CASE_LIGHT false             // Set true if Case Light is ON when pin is LOW
  #define CASE_LIGHT_DEFAULT_ON true          // Set default power-up state on
  #define CASE_LIGHT_DEFAULT_BRIGHTNESS 127   //MS Set default power-up brightness (0-255, requires PWM pin)
  #define CASE_LIGHT_MENU                     //MS Add Case Light options to the LCD menu
  //#define CASE_LIGHT_NO_BRIGHTNESS          // Disable brightness control. Enable for non-PWM lighting.
  #define CASE_LIGHT_USE_NEOPIXEL             //MS Use Neopixel LED as case light, requires NEOPIXEL_LED.
  #if ENABLED(CASE_LIGHT_USE_NEOPIXEL)
    #define CASE_LIGHT_NEOPIXEL_COLOR { 0, 0, 0, 127 } //MS { Red, Green, Blue, White }
  #endif
#endif

#define E0_AUTO_FAN_PIN  P1_28 //MS BOOKMARK SKR
#define E1_AUTO_FAN_PIN  P1_26 //MS BOOKMARK SKR
#define E2_AUTO_FAN_PIN -1
#define E3_AUTO_FAN_PIN -1
#define E4_AUTO_FAN_PIN -1
#define E5_AUTO_FAN_PIN -1
#define CHAMBER_AUTO_FAN_PIN -1
#define CHAMBER_AUTO_FAN_PIN -1

#define EXTRUDER_AUTO_FAN_TEMPERATURE 55 //MS
#define EXTRUDER_AUTO_FAN_SPEED 255   // 255 == full speed

But neither feature will work (on my old MKS Gen L running Marlin 1.1.9 everything worked)
Heating the extruder over 55°C will result in 3 Volts on P1_28 / P1_26 but this however does not make either fan spin (fans are connected over a mosfet to 12V with the gate going to the corresponding pin)
Turning the caselight on/off manually with max brightness does not have any effect on pin P1_24 however

Any ideas what I am doing wrong?
Thanks for any help

Edited 1 time(s). Last edit at 10/06/2019 11:05AM by Schild0r.
Re: SKR1.3 I/O Pins not working
October 06, 2019 11:57AM
the endstop pins have external resistors on the pcb

10K pullup to 3.3v
1K in line to the processor

Fairly sure that will break most things your trying to do with these IO pins when not used as inputs.

Edited 1 time(s). Last edit at 10/06/2019 11:59AM by Dust.
Re: SKR1.3 I/O Pins not working
October 06, 2019 01:17PM
Quote
Dust
the endstop pins have external resistors on the pcb

10K pullup to 3.3v
1K in line to the processor

Fairly sure that will break most things your trying to do with these IO pins when not used as inputs.

Dang
Is there some way to use these features anyway with this board then?
Re: SKR1.3 I/O Pins not working
October 06, 2019 08:11PM
Also the mosfet has to be designed to turn on with 3.3v logic, most for reprap are 5v (Even the skr1.3 board uses a 74HCT125 to shift 3.3 to 5v for its onboard mosfets)
and the neopixels need 5v signals
Re: SKR1.3 I/O Pins not working
October 07, 2019 04:19AM
"Heating the extruder over 55°C will result in 3 Volts on P1_28 / P1_26 but this however does not make either fan spin (fans are connected over a mosfet to 12V with the gate"

these might work then, with the pull up the fan will be on directly after power on, but will switch off quickly once the firmware turns them off, so it not a big deal (not like its a heater)
But you need to level shift the output to 5v to drive your external mosfet

no idea about the neopixels
Sorry, only registered users may post in this forum.

Click here to login