Welcome! Log In Create A New Profile


Problem with 2 axis' not moving both directions

Posted by fcapt10 
Problem with 2 axis' not moving both directions
November 20, 2019 08:31PM
I have a Plasma Table utilizing the Megatronics v2.0 board. The program used for running the table is Repetier Host. While running a Gcode file I had the Z axis quit going down once the position hit 0.00 on the screen display. While trying to determine why (checking limit switch curcuit) it quit going down completely. Shortly afterwards the X axis quit traveling to the left. Y axis works fine in both directions. I tried controlling motors at the table through the LCD screen and control knob and same results. I have a PROMO Torch height controller which allows the torch to maintain the correct distance above the work piece. I ran the THC in test mode and Z axis worked both directions. I had a spare board and installed it with the original drivers and had the same results. I moved drivers, swapped some with spare drivers, and same results. I moved X axis stepper motor wires to Y axis connector and it worked properly. I disconnected the torch height controller from the system to ensure there was no interference with no change in operation. I removed all stepper drivers from the board and installed a know good one in Z and X slot with same results. I also tried a different computer with a fresh install of RH software. I am at a loss right now. I have another board that is being flashed and sent to me from the table manufacturer but not totally confident that it will solve my problem. If anyone has seen this or has an idea of what to check that would be great! TYIA, Jim.

Edited 1 time(s). Last edit at 11/20/2019 08:59PM by fcapt10.
Sorry, only registered users may post in this forum.

Click here to login