Welcome! Log In Create A New Profile


Extruder issue SOLVED

Posted by Adam.m.Nelson 
Extruder issue SOLVED
June 09, 2011 12:03PM
I know this should be in the firmware section, but I don't think many people are actually looking there.

I believe this is a firmware issue.

I'm running typical Gen3 electronics, Motherboard v1.2, extruder controller v1.2, 2.x stepper drivers. I've had the extruder working in the past, but i've gone through so many different versions of code (and a crashed computer) I can't find which version it worked with. I can read the temperature and turn on the bed, fan, and heater outputs. When I try to step the extruder I get no response (no LED action or motor movement).

The current code I am running is based off of brupje's upload here Forum Post. I've made some small changes, but its still mostly the same. Its the most stable code we've found so far. Most other versions won't even run properly on the Micro (some sort of buffer issue i think).

I took an oscilliscope to the SDA/SCL lines, and there is no change in states when I try to drive the extruder forwards or backwards. Using my fluke I traced the SDA and SCL lines back to the micro and I have good continuity. I did notice that if I pull of the SDA line the extruder starts freakling out and spins uncontrolably. When I pull off the SDA/SCL lines I think there is a bit of oscillation as the pin floats causing the motor to start spinning (not uncommon with Micros), because its not being controlled by the micro at that time.

So I'm back to a firmware issue...

I have set the firmware to #define DEFAULTS MENDEL_GEN3_DEFAULTS, and have played with all possible combinations of these lines in the configuration.h file:

//#define E_STEPS_PER_MM 0.9
#define E0_STEPS_PER_MM 2.2

I am using the Extruder Controller firmware from code build 20110509, and the motherboard firmware is v1.8.

I included my code in a 7zip file incase anyone is curious enough to take a look.

Any help is greatly appreciated, this is the last thing before we can print! smiling smiley

Any thoughts? Am I missing something?

Edited 1 time(s). Last edit at 06/11/2011 01:02PM by Adam.m.Nelson.
Re: Extruder issue
June 11, 2011 01:01PM

In the pins.h lins 166 and 167, the pins to drive the extruder were wrong.

#define E_STEP_PIN 17 //Old Value 6
#define E_DIR_PIN 16 //Old Value 5
Sorry, only registered users may post in this forum.

Click here to login