diy 3d printer problem
November 26, 2020 06:06AM
i'm building this 3d printer using and Arduino mega 2560 and the Ramps1.4, plus the A4988 drivers.

i've used marlin 1.1.x and followed youtube tutoriels to set it up, flashed it to my card and used pronterface to command it and here's where the problems occured, now my situation has two phases : what used to happen, and what is happening now so bear with me :

- at first when i tried commanding the stepper motors the X and the Y motor would only vibrate and not move, the Z motor would move but not synchronized ( one would stop and the other one continues) and their rotation wasn't according to the command i would send (i would send a command to move 1mm and the would spin for like 40s at least one of them as the other one stops not so long before, and even the endstops wouldn't trigger them to stop eventhough i checked that the endstop were working using the command on pronterface). and sometimes even if would command the X or Y motors, the Z motors would start spining.

the other problem at this phase was that the LCD was kindda showing some giberish writing and wasn't clear at all.

( i tried multiple modifications on the firmware, tried adjusting the potentiometre o the drivers, tried changing the cables, changing the orientation of the cables, switched between motors...ect but nothing seemed to work)

- moving to what's happening now. now the screen in all bleu and blank, and none of the motors would work no matter what i would try, i retired everything i did the first time, i replugged all the cables multiple times to make sure that i'm not mistaken, i tried the test code for the stepper motors but without results, i even tried the repitier firmware but nothing worked, ( also i tried the graphic test for the screen but it didn't work)

did this happen to anyone else, and can someone guide me to atleast test that the components are failling.
Re: diy 3d printer problem
November 26, 2020 07:50AM
Sounds like you have completely killed it.

Secondly marlin 1.1.x is dead, old, unsupported. use Marlin 2.

If you run the standard ramps test [reprap.org] and the motors do not work you have a hardware issue.

possible causes are numerous
dead stepper drivers.
stepper driver plugged in wrong way around.
no jumper installed under stepper drivers to set 1/16th micro stepping.
incorrectly wired stepper motors.
dead IO pins on the mega.
ramps not seated into mega correctly or firmly enough.
12v not getting to stepper drivers.
not supplying 12v to 12v 5amp ramps input.

You don't mention your type of display.

If its a reprap discount 20x4 char display you can run this test [github.com]
if its a reprap discount 128x64 graphics display you can run this test [github.com]

Edited 2 time(s). Last edit at 11/26/2020 08:37AM by Dust.
Re: diy 3d printer problem
November 26, 2020 11:26AM
unfortunatly i couldn't get marlin 2 to wark on the ramps1.4
my screen is the 128x64 reprap discount full graphic smart controller, and i've tried the test but it doesn't work
what triggers me is that the steppers and the screen worked before (eventhough not properly) but all of a sudden decided to not show any response
Re: diy 3d printer problem
November 27, 2020 10:39AM
it is possible like stated earlier that the board was killed.
have you verified with a volt meter that the 5v out pin is still producing 5v. (5v output pin on the Arduino or Arduino mega board, or equivalent.)
often the cloned arduino boards have poor 5v regulators. if this is the case then an external lm7805 should be sufficient, but it might be cheaper and less headache to buy another board.

Edited 1 time(s). Last edit at 11/27/2020 10:41AM by jamesdanielv.
Re: diy 3d printer problem
November 27, 2020 05:35PM
The GLCD is driven directly from the mega IO pins.

If it is not working there is a hardware fault.

Either.
dead mega
dead ramps
dead lcd adaptor.
Re: diy 3d printer problem
December 03, 2020 04:41AM
could u please help me out with a pic or something to guide me i'm afraid i might touch the wrong pins and burn something else
i tried looking online but could find out where to test
Re: diy 3d printer problem
January 15, 2021 04:11AM
Have you installed the drivers for the glcd into the ardunio library and selected the right lcd setting in marlin along with the baud rate.
There a known issue with some of the glcd headers being reversed need to swap aux 1 goes into aux2 of the ramps as well as rotating the headers 180'.
Am stuck on a mobile which has a mind of it own so hoping another called explain this a little better [reprap.org] have a read of that thread This library needed

Edited 2 time(s). Last edit at 01/15/2021 04:29AM by jinx.
Sorry, only registered users may post in this forum.

Click here to login