Welcome! Log In Create A New Profile


Thermal Runaway Anomaly

Posted by TerryD15 
Thermal Runaway Anomaly
May 08, 2023 10:27AM
I have a DIY i3 style printer built in the true spirit of RepRap sometime around 2012. I printed with it succesfully for a few years, but for all sorts of reasons I left it alone for a while. A couple of years ago I added a sensor to enable auto bed levelling/tramming but it gave me a few problems at the time. Then work called me and my wife away from home for a year or so, so once again the printer was idle. I came to use it a few days ago but it immediately gives a 'Thermal Runaway' message and kills the printer.

Now here comes the anomaly, I checked thermistors and connections to Ramps board etc and they were ok. The printer then suddenly for no apparent reason started working after a reset I set the bed and hotend in Pronterface and(230 and 110°C) they heated to set temps with a minimum of variation (no PID). I ran all the usual checks on the motion and everything worked well. However when I came back to it this morning the thermal runaway message was back on the LCD and the piezo was screaming at me, even though the printer itself was not on, it was simply connected to the pc via usb. I simply repeats the message after each attempt to reset when the printer is switched on.

I'm using Marlin 2.0 (bugfix) which was the latest version at the time and have not made any changes. I just am not sure why the firmware started killing the printer, could the firmware be corrupted? or may be there is a problem with Ramps or Arduino, I don't think it's the thermistors as they worked perfectly and a resistance check was positive when they were heated. I don't want to start ripping the thing apart if there is a simple fix, so I came here looking for ideas.

Any sensible suggestions welcomed,
Re: Thermal Runaway Anomaly
May 08, 2023 10:36AM
... if the components are OK (sound resistance and connections), then try with reflashing the firmware - some boards sometimes "forgets" bits'n'bytes with time, so the software fails ...

Aufruf zum Projekt "Müll-freie Meere" - [reprap.org] -- Deutsche Facebook-Gruppe - [www.facebook.com]

Call for the project "garbage-free seas" - [reprap.org]
Re: Thermal Runaway Anomaly
March 05, 2024 06:11AM
Bit late but similar issue.

I too went down the DIY RepRap path and still haven't swapped out all the zip ties, super glue, cloths peg, cardboard, garden hose... etc after a few years now

Been suffering through thermal runaway error's halting print jobs immediately or at intermittent intervals into the print. Pronterface would throw up Bed_ID.. to indicate which thermistor was kill()ing the job.

What I can tell after installing a larger hotbed with an external MOSFET is that the D8 LED comes on but no current is being supplied to the connector which should in turn light up the onboard MOSFET LED indicating a voltage signal to drive the offloaded MOSFET > bed circuit.

As it turns out, the D8 solder connection on the RAMPS 1.4 board is dry/loose and the connector now has some wriggle room to disconnect. Testing I can replicate this while the bed is heating up by pushing the D8 connector on the RAMPS board. Print vibrations may explain the intermittent thermal runaway during print jobs.

Without an external MOSFET, use a multimeter to test the D8 12v output while giving the D8 a nudge or three and check for a voltage drop (external LED would vary in brightness) or disconnect

Edited 1 time(s). Last edit at 03/05/2024 06:33AM by fuzzy_logic.
Sorry, only registered users may post in this forum.

Click here to login