Problémes de fins de course
July 28, 2012 02:31PM
Bonjour,
Je viens de terminer le montage de ma mendel prusa, elle est equipée d'une ramps 1.4
J'ai quelques problèmes de config du firmware sprinter
Je n'arrive pas à faire fonctionner les fin de course, il s'agit de fins de course mécaniques (1 par axe) montés en NC.
Lorsque je demande la position "home", l'activation des fin de course ne provoque pas l'arret.
Je ne suis pas trés doué en anglais, donc je travaille à tâtons.
Si une âme charitable veut bien me filer un coup de main

Merci d'avance
Re: Problémes de fins de course
July 28, 2012 02:45PM
Salut,

mes fins de courses (qui fonctionnent) sont en "NO", je ne vois pas dans le firware comment préciser quelle config on a?
ce qui est sur est que tu ne dois pas commenter
#define ENDSTOPPULLUPS
ligne 43 chez moi, si cette ligne est commentée, c'est à dire s'il y a '//' devant, il faut les enlever (je ne sais pas si c'est activé ou non par défaut)

à part ça... vérifier le cablage?

Edited 1 time(s). Last edit at 07/28/2012 02:46PM by Hexa Emails.
Re: Problémes de fins de course
July 28, 2012 03:21PM
Lut, déja tu as placé tes end stop comment sur l'axe X/Y? quand tu demandes à printrun (avec le charriot extrudeur au milieu de l'axe X) d'avancer l'axe X de +10 mm ça s'en va ou par rapport à ton fin de course, vers lui ou vers l’extérieur?
pareil pour l'axe Y pour le Bed, dans quel sens le bed se déplace par rapport à ton fin course...

et ne déplace tes axes que de quelques mm, pas en faisant home si tu n'as pas réglé ton firmware:
Re: Problémes de fins de course
July 28, 2012 04:52PM
salut,
lorsque je fais une avance positive sur un axe, je m'éloigne du fin de course concerné.
lorsque je vais en négatif jusqu'au fin de course, le mouvement ne s’arrête pas une fois au contact.
j'ai connecté les fin de course en X-,Y- et Z- sur la reprap
je viens d'essayer en passant les fin de course en NO mais c'est pareil
j'ai contrôlé #define ENDSTOPPULLUPS et cette ligne est bien active (non commentée)

d'ailleurs si vous connaissez un bon tuto en français qui aborde la mise en route, ça pourrait sympa
Re: Problémes de fins de course
July 28, 2012 05:43PM
Vérifie le sens de tes axes:

Z+ vers le haut
X+ vers la droite
Y+ le plateau vers toi (donc l'extrudeur recule par rapport à la piece)
(que quelqu'un me corrige si ce n'est pas bon)

Si tu n'as pas les axes dans le bon sens, il faut inverser 2 fils (de la meme bobine) de tes moteurs pàp.

Si tes axes sont dans le bon sens, vérifie que tu as bien branché aux endstop mini, et si oui, il faudra changer des lignes de code.
Re: Problémes de fins de course
July 29, 2012 03:56AM
t'as bien cablé tes endstop ,comme ça :



et sur la Ramps tu dois avoir les deux fils qui vont sur X/Y/Z-Min comme suit :

Connect S (top row, labelled to the left) on RAMPS to NC on the switch. (NC du fin de course sur le pin S de la Ramps)
Connect GND on RAMPS to C on the switch. (C du fin de course sur la masse donc - des pins)


Re: Problémes de fins de course
July 29, 2012 08:20AM
Mon câblage semble correct est correct même si ma config diffère légèrement de celle de Djamuka (connecteur 2 pins)
est ce qu'il existe une commande permettant de visualiser l'état des fins de course afin de les contrôler en appuyant dessus?
cela permettrait de voir si le problème vient du firmware

Edited 1 time(s). Last edit at 07/29/2012 08:22AM by Folkenc.
Re: Problémes de fins de course
July 29, 2012 08:50AM
La commande M119 te renverras l'état des endstops.
Re: Problémes de fins de course
July 29, 2012 09:22AM
la commande M119 me retourne bien des changements d'état lorsque j'actionne les fin de course
j'ai jeté un oeil au programme, mais je ne voit pas d'où cela peu venir
de plus je viens de cramer bêtement un driver, lors d'un énième test. Un rad s'est décollé suite à un beau coup de coude et m'a fait un court jus...
Re: Problémes de fins de course
July 29, 2012 09:34AM
Re, dans Sprinter tu as un fichier pin.h, il faut que tu décommentes la ligne qui concerne ta version de Ramps, si tu as une V1.4 ou V1.3 il faut décommenter comme suit:

// uncomment one of the following lines for RAMPS v1.3 or v1.0, comment both for v1.2 or 1.1
#define RAMPS_V_1_3
// #define RAMPS_V_1_0

En bas de page ici
Et la liste des pin pour la V1.4 La

Edited 1 time(s). Last edit at 07/29/2012 09:48AM by Djamuka.
Re: Problémes de fins de course
July 29, 2012 10:12AM
Hexa Emails Wrote:
-------------------------------------------------------
> Vérifie le sens de tes axes:
>
> Z+ vers le haut
> X+ vers la droite
> Y+ le plateau vers toi (donc l'extrudeur recule
> par rapport à la piece)
> (que quelqu'un me corrige si ce n'est pas bon)
>
> Si tu n'as pas les axes dans le bon sens, il faut
> inverser 2 fils (de la meme bobine) de tes moteurs
> pàp.
>
> Si tes axes sont dans le bon sens, vérifie que tu
> as bien branché aux endstop mini, et si oui, il
> faudra changer des lignes de code.


Euh par contre je ne vois pas pourquoi inverser 2 Fils de la méme bobine, y'a l'option pour inverser le sens des axes dans sprinter:
// Inverting axis direction
//-----------------------------------------------------------------------
const bool INVERT_X_DIR = false;
const bool INVERT_Y_DIR = false;
const bool INVERT_Z_DIR = true;
const bool INVERT_E_DIR = false;
Re: Problémes de fins de course
July 29, 2012 10:53AM
l'affectation des pins est bon d'ailleurs c'est confirmé par la commande M119
Sorry, only registered users may post in this forum.

Click here to login