Carte SD détectée mais non accessible depuis un afficheur Full Graphic Smart
January 31, 2016 11:12AM
bonjour,

je suis nouveau dans le monde de l'imprimante 3D.
j'ai terminé le montage de ma prusa I3, celle-ci fonctionne correctement.
afin de la rendre autonome, j'ai fait l'acquisition d'un afficheur graphique + Sd, type ICD smart 12864.

lorsque je le raccorde avec les nappes d'origine (EXP1 et 2, longueur 30 cm), je n'ai pas de problème.

souhaitant déporter l'affichage, j'ai refait 2 nappes (longueur 1m).
dans cette configuration, l'afficheur fonctionne correctement.
mais je n'ai pas accès à la carte SD alors que celle-ci est détectée insérée.

après qqs recherches sur internet, j'ai trouvé la possibilité de modifier la vitesse d'initialisation de la liaison SPI (définition de la vitesse 6 et non 5 pour la variable SPI_SD_INIT_RATE dans l'onglet SDFATconfig.h).
lien vers la discussion : http://forums.reprap.org/read.php?146,238858
j'ai apporté cette modification dans mon marlin, MAIS sans succès !!

j'ai contrôlé le câblage de mes nappes. pas de pb.

Avez-vous déjà été confronté à un pb similaire ?
Y-a-t-il une limite de longueur pour la liaison entre l'afficheur et la RAMP ?
Le marlin peut-il être à l'origine de mon pb ? (je ne pense pas car la SD est disponible avec les nappes EXP1 et 2 de 30cm)

merci d'avance.
cdlt
Re: Carte SD détectée mais non accessible depuis un afficheur Full Graphic Smart
February 01, 2016 06:32AM
Bonjour

Tu as peut-être des parasites qui perturbent le systèmes.... Passage à côté d'un moteur ou d'une alimentation.... ou d'un câble de puissance.

As-tu essayé de permuter les 2 nappes ???

Ne change rien à Marlin si cela fonctionnait avant.

A+


« Le progrès ne vaut que s'il est partagé par tous. » : Aristote
Site WEB pour retrouver plus vite des sujets que j'ai traité
Ma chaîne
Re: Carte SD détectée mais non accessible depuis un afficheur Full Graphic Smart
February 01, 2016 12:16PM
bonjour,

j'ai permuté les nappes, réalisé un panachage.
rien n'y fait, la carte SD est toujours inaccessible.

au vu du schéma de l'afficheur, la liaison entre la carte SD et l'afficheur se fait par le connecteur EXP2.
je pensais retrouvé la disponibilité de la carte SD après avoir mis un câble court.
mais ce n'est pas le cas.

je n'y comprends plus rien.
un truc m'échappe.

cdlt
Re: Carte SD détectée mais non accessible depuis un afficheur Full Graphic Smart
February 01, 2016 12:50PM
Bonsoir

Si tu remets les 2 nappes de 30cm tout fonctionne ???

Si c'est le cas alors c'est une incompatibilité avec une nappe trop longue.

A+


« Le progrès ne vaut que s'il est partagé par tous. » : Aristote
Site WEB pour retrouver plus vite des sujets que j'ai traité
Ma chaîne
Re: Carte SD détectée mais non accessible depuis un afficheur Full Graphic Smart
February 01, 2016 02:19PM
Re,
avec les 2 nappes courtes, tout fct parfaitement.
pour autant, la mise en place de nappes d'1m est possible, voir cet échange : http://forums.reprap.org/read.php?110,581659
mais me concernant, je n'y arrive pas.
cdlt
Re: Carte SD détectée mais non accessible depuis un afficheur Full Graphic Smart
February 01, 2016 02:24PM
Bonsoir

Dans ce cas perturbations électromagnétiques..

A+


« Le progrès ne vaut que s'il est partagé par tous. » : Aristote
Site WEB pour retrouver plus vite des sujets que j'ai traité
Ma chaîne
Re: Carte SD détectée mais non accessible depuis un afficheur Full Graphic Smart
February 01, 2016 02:50PM
Bonsoir

Tu a refait tes nappe a tu testé la continuité de chaque fil, peut etre un mauvais contact.
Re: Carte SD détectée mais non accessible depuis un afficheur Full Graphic Smart
February 01, 2016 02:56PM
Salut,

J'ai eu le même problème et cela venait tout simplement de la carte SD... (très étrange)

Tu as essayé avec une autre carte ??
Re: Carte SD détectée mais non accessible depuis un afficheur Full Graphic Smart
February 02, 2016 05:37AM
Salut,

Avant d'en tester une autre, as tu juste essayé de la formater ?
Des fois, ça suffit à résoudre les soucis.
Re: Carte SD détectée mais non accessible depuis un afficheur Full Graphic Smart
February 02, 2016 09:43AM
Bonjour ...

Lu sur un tuto :
Blinder les deux nappes en enroulant autour 2 couches de papier alu puis bien isoler avec du ruban adhésif.
Relier ce blindage à la masse de la Ramps. Laisser en l'air côté afficheur.
Si ce sont vraiment tes nappes qui sont trop longues, ça peut aider.
Amitiés
Sorcerer


Prusa I3 Frame Box - Ramps 1.4 - Extrudeur Greg Wade - Hotend E3D V6 Direct Buse 0.4 - Marlin
Re: Carte SD détectée mais non accessible depuis un afficheur Full Graphic Smart
February 02, 2016 12:33PM
Tu as activé la SD dans le Firmware ?

Ligne 668 : //#define SDSUPPORT // Enable SD Card Support in Hardware Console

++
Re: Carte SD détectée mais non accessible depuis un afficheur Full Graphic Smart
February 02, 2016 03:37PM
Quote
Xav83
Tu as activé la SD dans le Firmware ?

Ligne 668 : //#define SDSUPPORT // Enable SD Card Support in Hardware Console

++

Ça marche avec 30 cm de nappe, donc il l'a activé...

Je le redis, j'ai 5 SD et une ne marche pas avec 1 mètre de mappe mais est OK avec 30 cm. Les 4 autres marche dans les 2 configs de longueurs.

Zarbi tout ça !!
Re: Carte SD détectée mais non accessible depuis un afficheur Full Graphic Smart
February 03, 2016 12:59PM
Merci à tous pour vos pistes de diagnostic.

J'ai fait l'essai avec les cartes SD à ma disposition, et le pb est toujours le même.
je ne comprends pas pourquoi ça ne marche pas !!!! confused smiley

cartes sd utilisées dans le test :
- EMTEC SD card 2Gb
- SCANDISK SDHC Card 8Gb
- DANE-ELEC SD 128Mb
- SCANDISK micro SDHC 4Gb + adaptateur
formatage FAT ou FAT32

Manu-406, peux-tu STP me dire la marque et le type de carte SD qui ne fonctionnait pas sur ta config avec les liaisons d'1m ?

il y a un truc qui me perturbe.
si le pb de la SD est lié à la nappe longue (1m), pourquoi je ne retrouve pas un fonctionnement normal lorsque je raccorde la liaison EXP2 avec une nappe courte en conservant EXP1 en nappe longue ???

au vu du schéma de l'afficheur, les données de la SD transitent uniquement pas le connecteur EXP2.
partagez-vous cette affirmation ?

toujours dans cette configuration, j'ai remplacé ma nappe longue par ma 2ieme nappe d'1m et le pb est identique.
on peut donc en conclure que le défaut n'est pas dû à un faux contact (peu probable d'avoir un défaut de connectique identique sur 2 nappes).

Je continue mes recherches...
Re: Carte SD détectée mais non accessible depuis un afficheur Full Graphic Smart
February 03, 2016 01:33PM
juste pour compléter mon dernier message.

avec les nappes longues, j'arrive :
- à piloter les moteurs par le biais de bouton rotatif (encodeur) sur l'afficheur
=> la liaison EXP1 est donc disponible
=> les bornes 3 et 5 de l'EXP2 sont donc opérationnelles (encodeur)
- le bouton poussoir "STOP" est opérationnel
=> la borne 8 de l'EXP2 est donc bien raccordée
- la carte SD est détectée.
=> la borne 7 de l'EXP2 est donc bien raccordée

il reste plus que les signaux propres à la Sd que je ne sais pas comment contrôler ...
Re: Carte SD détectée mais non accessible depuis un afficheur Full Graphic Smart
February 04, 2016 03:30PM
Quote
cyval

Manu-406, peux-tu STP me dire la marque et le type de carte SD qui ne fonctionnait pas sur ta config avec les liaisons d'1m ?

Pas de marque particulière, c'est une carte de GPS TOMTOM ( 256 Mo).
Sorry, only registered users may post in this forum.

Click here to login