Extrudeur qui ne veut rien savoir
November 11, 2018 03:47AM
Bonjour à tous,

Alors voila, depuis quelque temps les imprimantes 3D m’intéresse beaucoup, j'ai donc décidé de me lancé dans l'aventure.

Pour l'imprimante je me suis basé sur une CoreXY contrôlée par :
- Alimentation : 12V 30A
- Mega 2560 + Ramps 1.4
- Drivers moteurs : DRV8825
- Moteurs pas à pas Nema 17 (axe X, Axe Y, Axe Z x2, Extrudeuse)
- Lit chauffant : MKB3 300 x 300
- Hot-end : E3D v6

Après avoir passé quelques commandes je me suis lancé dans le montage de la mécanique sans grandes difficultés pour l'instant, tout se déplace normalement à la main spinning smiley sticking its tongue out.
Je me suis ensuite attaqué au câblage provisoire le temps de vérifier que l’électronique fonctionne.
Etant totalement novice en programmation j'ai suivis plusieurs tutos pour la mise en route et utilisé l'outil de configuration Repetier pour le paramétrage.Apres avoir téléverser la config sur la carte, j'ai tester l'ensemble sous Repetier (mode manuel) et mes moteur X,Y,Z1 et Z2 fonctionnent, la hotend monte en température, le lit chauffant aussi.

Par contre je n'arrive pas à faire fonctionner le moteur de de l'extrudeuse..
J'ai donc vérifier :

- Vérifié mon câblage
- Essayé un autre moteur fonctionnel
- Changé le câble carte-moteur
- Testé mon driver moteur sur l'axe X
- Vérifié les tensions sur le driver
- Essayé d'inverser les pins E0 et E1
- Changé la Ramps 1.4

Je pense bloquer sur quelque chose au niveau de la configuration de mon firmware mais sans certitude.
Avez-vous des idées sur le problème ? Je sèche depuis 1 semaine dessus, pouvez-vous m'aider ?

Merci d'avance.
Re: Extrudeur qui ne veut rien savoir
November 11, 2018 04:40AM
bonjour,

et bien normalement il faut momentanément diminuer cette valeur
#define EXTRUDE_MINTEMP 170
#define EXTRUDE_MAXLENGTH (X_MAX_LENGTH+Y_MAX_LENGTH) //prevent extrusion of very large distances.


et televerser etc...
Re: Extrudeur qui ne veut rien savoir
November 11, 2018 04:49AM
Hello,

+1 avec ledjo, il y a une sécurité dans le firmware qui empêche toute extrusion possible si ta hotend n'est pas à une température minimum (par défaut 170°).

Donc comme dit plus haut, soit tu diminue la température dans le firmware (mais ça oblige à re téléverser), soit tu chauffes ta hotend à une température de 170° minimum et tu pourras utiliser ton extrudeur smiling smiley

++


Ma Prusa i3 (ancienne imprimante, transformé en Itopie depuis)
Mon Itopie
Mon thingiverse
[TUTO] Lcd full graphic avec firmware Marlin
--
Possibilité de vous imprimer des pièces, n'hésitez pas à demander en MP
Re: Extrudeur qui ne veut rien savoir
November 11, 2018 08:12AM
Bonjour Ledjo et Joyeufetar,

j'ai déjà essayé avec une buse à 210° et rien n'y fait, même avec le code M302 dans Repetier pour l'extrusion à froid..
Je vais revérifier quand même revérifier les lignes que vous m'avez donné.
Re: Extrudeur qui ne veut rien savoir
November 11, 2018 03:10PM
Accessoirement, si tu as déjà testé avec une buse chaude, c'est que le soucis vient d'ailleurs.

As tu testé ton moteur sur un autre emplacement (x, y ou z par exemple) ou tout seul ?


Ma Prusa i3 (ancienne imprimante, transformé en Itopie depuis)
Mon Itopie
Mon thingiverse
[TUTO] Lcd full graphic avec firmware Marlin
--
Possibilité de vous imprimer des pièces, n'hésitez pas à demander en MP
Re: Extrudeur qui ne veut rien savoir
November 12, 2018 06:24AM
Bonjour Joyeufetar,

Oui j’ai essayé de brancher le moteur et son câble sur l’axe X, et tout fonctionne bien..
J’ai aussi connecté le driver sur l’axe X et il fonctionne aussi
Re: Extrudeur qui ne veut rien savoir
November 12, 2018 02:49PM
Bonsoir smiling smiley

Du coup, as tu essayé de brancher un autre moteur/driver sur l'emplacement extrudeur de la ramps ?
C'est peut être lui qui a un soucis...

Sinon, tente quand même de désactiver la sécurité comme dit plus haut.

Cordialement


Ma Prusa i3 (ancienne imprimante, transformé en Itopie depuis)
Mon Itopie
Mon thingiverse
[TUTO] Lcd full graphic avec firmware Marlin
--
Possibilité de vous imprimer des pièces, n'hésitez pas à demander en MP
Re: Extrudeur qui ne veut rien savoir
November 12, 2018 03:02PM
Bonsoir,

Oui j'ai essayé un autre moteur (celui que j'avais sur l'axe X ) et un autre driver sur l'emplacement E0, résultat toujours aucune réponse.
J'ai refais un test avec la buse à 200°, et rien, impossible de le bouger dans Repetier..

J'ai programmé un deuxième moteur sur l'emplacement E1 et même chose, rien ne se passe pour les deux extrudeurs...

Avant de poster sur le forum, j'ai également acheté une nouvelle Ramps en pensant que ça venait de la carte mais j'ai ce soucis avec les deux cartes.
Re: Extrudeur qui ne veut rien savoir
November 12, 2018 03:27PM
Ca vient clairement du firmware alors...
Je doute que ce soit autre chose.

Mais à tout hasard, le moteur de l'extrudeur juste branché, mais non monté (sans le système extrudeur du coup), il fonctionne ?


Ma Prusa i3 (ancienne imprimante, transformé en Itopie depuis)
Mon Itopie
Mon thingiverse
[TUTO] Lcd full graphic avec firmware Marlin
--
Possibilité de vous imprimer des pièces, n'hésitez pas à demander en MP
Re: Extrudeur qui ne veut rien savoir
November 12, 2018 03:35PM
Le moteur de l’extrudeur n’a encore pas été monté.. je voulais tout tester avant de m’amuser à tout redémonter spinning smiley sticking its tongue out

Je pense aussi que cela vient du firmware mais comment en être sur, et comment détecter l’erreur ?
Re: Extrudeur qui ne veut rien savoir
November 12, 2018 04:27PM
Essaye en commentant carrément ses 2 options dans le firmware (PREVENT_COLD_EXTRUSION et PREVENT_LENGTHY_EXTRUDE) :

// This option prevents extrusion if the temperature is below EXTRUDE_MINTEMP.
// It also enables the M302 command to set the minimum extrusion temperature
// or to allow moving the extruder regardless of the hotend temperature.
// *** IT IS HIGHLY RECOMMENDED TO LEAVE THIS OPTION ENABLED! ***
#define PREVENT_COLD_EXTRUSION
#define EXTRUDE_MINTEMP 170

// This option prevents a single extrusion longer than EXTRUDE_MAXLENGTH.
// Note that for Bowden Extruders a too-small value here may prevent loading.
#define PREVENT_LENGTHY_EXTRUDE
#define EXTRUDE_MAXLENGTH 200

Tu peux les commenter en mettant // devant la ligne.

Ou si ça ne fonctionne pas, de passer la variable EXTRUDE_MINTEMP à 0 et/ou EXTRUDE_MAXLENGTH à une valeur beaucoup plus élevée par exemple.

Ne sachant pas trop laquelle des deux options te posent soucis (même si je pencherais quand même pour la 1er...
Essaye l'une ou l'autre ou les deux en même temps.


Ma Prusa i3 (ancienne imprimante, transformé en Itopie depuis)
Mon Itopie
Mon thingiverse
[TUTO] Lcd full graphic avec firmware Marlin
--
Possibilité de vous imprimer des pièces, n'hésitez pas à demander en MP
Re: Extrudeur qui ne veut rien savoir
November 13, 2018 12:57PM
Je ne trouve pas les mêmes lignes que toi, Tu es dans le fichier configuration.h ?

J'ai : #define MIN_EXTRUDER_TEMP 170
#define MAXTEMP 275

J'ai essayer de mettre "#define MIN_EXTRUDER_TEMP 0" mais rien ne se passe.
Re: Extrudeur qui ne veut rien savoir
November 13, 2018 02:40PM
Oui, c'est la même ligne.

Et si tu commentes la ligne directement, il se passe quoi ?


Ma Prusa i3 (ancienne imprimante, transformé en Itopie depuis)
Mon Itopie
Mon thingiverse
[TUTO] Lcd full graphic avec firmware Marlin
--
Possibilité de vous imprimer des pièces, n'hésitez pas à demander en MP
Re: Extrudeur qui ne veut rien savoir
November 13, 2018 03:43PM
Si je commente la ligne en mettant : //#define MIN_EXTRUDER_TEMP 170

J'ai alors le message :
exit status 1
'MIN_EXTRUDER_TEMP' was not declared in this scope

En commentant les deux lignes, j'ai ce message qui se rajoute :
'MAXTEMP' was not declared in this scope

Edited 1 time(s). Last edit at 11/13/2018 03:43PM by dinyo.
Re: Extrudeur qui ne veut rien savoir
November 13, 2018 04:40PM
Quelle version de Marlin tu utilises ?
As tu testé avec une autre ?

Parce que la, je ne sais plus...


EDIT : une chose à laquelle je viens de penser.
Que te renvois la commande M105 (à froid et à chaud) ?

Edited 1 time(s). Last edit at 11/13/2018 04:47PM by joyeufetar.


Ma Prusa i3 (ancienne imprimante, transformé en Itopie depuis)
Mon Itopie
Mon thingiverse
[TUTO] Lcd full graphic avec firmware Marlin
--
Possibilité de vous imprimer des pièces, n'hésitez pas à demander en MP
Re: Extrudeur qui ne veut rien savoir
November 13, 2018 05:48PM
Pour les versions j'utilise Arduino 1.8.7 et Repetier-Host V2.1.3.

Pour la commande M105 :
- A froid : T : 18.97 /200 B : 9.28 /55 [email protected]:255 @:255
- A chaud : T:200.58 /200 B:55.11 /55 [email protected]:0 @:0

C'est surement quelque chose de basique ou j'ai du me louper, qui fait que l'on y pense pas du tout sad smiley
Re: Extrudeur qui ne veut rien savoir
November 14, 2018 12:16PM
Tiens voila mon firmware (voir pj).
Il ne sera pas adapté pour ton imprimante, mais tu pourras tester ton extrudeur.

On saura déjà si ça vient de la.


Ma Prusa i3 (ancienne imprimante, transformé en Itopie depuis)
Mon Itopie
Mon thingiverse
[TUTO] Lcd full graphic avec firmware Marlin
--
Possibilité de vous imprimer des pièces, n'hésitez pas à demander en MP
Attachments:
open | download - Configuration.h (64.8 KB)
Re: Extrudeur qui ne veut rien savoir
November 14, 2018 01:27PM
Merci c'est gentil !

Est'ce qu'on utilise les mêmes versions ? car je n'arrive pas à compiler, à chaque fois que je corrige une erreur, une autre apparait ;(

Comment as-tu créé ton firmware ? Sur le site de Repetier? manuellement? un autre logiciel ?
Re: Extrudeur qui ne veut rien savoir
November 14, 2018 01:30PM
Euh, j'ai téléchargé le firmware, je l'ai juste modifié via un éditeur de texte et je l'ai téléversé via le logiciel arduino.

Un conseil, désactive l'écran lcd.
Le mien nécessite une librairie spécifique, je n'avais pas pensé à ça.

Je ne sais pas si on utilise la même version du firmware, je suis en "1.1.8" (visible dans le fichier "Version.h").

Quelles sont les erreurs que tu as ?


Ma Prusa i3 (ancienne imprimante, transformé en Itopie depuis)
Mon Itopie
Mon thingiverse
[TUTO] Lcd full graphic avec firmware Marlin
--
Possibilité de vous imprimer des pièces, n'hésitez pas à demander en MP
Re: Extrudeur qui ne veut rien savoir
November 14, 2018 01:50PM
Ou as-tu téléchargé le firmware? Car lorsque je regarde le tien il est clair, beaucoup plus détaillé que le mien...
Du coup je me dit que je devrais peut être essayer un autre moyen pour faire mon firmware

Il y en a beaucoup, mais elle ressemble à ça :

Configuration.h:156:12: error: missing binary operator before token "("

#if ENABLED(MK2_MULTIPLEXER)

ou

Configuration.h:944:4: error: #endif without #if

#endif

ou

gcode.h:86:14: error: #if with no expression

ou

Printer.h:157:2: error: #error No supported printer mode compiled

#error No supported printer mode compiled
Re: Extrudeur qui ne veut rien savoir
November 14, 2018 01:52PM
Humm, il est plus détaillé parce que je ne dois avoir une version plus récente de la tienne.
Je l'ai téléchargé sur le site officiel : [marlinfw.org]

Il n'y a pas 36 moyens pour le firmware, tu le télécharges, tu modifies le fichier de config et tu l'uploads sur l'arduino.
C'est tout.


Ma Prusa i3 (ancienne imprimante, transformé en Itopie depuis)
Mon Itopie
Mon thingiverse
[TUTO] Lcd full graphic avec firmware Marlin
--
Possibilité de vous imprimer des pièces, n'hésitez pas à demander en MP
Re: Extrudeur qui ne veut rien savoir
November 14, 2018 02:05PM
Bon et bien je vais tout recommencer depuis le début, j'ai du faire une ou deux boulettes je pense.

Je te retiens au courant quand j'aurai refais des essais.
Re: Extrudeur qui ne veut rien savoir
December 29, 2018 08:38AM
Bonjour,

Ces dernières semaines ont été assez mouvementées et je n'avais pas trop le temps de me remettre sur la programmation du firmware..

Mais ça y est je suis enfin de retour, et pour tout vous dire, toujours dans le même cas... sad smiley

J'ai re téléchargé le firmware, l'ai modifié en fonction de mon imprimante et ne trouve toujours pas comment activé le moteur de l'extrudeur..

Je vous le transfert en PJ, si quelqu'un pouvait le regarder ou même l'essayer, pour me dire si cela vient bien de ma programmation, et m'expliquer sur quoi j'aurai pu faire une erreur...

Bien cordialement,
Attachments:
open | download - Configuration.h (72.2 KB)
Re: Extrudeur qui ne veut rien savoir
December 29, 2018 09:29AM
Hello,

Je viens de regarder ton firmware, je n'ai rien vu qui pourrait poser problèmes.

Du coup, tu utilises quel logiciel pour contrôler l'imprimante ?
On est bien d'accord que tu chauffes l'extrudeur à au moins 170° avant de tenter de le faire bouger ?
Si tu passes directement par le lcd c'est pareil ?

++


Ma Prusa i3 (ancienne imprimante, transformé en Itopie depuis)
Mon Itopie
Mon thingiverse
[TUTO] Lcd full graphic avec firmware Marlin
--
Possibilité de vous imprimer des pièces, n'hésitez pas à demander en MP
Re: Extrudeur qui ne veut rien savoir
December 29, 2018 10:23AM
Bonjour,

Du coup, tu utilises quel logiciel pour contrôler l'imprimante ?
Pour contrôler l'imprimante j'utilise Repetier HOST

On est bien d'accord que tu chauffes l'extrudeur à au moins 170° avant de tenter de le faire bouger ?
Oui je viens de refaire des essais à 175° et il me semble en plus que dans le firmware j'ai réglé la température mini à 5°

Si tu passes directement par le lcd c'est pareil ?
Pour le LCD oui c'est pareil je n'arrive pas à faire bouger ce moteur.. sad smiley
Re: Extrudeur qui ne veut rien savoir
December 29, 2018 11:45AM
Vraiment étrange ton histoire.

Ton extrudeur ne bouge même pas un peu ?
Est ce qu'il émet un son quelconque quand tu essayes d'extruder ?
Même ne serait qu'une légère vibration suffirait à indiquer que ça fonctionne.

Tu le tests à vide ou avec un filament ?
Rien est coincé ou empêche le filament d'avancer ?

Franchement, la, je ne vois pas du tout le soucis.

Tu peux faire des photos de ton montage/branchement... ?
Et peut être même une petite vidéo pour montrer les étapes que tu suis pour essayer d'extruder ?
On a peut être loupé quelque chose...


Ma Prusa i3 (ancienne imprimante, transformé en Itopie depuis)
Mon Itopie
Mon thingiverse
[TUTO] Lcd full graphic avec firmware Marlin
--
Possibilité de vous imprimer des pièces, n'hésitez pas à demander en MP
Re: Extrudeur qui ne veut rien savoir
December 29, 2018 12:48PM
Je tiens l'axe du moteur en main et je ne sent rien du tout, ni aucun bruits.

Pour l'instant, j'avais tout mis en câblage volant donc le moteur n'est pas sur monté sur l'extrudeur, je voulais m'assurer que tout fonctionnait avant de faire les passages de câbles.
Par conséquent aucun filament n'est installé.

Je suppose que c'est une erreur toute bête, mais je ne suis pas assez calé la dedans pour la trouver tout seul sad smiley

J'ai mis des photos en PJ mais je ne sais pas si elles sont très parlantes.

En tout cas merci pour votre aide!
Attachments:
open | download - IMG_1706.jpg (112.5 KB)
open | download - IMG_1707.jpg (82.2 KB)
open | download - IMG_1708.jpg (164.3 KB)
open | download - Repetier.PNG (59.9 KB)
Re: Extrudeur qui ne veut rien savoir
December 30, 2018 06:10AM
Ah tout hasard, si tu exécutes une commande du genre :
G1 E10

Il se passe quelque chose ?


Ma Prusa i3 (ancienne imprimante, transformé en Itopie depuis)
Mon Itopie
Mon thingiverse
[TUTO] Lcd full graphic avec firmware Marlin
--
Possibilité de vous imprimer des pièces, n'hésitez pas à demander en MP
Re: Extrudeur qui ne veut rien savoir
January 02, 2019 11:53AM
Hello,

Je viens d'essayer la commande G1 E10 et non rien ne se passe.

Quelque chose devrait se passer ?
Re: Extrudeur qui ne veut rien savoir
January 02, 2019 05:50PM
Salut,

Si la température de la hotend est à au moins 170° (limite minimum du firmware), alors ça devrait extruder 10mm de filament sad smiley


Ma Prusa i3 (ancienne imprimante, transformé en Itopie depuis)
Mon Itopie
Mon thingiverse
[TUTO] Lcd full graphic avec firmware Marlin
--
Possibilité de vous imprimer des pièces, n'hésitez pas à demander en MP
Sorry, only registered users may post in this forum.

Click here to login