Welcome! Log In Create A New Profile


Reprap Host 0.9 Missing Library?

Posted by emt 
Reprap Host 0.9 Missing Library?
June 16, 2008 07:05AM

I just downloaded latest release.

This main panel appears OK running under windows but in the DOS window I see the following message:-

Exception in thread "RepRap" java.lang.NullPointerException
at javax.swing.ImageIcon.(Unknown Source)
at org.reprap.gui.botConsole.PrintTabPanel.initComponents(Unknown Source)
at org.reprap.gui.botConsole.PrintTabPanel.(Unknown Source)
at org.reprap.gui.botConsole.BotConsoleFrame.initComponents(Unknown Source)
at org.reprap.gui.botConsole.BotConsoleFrame.(Unknown Source)
at org.reprap.gui.botConsole.BotConsoleFrame$1.run(Unknown Source)
at java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)

I guess I have a library missing that is needed for full fuctionality.

Can any one tell me which library this is and where I can download it?


Re: Reprap Host 0.9 Missing Library?
June 29, 2008 01:04PM
Ian, I'm running Ubuntu, both the live Reprap DVD version, and a regular installation on my laptop, and I'm getting that exact same error. I don't know what it means, but I did find that if I run the reprap-host-0.8.3 version, as opposed to the latest 0.9 version, I don't get that error. Why, I couldn't tell you. smiling smiley

Of course, I'm still getting other errors, right now it's a RXTX exception on the 0.7 livecd, but that's another thread.


Re: Reprap Host 0.9 Missing Library?
June 30, 2008 02:46PM
Hm, I installed the entire developer chain, Eclipse, Subclipse and Netbeans, thinking I might be missing some gui icons somewhere. Now neither version of the host software will run - maybe that means I'm on the right track? smiling smiley Will keep hacking away until I discover something useful. I think nuking my linux install might be a good place to start.

Oh, and Ian, Reece mentioned in another thread that the 0.9 host needs the 1.6 version of Java, not 1.5 like the host version 0.8.3. Didn't help me, but maybe you?

Details here:


Edited 1 time(s). Last edit at 06/30/2008 03:04PM by Wade.
Sorry, only registered users may post in this forum.

Click here to login