Welcome! Log In Create A New Profile


Unable to load default SVN Client

Posted by mccoyn 
Unable to load default SVN Client
September 08, 2008 05:34PM
I'm having trouble getting the development environment set up and I wondered if anyone has seen this before. I installed subversion, java, eclipse and subclipse with no problem. When I try to add the reprap repository (or do anything with subclipse) I get an error that says "Unable to load default SVN Client".

This appears to be a version issue, so here is my versions of everything:

sun-java5-bin: 1.5.0-14-letch1
sun-java5-jdk: 1.5.0-14-letch1
sun-java5-jre: 1.5.0-14-letch1
subversion: 1.5.1dfsg1-1
subversion-toos: 1.5.1dfsg1-1
eclipse: 3.2.1-4
subclipse: 1.4.1
subversion client adapter: 1.5.1
subversion native library adapter (JavaHL) 1.5.2

Anyone know what I have to do to get this running?
See this which should hopefully explain it. Basically, you need the actual JavaHL native libraries part.


Re: Unable to load default SVN Client
September 08, 2008 11:04PM
I just found that I could only use the Subclipse 1.2.x (Eclipse 3.2+)

But since I downloaded the 1.4.x one I had to remove (by going to software updates> manage configuration) the 1.4.x and install the 1.2.x which broke my svn browser screen now?

Oh I am using Ubuntu 8.10

Bruce Wattendorf
Re: Unable to load default SVN Client
September 09, 2008 11:32AM
I am using etch and had the same problems using Subclipse 1.4.x and 1.2.x .

I was wondering about the java-gcj message when starting eclipse from gnome-terminal, so I removed




and it worked.

If this doesn't work with your machine, tell me, there are some more things I tried before.

Edited 2 time(s). Last edit at 09/09/2008 12:21PM by uplift.
Re: Unable to load default SVN Client
September 09, 2008 07:10PM
I have now downloaded eclipse 3.4.0, no configuration changes necessary. It changed the view of the etch-eclipse 3.2.1 version but SVN browsing is still

possible, in both versions.

Also with eclipse > 3.3.x you will meet AVRDude if you install the AVR plugin, a really nice guy smiling smiley

Edited 1 time(s). Last edit at 09/09/2008 07:13PM by uplift.
Re: Unable to load default SVN Client
September 30, 2008 08:02PM
Sorry about not responding earlier. I got it working. I had to go into the software configuration in Eclipse and disable and uninstall anything with JavaHL or SVNKit in the name. Then I was able to install the right SVNKit (or JavaHL, I suppose).
Have you tried downloading SVNKit from the update site of Subclipse?

Go to Install New Software and select the Subclipse update site. Select the JNA and SVNKit library as well as the SVNKit Client Adapter.

After, change the interface from JavaHL to SVNKit in the Preferences → Team → SVN → SVN Interface.
Sorry, only registered users may post in this forum.

Click here to login