Welcome! Log In Create A New Profile


OSX 10.5 Software startup issues

Posted by robacarp 
OSX 10.5 Software startup issues
September 23, 2008 08:30PM
Hi! I am trying to install the reprap host software on my Intel mac and am apparently having some difficulty.

I followed the directions [www.reprap.org]
and I am getting the following error message in a popup window. If I start the program from a terminal it also comes out there, along with a stack dump. I can post the stack dump if you want.

Could not connect at /dev/ttyS0.

Check to make sure that is the right path.
Check that you have your serial connector plugged in.The program will continue but your geometry preference has been set to 'nullcartesian' for this session.

The only part of the installation instructions that I had to "make up" on my way was in installing the RxTx library. After ./configuring, patching, and make-ing it I was left with no librxtxSerial.jnilib file. I poked around in the project files for the various IDEs that are included and found a copy of it and put in the correct location...but I cannot verify that it is the correct file.

Any ideas? I searched the forums for an exact phrase match to "Could not connect at /dev/ttyS0" and no results came up. Also searching for "10.5" and "Leopard" produced nothing of consequence if anything at all.

Am I seriously the first mac user in here? Or am I just the first with problems?
Anonymous User
Re: OSX 10.5 Software startup issues
September 24, 2008 10:49AM

Try looking here:


You need to locate the reprap.properties file and edit the port address. If you don't have an arduino attached you'll still get this error.
Re: OSX 10.5 Software startup issues
September 25, 2008 01:46AM
Okay! making progress .... some anyways.

fool: Thanks for your reply and the link...and I now see the "search within last 30 days" dropdown -- an odd restriction to be the default.

Some poking around and the OS X "reprap.properties" file is located at ~/.reprap/reprap.properties .

In order to find the correct port name I plugged in my Arduino board and ran `ls /dev | grep tty.u`, removed the usb cable and ran it again....my port name is actually: tty.usbserial-FTALE4VO

After pulling that into the properties file I was getting the error "port is already in use by another program" which a quick non-date-restrictive search produced a need to create a directory /var/lock, with user write permissions:

$ cd /var
$ sudo mkdir lock
$ sudo chown username lock

And now the program doesn't do anything....stack trace:

Exception in thread "AWT-EventQueue-0" java.lang.NoClassDefFoundError: javax/swing/GroupLayout$Group
at org.reprap.Main$22.run(Unknown Source)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:461)
at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:269)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:184)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:176)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)

The program just sits there doing nothing except taking up memory. It doesn't freeze, thankfully, but apparently the window toolkit is missing a class definition for GroupLayout.Group (if I remember my Java correctly).

Now this guy [forums.reprap.org] said that changing the order of the JRE in Java preferences worked for him. Not for me...I don't have a "Java 1.6" in my list. You may be thinking...install the newest Java. But its done. Software Update did it for me earlier today and I double checked by reinstalling it just now. My options are:

* J2SE 5.0 32-bit
* Java SE 6 64-bit
* J2SE 5.0 64-bit
* J2SE 1.4.2 32-bit

Which I rearranged the list and attempted to run the software for each of these being on top.

Any ideas?
Anonymous User
Re: OSX 10.5 Software startup issues
September 25, 2008 05:22AM
There's this available:


...but it appears to be for 64 bit only. Any use?
Re: OSX 10.5 Software startup issues
September 25, 2008 11:06AM
That is the package that was installed yesterday over software update and again later by me.

Thanks...good try though
Re: OSX 10.5 Software startup issues
September 29, 2008 06:18AM
I'm not sure but it seems like Java 6 isn't being used to run RepRap on your system, even when 'Java Preferences' are set to jdk1.6. AFAIK all the 'Java Preference' tool does is change a link, /Library/Java/Home, to point to a different version's install location. This only works if the /Library path is used everywhere, anything that uses a path to a specific JDK won't be effected by the link changing. In SVN there are two OSX startup scripts;
The leopard script explicitly sets JAVA_HOME to the 1.6 version which should ensure the right JDK is used.


export JAVA_HOME=/System/Library/Frameworks/JavaVM.framework/Versions/1.6/Home
export PATH=$JAVA_HOME/bin:$PATH
java -jar jar/reprap.jar
Re: OSX 10.5 Software startup issues
October 01, 2008 09:05AM
Also note that you're pretty much on your own if you use a 64-bit JVM since the 64-bit support on the RxTx library is a bit flaky. Have a look at the rxtx mailing list for more information.
I haven't tested this in a while though since we're only using the GCode pipeline atm., so the 64-bit support might have improved lately.

~/= Marius

We are Elektropeople for a better living.
Re: OSX 10.5 Software startup issues
October 01, 2008 10:32AM

Thanks for the script. I'd just about given up on this thread, and besides that I have been busy with the stepper motors I just got in the mail. It does seem to change the way the program runs.


Sweet...thanks. Unfortunately Apple is not doing a 32-bit JVM 1.6...ever. I am now, thanks to peteredworthy's pointer, getting some rxtx errors. I'll look at the mailing list as you suggest. Thanks.


Is it wrong to just give up on this java package and write my own software?

Robert Carpenter
Re: OSX 10.5 Software startup issues
October 01, 2008 11:17AM
No, it is NOT wrong to give up on the java package and write your own software.

In fact, this has already been done. Search for Enrique's fine "skienforge" software. Written in python, it does almost everything the host software does. More in several cases. And all without the JVM headaches. Are you using the Arduino? If so, it's (almost) plug and play - you can use my send.py as both a "jog" interface and to print. If you're using the older PIC electronics, they don't understande G-Code, and I'm not at all sure how solid the python support for SNAP is. I know somebody wrote a python SNAP library, but I don't think it's integrated at all into skienforge.

I'm building it with Baling Wire
Re: OSX 10.5 Software startup issues
October 01, 2008 11:46AM
John Gilmore
[...]without all the JVM headaches

So as to avoid defacing the public forums, my rant on the subject of Java is posted here: [robertcarpenter.net]

Edit: I am using the Gen 2 electronics...a Sanguino to be specific.

Edited 1 time(s). Last edit at 10/01/2008 11:47AM by Robert L. Carpenter.

Robert Carpenter
Sorry, only registered users may post in this forum.

Click here to login