Welcome! Log In Create A New Profile


PIC Extruder Firmware and communication errors

Posted by peteredworthy 
PIC Extruder Firmware and communication errors
January 15, 2009 08:10PM
I'm finally getting there. I have working X,Y,Z Bot, thanks to Bits from Bytes and the RepRap Research Foundation, but I just can't seem to get the extruder board/firmware to work.

If the extruder board is included in the comms chain then the v1.0 reprap host software outputs 'sendMessage error - retrying' repeatedly.

I've tried;
- linking only the extruder board and the I/O board
- flashing the PIC with version 1.1 and 1.2 from sourceforge and 1.2 from the SVN of extruder0.hex firmware.
- swapping the PIC into one of the stepper driver boards
- burning the firmware onto a different PIC
all with no change.

None of the obvious comms faults produce this message, e.g. if there is a break in the ring or the connectors are the wrong way around then the host just hangs with no error message.

Both LEDs on the comms board flicker so it seems something is being returned.

With a stepper board PIC in the extruder board the host starts normally. While testing this setup the stepper board that the chip was borrowed from was removed from the comms chain. Swapping the extruder firmware PIC back into the board and making no other changes the error messages return.

My next thought was that it might be a problem with a lack of input's, but I added jumpers on the min and max connections as well as a 100k resistor on the thermistor connector with no change. I also checked the size of the capacitor in the temp sense circuit, 4.7nF, which seems like it should be OK.

Possible factors are:

It was working with some nondescript version of the firmware that I foolishly overwrote without backing up and so I can't test if it would still work. The multiple versions tried seem to rule out a corrupt file though.

At the same time as the re-flash I replaced the TIP-110 in Alt-2 (for the cooling fan). The previous one was knocked and straightened one too many times and snapped a pin. That the stepper firmware communicates fine when used on the board seems to rule out a problem with the board. In case it was something to do with this I cut the wire linking the new TIP-110 to the seven pin connector but it made no difference to the error messages.

I'm at a loss as to what more to try, any ideas anyone?
Re: PIC Extruder Firmware and communication errors
January 16, 2009 04:06AM
4.7nF is way too small, IIRC 220nF is the best value. I don't know whether that would stop the board from working.

Re: PIC Extruder Firmware and communication errors
January 26, 2009 05:51PM
I've finally solved it! after bread boarding an extruder and power & comms board with no components in common and still having the same errors.

It was the power supply, I don't know why it only effected the extruder but there was a 600mv ripple at 145kHz on the power line even after the filter caps and the 7805.
Sorry, only registered users may post in this forum.

Click here to login