Welcome! Log In Create A New Profile


Firmware WONT compile!!

Posted by chuck 
Firmware WONT compile!!
April 09, 2009 09:08PM
Hi all,

Im new to the game and getting hung up on loading up the firmware to my arduino. I have versions 13, 14, and 15 of the arduino environment. No matter what I do, or which computer I load it on,,,I cannot get ANY of the arduino snap or gcode firmwares to compile so i can upload it to the arduino.

The arduino works fine when i upload the sample stepper codes and such, but ive tried this on 2 different computers running Windows XP SP 3 32BIT and Vista 64BIT. I cannot for the life of me figure out what the problem is. My latest compiling error tells me this string::

error: 'char word[128]' redeclared as different kind of symbol::

#include "reprap_new_firmware.h"

#define COMMAND_SIZE 128
char word[COMMAND_SIZE]; <-------------THIS IS HIGHLIGHTED?????
byte serial_count;
int no_data = 0;
long idle_time;
boolean comment = false;
boolean bytes_received = false;

Ive also tried having someone send me their known working firmware and its still not compiling for me. Is there a special installation instruction that im missing? This is been going on now for 7 days straight and im getting super frustrated, but im sure its just a small parameter somewhere that is incorrect. Someone please help me troubleshoot this....Thanks

Re: Firmware WONT compile!!
April 10, 2009 12:34AM
Did you try the Arduino IDE version 0012 that I mentioned in your last thread? Since they added a "word" function or something (I'm no great programmer) in version 0013, it looks like all the versions after 0012 will not work with the code I sent you.


Edited 1 time(s). Last edit at 04/10/2009 01:07AM by Wade Bortz.
Re: Firmware WONT compile!!
April 10, 2009 02:33AM
Just replace all the occurrences of "word" in the RepRap code with something else, like "Word" and you will be fine.

Re: Firmware WONT compile!!
April 11, 2009 11:06AM
Thanks for the replies...

Sorry forgot to add that one in the last post. Yes, Tried 012 and still the same thing. It seems like now im getting errors with the compiler. When i try to compile the new firmware, first it doesnt have an option to select the arduino duemilanove board in the options menu so i pick the diecimilia. Could this be the start of a problem??

Then, It gives me an error on compiling saying that its looking for new_reprap_firmware.HEX <---- I cannot find a file like this anywhere. Could the problem be with my version of the AVR? and if so, can someone walk me through upgrading or changing the AVR software?

Also, tried replacing the charword thingies to no avail. Thanks for the help

Re: Firmware WONT compile!!
April 12, 2009 10:52PM
Is it possible to talk to someone in person about this issue? If anyone is willing, I would just need about 10 minutes of your time to help me troubleshoot. Please help, its been over a week now since ive finished construction and still cant figure this firmware problem out to start using the machine.

Thanks in advance for any help on this matter.

Re: Firmware WONT compile!!
April 12, 2009 11:53PM
Try emailing me off list at wbortz at gmail. I can skype you sometime, we just have to sort out the time zones.

Re: Firmware WONT compile!!
April 15, 2009 11:33PM

I got a firmware to compile correctly!!!! I believe it is the original G code interpreter file. Got it to compile on version 015 of the IDE. Now im on to my next task, which I'll start a new thread for ....but basically its now how to use the software to use my repstrap as a mill instead of an extruder based machine. Thanks everyone for the help

Sorry, only registered users may post in this forum.

Click here to login