Welcome! Log In Create A New Profile


Skienforge has errors analyzing models created in 3ds Max

Posted by Nadir 
I have been trying to fix up a character model so it is sutible for printing it seems no matter what I export from 3ds max the analyzer just spits errors back at me. I tried just loading in a just a cube I exported to STL and OBJ from max and I get the same errors as I get from the character pieces.

Here is what it prints out:

Skeinforge preferences have been saved.
File C:/Users/HAL/Desktop//Printing/Cube.STL is being chain exported.
Exception in Tkinter callback
Traceback (most recent call last):
File "C:\Python26\lib\lib-tk\Tkinter.py", line 1410, in __call__
return self.func(*args)
File "C:\Users\HAL\Desktop\Printing\skeinforge_tools
\skeinforge_utilities\preferences.py", line 1471, in execute
File "C:\Users\HAL\Desktop\Printing\skeinforge.py",
line 324, in execute
writeOutput( fileName )
File "C:\Users\HAL\Desktop\\Printing\skeinforge.py",
line 296, in writeOutput
craft.writeOutput( fileName )
File "C:\Users\HAL\Desktop\Printing\skeinforge_tools
\craft.py", line 38, in writeOutput
pluginModule.writeOutput( fileName )
File "C:\Users\HAL\Desktop\Printing\skeinforge_tools
\craft_plugins\export.py", line 144, in writeOutput
gcodeText = consecution.getChainTextFromProcedures( fileName, procedures[ :
- 1 ], gcodeText )
File "C:\Users\HAL\Desktop\Printing\skeinforge_tools
\skeinforge_utilities\consecution.py", line 38, in getChainTextFromProcedures
text = craftModule.getCraftedText( fileName, text )
File "C:\Users\HAL\Desktop\Printing\skeinforge_tools
\craft_plugins\preface.py", line 88, in getCraftedText
return getCraftedTextFromText( gcodec.getTextIfEmpty( fileName, text ), pref
acePreferences )
File "C:\Users\HAL\Desktop\Printing\skeinforge_tools
\craft_plugins\preface.py", line 96, in getCraftedTextFromText
return PrefaceSkein().getCraftedGcode( prefacePreferences, text )
File "C:\Users\HAL\Desktop\Printing\skeinforge_tools
\craft_plugins\preface.py", line 277, in getCraftedGcode
File "C:\Users\HAL\Desktop\\Printing\skeinforge_tools
\craft_plugins\preface.py", line 200, in addInitializationToOutput
self.distanceFeedRate.addTagBracketedLine( 'layerThickness', self.distanceFe
edRate.getRounded( self.layerThickness ) )
AttributeError: PrefaceSkein instance has no attribute 'layerThickness'

I am not a programmer so I am not sure what this is telling me is wrong. I tried importing the models into blender and then exporting again in case it was the exporter (Once again I tried STL and OBJ) but I still get the same errors.

So it seems to me that any model that originates from my copy of 3ds 2009 produces these errors. Does anyone know what the problem is and how I could fix it?
Re: Skienforge has errors analyzing models created in 3ds Max
October 17, 2009 11:20PM
If you email me your model and preferences, I will look at it.

In general, if anyone has a bug, please email your model file and zipped skeinforge preferences.


Edited 1 time(s). Last edit at 10/17/2009 11:25PM by Enrique.
Re: Skienforge has errors analyzing models created in 3ds Max
October 18, 2009 04:36PM
Hi Nadir,

... have you converted your model to triangulated surface (so any polygon is cut into aligned triangles)?

AFAIK this was a common Error when exporting from programs like Lightwave or older 3DSMax versions ...

Re: Skienforge has errors analyzing models created in 3ds Max
April 27, 2010 12:21AM
I had this same error message when the bottom face of a model was really close to zero. Moving it down a tiny bit fixed the error.
Re: Skienforge has errors analyzing models created in 3ds Max
April 28, 2010 06:31PM
Did you check the model in Netfabb?

* homeprototype free 3d design repository
* Blog
* Google+
Sorry, only registered users may post in this forum.

Click here to login