Welcome! Log In Create A New Profile


Live CD

Posted by reece.arnott 
Re: Live CD
December 13, 2007 03:33AM
Oh dear, can you say scope creep :-)

I don't mind though. The way I figure it, for a wee while to come the LiveCD will be a good vehicle to 'get the message out there'. At least until we have a Darwin in every city. As such I want it to make a good impression and be immediately useful in some way for everybody.

I'm going to be flat out with work and family for the next month, so I won't be actively doing much reprap stuff for a while. After that my first priority is probably going to be shopping for another ISP who can give me more bandwidth for my buck. Then I'll be working on the next version of the LiveCD (whatever that happens to based on) and hopefully finishing off my own Darwin with the molded parts.

All of which is a long winded way of saying 'thanks for the input and feedback. Keep it up, I do appreciate it and any help would be great'.
Re: Live CD
December 13, 2007 03:59AM
A quick way to zip up the source folders is with the following for loop:

for folder in $(ls -1); do zip -r $folder.zip $folder;done

Note that this will break if the folder names have spaces in them but the ones for the downloaded source folders won't.
Re: Live CD
December 14, 2007 11:26PM
Interesting issue - I have had my bit torrent up with the 0.4 version available and not one (1) byte downloaded. Just thought it was interesting.

Bob Teeter
Re: Live CD
December 15, 2007 11:57AM
Ok - about 12 hours later and I have uploaded 150Kb. Well its a start I guess.

Bob Teeter
"What Box?"
Re: Live CD
December 15, 2007 03:27PM
~~Robert Teeter

I Started downloading about 3 hours ago, and I'm at 369 MB downloaded at about 20 kb/s, so I think that the problem is on your end.

Re: Live CD
December 16, 2007 04:12PM
I've been seeding a while now. Uploaded quite a bit. Has to be RTs end.

Re: Live CD
December 16, 2007 04:25PM
Guys It could be on my end. It also could be which seed is being used. But my meter is setting at 310Kb and has not changed in 24 hours. O well. By the way my download speed is 5Mb and upload speed 1.5Mb so I don't think that it is speed related.

Bob Teeter
"What Box?"
Re: Live CD
December 16, 2007 06:05PM
You might not have your firewall/etc opened correctly for the port... I've used BT in the past for other stuff, so I've already gone through that headache...

I've also got a great cable connection... so I've got a 100kB/s software limit, and I've shared it just under 7 times... 1.5 is nice and all, but I can saturate a lot of people's download bandwidth just by myself... (and it's always nice when you've got a 100% legit reason to use all that bandwidth!)
Re: Live CD
December 16, 2007 06:48PM
Oh I know I have my side set up correctly. Because I routinely download and upload fedora linux and such. So just as long as those that what a copy of the disk can get it I am not going to worry about. Thanks for the help.

Bob Teeter
"What Box?"
Re: Live CD
December 18, 2007 10:00PM
I have been seeding for a couple of days, but i don't think that it is really doing anything. Any tips on how i could find out exactly what it is doing and/or to make it actually start seeding?

Re: Live CD
December 18, 2007 10:15PM
I suspect that people aren't downloading it. After all, the demand should be pretty slight. We aren't a huge community...YET!

Re: Live CD
December 19, 2007 05:06PM
OK, so if it says its seeding, than it most likely is? In any case, I have a dedicated computer for just downloading, cus thats just about all it can handle. Can anyone say 8Mb Graphics card?

Re: Live CD
January 08, 2008 02:30PM
I'm a little confused as what we can use this live CD for. I just installed Ubuntu 7.10 and it works good. I was about to install all the java stuff that I would need such as J3D when I remembered this thread. Will the live CD automate the installation of all those files for me or will it require me to install the entire Operating System and wipe out my existing system.

I'm new to linux and would really just like a package(batch file) that automatically downloads JRE and JDK with J3D and the RS232 dependency that is needed along with maybe Eclipse. Is something like that possible?
Re: Live CD
January 08, 2008 03:28PM
I don't really have much experience in linux or with java, but when I installed off of the LiveCD, all of the reprap software was there installed for me.

Re: Live CD
January 09, 2008 01:12AM
Short answer is the live CD will *not* automate the installation of all those files , it *will* install the entire Operating System but this can be done without wiping out your existing system. It just makes another option in the boot loader.

It is a full install of Ubuntu 7.04 along with all the Reprap stuff. If you elect to install it, it is a full operating system in its own right. If you don't have the additional free space and don't want to lose what you've got, you just run off the CD and don't install it.

Edited 1 time(s). Last edit at 01/09/2008 03:52AM by reece.arnott.
Re: Live CD
January 09, 2008 04:36PM
Oh, I see what I did. Sorry for the confusion. I copy and pasted the software off of my flash drive and it worked.

Re: Live CD
January 16, 2008 05:07PM
Hi Reece,

I'm the other half of BitsFromBytes with Ian Adkins. I've got your live CD and it boots fine on our main machines but we have tried without success to get it onto older, more suitable for workshop environment :-P machines. The machine I have tried is using a Pentium III processor with 256MB of RAM.
The behaviour I see is that the CD boots and I choose the first option which is to start/install. A number of checks run and I see the error 'Failed to reset NO_REBOOT flag' and/or 'FWH not detected'. Then, at the end of the tests, it goes to a blank screen and nothing further happens (at least until my patience runs out after about 4 mins).
As I say my newer machine and Ian's both cope fine and we get in without issue. Is there something we're missing here? I've had a quick look on the UBUNTU forums but, although I can find both errors, I can't see any quick solutions.

Many thanks,

Re: Live CD
January 17, 2008 04:35AM
The errors you're getting seem to imply that its choking on your specific hardware (also implied by it working on another machine of course).

A quick Google shows this known bug report: [bugs.launchpad.net]

It appears to also go hand in hand with long delays in boot up.

Root cause from that link seems to be Intel Network cards, especially wireless ones.

If your (wireless) network card isn't an integrated one, just take it out and see if it boots. If you have wireless, go into the BIOS/flick the switch to disable it if its enabled and enable it if its disabled.

There is also a known issue where instead of the Ubuntu logo and loading bar appearing there is a blank screen until its finished. So, maybe you just need to be more patient :-) I'd just leave it for 30 minutes and go and do something else to make sure its not booting. Sometimes the blank screen is fixed by changing the monitor but normally its related to the graphics card. In your case of course, thats a minor hassle...

The only other solution I can think of is to modify the LiveCD yourself in line with some of the instructions on the linked page but I wouldn't recommend it unless its *really* bothering you.

If you want to, all you need to do is apparently add the line "blacklist intel_rng" to the end of the file /etc/modprobe.d/blacklist (this is also a note for me in the future).

When I make the next version I'll put in all the latest updates (rather than leave it with 8 months worth of bugs and security holes :-) and hopefully it will go away.

If you can't fix it, could you make a point of testing the next version and seeing if it has the same issue? If it does I'll look into putting this workaround in.

I'm not sure at the moment exactly what this will stop but according to [www.linuxquestions.org]
this is 'Intel

Edited 2 time(s). Last edit at 01/17/2008 04:43AM by reece.arnott.
Re: Live CD
January 17, 2008 04:44AM
The blank screen sometimes happens when linux goes from a text terminal to xwindows during boot, but then has trouble with your video card. I've also had one machine that blacks out shortly after booting when it gets to the linux framebuffer:
but then gets into xwindows without problems.

Try mucking around with the boot options:

BootOptions - Community Ubuntu Documentation

You may find it useful to download and burn a knoppix cd and see if the machine chokes on that, and if it manages to boot using knoppix "failsafe" mode.

Cheat Codes - Knoppix Documentation Wiki

Edited 1 time(s). Last edit at 01/17/2008 05:43AM by SebastienBailard.
Re: Live CD
January 19, 2008 03:21PM
Hi Reece / Sebastien,

I took out the graphics card and network card (it wasn't / isn't wireless enabled) and plugged the VGA cable into the on-board graphics and now it works. Not sure what the issue was but I'm over it.

Just for completeness the observed behaviour in more detail was that I would load the cd, select option 1 to load / install and after seeing the Ubuntu logo and progress bar I would get a series of install time messages which went through about 4 or 5 including as the last positive one 'Loading hardware drivers' followed by 'xxx.xxxxxx TCO_wdt: failed to reset NO_REBOOT flag, reboot disabled by hardware.' (where x is a digit). There was also another error 'xxx.xxxxxx intel-rng: FWH not detected'. Finally I would see a load more diagnostics output including the line beginning 'Starting common UNIX' and it would instantly flip to a blank screen which I left for 2 hours without any progression.

As I type the other machine has been setting up and comes up with an error 'There was an error starting the GNOME Settings Daemon ... The last error message was: ... Did not receive a reply ...' I'm not sure what this is but other than this it appears to be working.

Thanks - I'm off to deliver the machine to Ian's workshop!

Sorry, only registered users may post in this forum.

Click here to login