Something isn't working. Help? -SOLVED-
March 02, 2011 01:06AM
I'm VERY new to this whole thing so please bear with me.

I just got the reprap host working tonight for the first time, after many fights between win 7 and java.

I keep getting the "container in a container' error on startup but have been just ignoring it since once I click ok everything seems to load fine.


I'm running teacup on an Arduino Pro Mini (atmega 328) with a pololu style stepper driver. I've tested the driver in the arduino environment and it works fine. I only have one driver hooked up at the moment


Moving along...

When in the host software, I try to do an axis move but nothing happens. I do not see the serial indicator lights on the arduino light up, and the debug window returns " horizontal move to a non running output buffer ."

I've made sure the software and teacup are configured for 56700 baud, and the correct atmega chip is specified in teacup. Also, the step pin for the driver is correctly set to and attached to analog 0.


Any suggestions?

Thanks.

Edited 1 time(s). Last edit at 03/03/2011 12:54PM by Andrew Diehl.
Re: Something isn't working. Help?
March 02, 2011 12:11PM
Ok. I did not have the com port correctly set in preferences and apparently the 'container in container' error was more of a problem than previously thought.

I've moved to a different (simpler) computer, and have the comm port set correctly now.


Now I run the host, and the command prompt opens, lights blink on the serial connection, but It never opens all the way to the GUI. This is all I get:

[i211.photobucket.com]

What am I doing wrong now ?
Re: Something isn't working. Help?
March 03, 2011 03:43AM
The output looks fine so far. What happens then? Nothing?

Looking at Teacup's code, it doesn't match the behaviour of M110 described at [reprap.org] . Just fixed that, please do a "git pull".


Generation 7 Electronics Teacup Firmware RepRap DIY
     
Re: Something isn't working. Help? -SOLVED-
March 03, 2011 12:56PM
I learned the program baud rate is NOT THE SAME as the baud rate used to communicate between Host and Teacup. 115200 is the correct setting in host.
Sorry, only registered users may post in this forum.

Click here to login